Gargoyle 1.11.0 Release Candidate 1

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

lceron80
Posts: 113
Joined: Sun Jul 24, 2011 3:42 pm

Re: Gargoyle 1.11.0 Release Candidate 1

Post by lceron80 »

Lantis wrote:All DFS channels require the router to scan for interference for 60 seconds before actually broadcasting on the channel.
Set it and wait, or don't use DFS.
thanks for the info Lantis, i tried your suggestion but that did not work. maybe i have too much interference because i live in an apt building but not really because channels 36,44 are fine. i'll try to load openwrt to see if it has the same issues there.

i also noticed that usb3 doesn't work, it could be that my usb stick ins't being recognized.

i also noticed that the fan does not stop spinning, i left the router on for about 24 hrs and it did not stop.
1x wndr3700v4 exp. 1.9.x
1x wndr3800 exp. 1.9.x
1x wndr4300v1 exp. 1.9.x
1x wndrmacv2 exp. 1.9.x

Lantis
Moderator
Posts: 5887
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle 1.11.0 Release Candidate 1

Post by Lantis »

When I say interference, I mean radar interference, not other networks.
I’d recommend reading about DFS if you want to understand what you’re getting yourself into by using those channels.

Can you try installing kmod-usb-storage-uas from the CLI and see if your device begins to function? You might need to reboot afterwards.

A reboot should fix the fan issue, although I’d recommend just switching to a proper fan script
http://lantisproject.com/gargoyle_mvebu ... _daemon.sh
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

fifonik
Posts: 113
Joined: Fri Dec 02, 2016 3:52 am
Location: Brisbane, AU

Re: Gargoyle 1.11.0 Release Candidate 1

Post by fifonik »

Installed over 1.10 on Linksys WRT1200AC.

Have not found any issues yet (quotas issue from latest ispy build is resolved).

Many thanks.

rseiler
Posts: 198
Joined: Sun Dec 15, 2013 12:31 am

Re: Gargoyle 1.11.0 Release Candidate 1

Post by rseiler »

I can't look into this now, but this is something that I've never encountered before with the Email plugin. It's as if sendmail isn't there.

https://i.imgur.com/ldVx6Vg.jpg

Lantis
Moderator
Posts: 5887
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle 1.11.0 Release Candidate 1

Post by Lantis »

rseiler wrote:I can't look into this now, but this is something that I've never encountered before with the Email plugin. It's as if sendmail isn't there.

https://i.imgur.com/ldVx6Vg.jpg
Umm, bugger. Think that’s my fault.
Can you check if /usr/bin/msmtp exists? If so, try replacing the call to “sendmail” with “msmtp”.
If that works as expected, I’ll go ahead and make the fix.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

doug_porsche
Posts: 75
Joined: Fri Aug 16, 2013 3:59 pm

Re: Gargoyle 1.11.0 Release Candidate 1

Post by doug_porsche »

Probably been talked about, but.

Guest network does not find any DNS.
It will let me connect to my guest network, just no DNS, so useless.
NETGEAR WNDR3700v4 or an old Soup can with string. So hard to tell these days.

phgerin
Posts: 118
Joined: Sun Dec 21, 2014 2:03 pm

Re: Gargoyle 1.11.0 Release Candidate 1

Post by phgerin »

Works great for me, thanks for all the work :-)

rseiler
Posts: 198
Joined: Sun Dec 15, 2013 12:31 am

Re: Gargoyle 1.11.0 Release Candidate 1

Post by rseiler »

Lantis wrote:
rseiler wrote: Can you check if /usr/bin/msmtp exists? If so, try replacing the call to “sendmail” with “msmtp”.
If that works as expected, I’ll go ahead and make the fix.
It's there, and that symlink points to the same place as before (I checked a 1.10 router), but it results in this:
https://i.imgur.com/7z9h8DF.jpg

It points to this, as before:
/plugin_root/usr/bin/msmtp

I see that /usr/sbin/sendmail (in 1.10) points to /usr/bin/msmtp, which in turn points to /plugin_root/usr/bin/msmtp as now, so I'm not sure why it wouldn't work. Maybe something I'm doing.

BTW, /usr/sbin contains 9 fewer items in it than in 1.10, so this may turn up for other things too (no idea if they should be there or not now though). Examples: telnetd, rmmod, modprobe, modinfo, lsmod.

Lantis
Moderator
Posts: 5887
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle 1.11.0 Release Candidate 1

Post by Lantis »

Broken pipe is ok. So did it actually function sending the email?
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Lantis
Moderator
Posts: 5887
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle 1.11.0 Release Candidate 1

Post by Lantis »

doug_porsche wrote:Probably been talked about, but.

Guest network does not find any DNS.
It will let me connect to my guest network, just no DNS, so useless.
Is your DNS not hosted on the router, but another device?
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Post Reply