[TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

Lantis
Moderator
Posts: 5528
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Post by Lantis »

I don’t know how you could know that given that the threat vector has not been revealed.
It is likely pointing to a vulnerability coupled with not changing default passwords. As Gargoyle enforces the changing of the default password on boot, this bit should be inherently secured.

If you are really worried.
Reset to factory. Sysupgrade a new version without keeping settings. Set it up new.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

User avatar
apvm
Posts: 100
Joined: Thu Apr 30, 2015 7:30 am

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Post by apvm »

How stable is it for a ac1900 v2? TIA

Rog66
Posts: 206
Joined: Fri Jan 04, 2013 4:53 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Post by Rog66 »

Have upgraded to WRT32X and been a little disappointed to find that wifi coverage is slightly worse than my WRT1900ACS but the v10 spectrum analyser doesn't work on the WRT32X - all the signals show 0dB - I assume there are no V11 plugins yet - is that correct?

Lantis
Moderator
Posts: 5528
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Post by Lantis »

No signal levels being reported is a problem with the new wifi driver.
I have asked the dev to look into it, but it is very low on his priority list.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

smyr
Posts: 17
Joined: Thu May 30, 2013 11:17 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Post by smyr »

Hello

Finally Gargoyle if available for Linksys routers so now I am really happy since its the number one custom firmware that I enjoy the most... here's my specs:

Code: Select all

Device Name:WRT1900ACS
Gargoyle Version:1.11.X (Built 20180704-1216 git@b7ff2a39)
Model:Linksys WRT1900ACv2
Device Configuration:Gateway
Memory Usage:47.8MB / 498.9MB (9.5%)
Swap Memory Usage:0MB / 3748.9MB (0%)
Connections:48/4096
CPU Load Averages:0.01 / 0.05 / 0.01 (1/5/15 minutes)
CPU Temperature:79 °C
RAM Temperature:50 °C
Wifi Temperature:48 °C


I used this to upgrade:
gargoyle_1.9.x-mvebu-armada-385-linksys-shelby-squashfs-sysupgrade (10kb)

I also noticed (cant remember where exatly sorry) some files called:
openwrt-18.06.0-mvebu-cortexa9-linksys-wrt1900acv2-squashfs-sysupgrade (4kb)

It is a v2 so I dont know why device name says different. Is the temperature ok really? I did not change any settings, its default at max...

And last and most important: Where are the plugins? Or should I say correct url's? Damn I hate the white theme, want it to be dark.

I also have a TP-Link TL-WR1043N/ND v2 running latest firmware (1.10.X (Built 20180324-0955 git@68ce297) and using it as a usb tethering device only same as with the Linksys and works perfect! Can I copy the plugin links from the TP link router or is this a bug and will be fixed and/or what can I do to fix it!?

Thanks
/smyr
Netgear R85000 - Netgear original firmware
Linksys WRT1900ACv2 - Gargoyle 1.11.X
TP-Link TL-WR1043N/ND v2 - Gargoyle 1.10.X
ASUS RT-AC66U - Merlin LTS 374.43_2
Netgear R7000 - Lede/Openwrt 18.06.0

Lantis
Moderator
Posts: 5528
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Post by Lantis »

1. If you have a WRT1900ACv2, then you should use that image file. It looks like you tried to use a Shelby image which is intended for WRT1900ACS. That would explain the wrong device name.
Between 1.10.x and 1.11.x we moved from using Linksys codenames (mamba, cobra, Shelby etc) to using the model names.
If you flashed the wrong image, I strongly advise you return to OEM firmware and start fresh using the right image. Please take better care in future as it is a mistake that you cannot always recover from.

2. Openwrt files are not Gargoyle files, I don’t understand why you have listed this. Also I don’t see how you could use a 1.9.x image to get to 1.11.x

3. Temperature is fine

4. 1.11.x is a testing/beta build. Plugins are provided in the torrent download so you can deploy them yourself. They will be available from official locations when 1.11.0 is officially released.

5. You should not copy packages between architectures. While it will probably work for some packages (like themes) it is ill advised.

6. You should use the LATEST 1.11.x beta if you’re going to stick with this branch
viewtopic.php?f=14&t=11711
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

smyr
Posts: 17
Joined: Thu May 30, 2013 11:17 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Post by smyr »

Well actually I have none of the devices listed.. i have the WRT1900ACS v2.... now I will for sure go back to oem and do it the right way. Just to be clear the when I have gone back to the OEM I should look for the name wrt1900ACSv2, correct.

And the mamba, cobra9, openwrt thing was for the R7000 router. Sorry for the confusion.... but isnt gargoyle based on openwrt?? Oh well...

Regarding the temp is there anything I can do to lower it? Lower the transmission power, put a fan onto the router itself (cpu cooler,... lol). Turn off wifi? The power adapter is 0.5 amps to high also... its 12v, 3.5 amps. Should be 12v, 3 amp. Guess I could try a 12v, 2.0 amp and see if it works.

I went from dd-wrt to gargoyle btw...

Ok thanks. I know how easy it is to brick a router, so will be more careful next time.

Also... compared to the Netgear R7000 and the Linksys the R7000 always seems to be everyones first pick... maybe wrong place to ask but any idea why? My guess is the hardware but have not done any real tests between them.

My main router is btw the Netgear R8500 but I keep the original Netgear firmware on it coz of link aggregating etc but switching to a custom firmware would probably make it better.. Anyone that can give some advice would be appreciated..

Thank you for helping out! You are a real pro.


Lantis wrote:1. If you have a WRT1900ACv2, then you should use that image file. It looks like you tried to use a Shelby image which is intended for WRT1900ACS. That would explain the wrong device name.
Between 1.10.x and 1.11.x we moved from using Linksys codenames (mamba, cobra, Shelby etc) to using the model names.
If you flashed the wrong image, I strongly advise you return to OEM firmware and start fresh using the right image. Please take better care in future as it is a mistake that you cannot always recover from.

2. Openwrt files are not Gargoyle files, I don’t understand why you have listed this. Also I don’t see how you could use a 1.9.x image to get to 1.11.x

3. Temperature is fine

4. 1.11.x is a testing/beta build. Plugins are provided in the torrent download so you can deploy them yourself. They will be available from official locations when 1.11.0 is officially released.

5. You should not copy packages between architectures. While it will probably work for some packages (like themes) it is ill advised.

6. You should use the LATEST 1.11.x beta if you’re going to stick with this branch
viewtopic.php?f=14&t=11711
Netgear R85000 - Netgear original firmware
Linksys WRT1900ACv2 - Gargoyle 1.11.X
TP-Link TL-WR1043N/ND v2 - Gargoyle 1.10.X
ASUS RT-AC66U - Merlin LTS 374.43_2
Netgear R7000 - Lede/Openwrt 18.06.0

Lantis
Moderator
Posts: 5528
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Post by Lantis »

For the WRT1900ACSv2 you just need the WRT1900ACS image. There is no difference between v1 and 2 for that device.

Sure you can put a fan on it. But it isn’t necessary. The chips on these are rated to 105°C from memory. It is well within its operating constraints.
The wifi driver on that device won’t let you lower the power so you can’t do that. Turning off wifi will save a few degrees.
An overrated power supply is ok. The device will only pull what it requires. Underrating won’t work.

Some people have trouble with wifi on these devices. I’ve personally never had any issue so I think it is great.

I don’t see any Openwrt support for the R8500 sorry
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

smyr
Posts: 17
Joined: Thu May 30, 2013 11:17 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Post by smyr »

Any new developmens or updates planned? I would really like to be able to pick a different theme and some more advanced plugins like a small webserver/ftp/dnsserver. And a system logfile would also help alot...

Opnwrt plugins will they work!?

Thanks.
Netgear R85000 - Netgear original firmware
Linksys WRT1900ACv2 - Gargoyle 1.11.X
TP-Link TL-WR1043N/ND v2 - Gargoyle 1.10.X
ASUS RT-AC66U - Merlin LTS 374.43_2
Netgear R7000 - Lede/Openwrt 18.06.0

Post Reply