1.12.0.x gargoyle-ispy 2020-March-02 06

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

ispyisail
Moderator
Posts: 4833
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

1.12.0.x gargoyle-ispy 2020-March-02 06

Post by ispyisail »

USE AT YOUR OWN RISK

WARNING: DO NOT PRESERVE SETTINGS

Now includes packages

1.12.0.x gargoyle-ispy 2020-March-02 06
Torrent
http://bit.ly/2VCnP5w

magnet:?xt=urn:btih:c4cbaeb90543d0ee2bdd84b8b008d6a03280414c&dn=1.12.0.x%20gargoyle-ispy%202020-March-02%2006.7z&tr=udp%3a%2f%2ftracker.openbittorrent.com%3a80&tr=udp%3a%2f%2fopen.demonii.com%3a1337&tr=udp%3a%2f%2ftracker.coppersurfer.tk%3a6969&tr=udp%3a%2f%2ftracker.leechers-paradise.org%3a6969&tr=udp%3a%2f%2ftracker.coppersurfer.tk%3a6969%2fannounce&tr=udp%3a%2f%2ftracker.open-internet.nl%3a6969%2fannounce&tr=udp%3a%2f%2fallesanddro.de%3a1337%2fannounce&tr=udp%3a%2f%2f9.rarbg.to%3a2710%2fannounce

Routers
http://bit.ly/2IdF1Gw


Changelog
(see creation date for commit date)

https://github.com/ericpaulbishop/gargoyle/commits/1.12

ektus
Posts: 183
Joined: Sun Aug 11, 2013 2:26 am
Location: Germany

Re: 1.12.0.x gargoyle-ispy 2020-March-02 06

Post by ektus »

Installed on a (previously) spare TL-WR1043ND V1, running as AP and wireless repeater. No problems so far.

Seeding the torrent, too :D

phgerin
Posts: 109
Joined: Sun Dec 21, 2014 2:03 pm

Re: 1.12.0.x gargoyle-ispy 2020-March-02 06

Post by phgerin »

I have a few reboots with this build, not sure what causing them. I can't see anything in the logs (for now).

WRT 1200ac

ektus
Posts: 183
Joined: Sun Aug 11, 2013 2:26 am
Location: Germany

Re: 1.12.0.x gargoyle-ispy 2020-March-02 06

Post by ektus »

Uptime: 17 days, 14 hours, 11 minutes

So no, mine is stable. But it's being used as Wireless Repeater only, so it has very minor load.

ispyisail
Moderator
Posts: 4833
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: 1.12.0.x gargoyle-ispy 2020-March-02 06

Post by ispyisail »

phgerin wrote:
Mon Mar 23, 2020 2:43 am
I have a few reboots with this build, not sure what causing them. I can't see anything in the logs (for now).

WRT 1200ac
reset your router

pmerrill
Posts: 289
Joined: Wed Feb 15, 2012 8:23 pm

Re: 1.12.0.x gargoyle-ispy 2020-March-02 06

Post by pmerrill »

Just did an update to this latest one and noticed a couple of curiosities (btw, I did an upgrade but did NOT preserve settings)
Router is Archer C7 V2:
  • Wifi works fine but the activity leds no longer display
  • When I turned on QoS Download I noticed that the Congestion Control Status is blank. I remember in past releases it did show some info
Any ideas?
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W

Lantis
Moderator
Posts: 5588
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: 1.12.0.x gargoyle-ispy 2020-March-02 06

Post by Lantis »

Saving QOS again should fix the congestion control status being blank.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

pmerrill
Posts: 289
Joined: Wed Feb 15, 2012 8:23 pm

Re: 1.12.0.x gargoyle-ispy 2020-March-02 06

Post by pmerrill »

Lantis wrote:
Wed Apr 01, 2020 5:41 am
Saving QOS again should fix the congestion control status being blank.
Hey Lantis, thanks for the suggestion but no luck. I've enabled, disabled, tried different browsers no luck. I'm an old Unix/ASM hack so I can login to the router via root was wondering if there is anything I can check in /etc that may indicate a problem?

It's also strange that while wifi works fine, the leds on the router no longer display activity. Is there some file I can check in /etc to see if there is a setting problem?

My only other approach is to do a backup, re-flash and then a restore and see if that "fixes" it.

Very strange to me.
Paul
Gargoyle 1.11.x on TP-Link Archer C7 V2 H/W

Lantis
Moderator
Posts: 5588
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: 1.12.0.x gargoyle-ispy 2020-March-02 06

Post by Lantis »

Those stats not showing up are usually accompanied by log entries along the lines of "device IMQ0 does not exist"
Which indicates that the IMQ driver failed to start correctly.
Usually saving QOS again causes it to restart and therefore attempt to reinsert the driver.

I need to put some try, wait, fail code around the IMQ driver but I don't have a reliable way of making it fail to load so I can't test it.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

phgerin
Posts: 109
Joined: Sun Dec 21, 2014 2:03 pm

Re: 1.12.0.x gargoyle-ispy 2020-March-02 06

Post by phgerin »

ispyisail wrote:
Wed Mar 25, 2020 10:37 pm
phgerin wrote:
Mon Mar 23, 2020 2:43 am
I have a few reboots with this build, not sure what causing them. I can't see anything in the logs (for now).

WRT 1200ac
reset your router
Disabling quotas fixed my crashes.

Post Reply