WiFi button not supported

Suggest improvements and new features for Gargoyle.

Moderator: Moderators

wazahuis
Posts: 9
Joined: Tue Jun 09, 2015 6:18 pm

Re: WiFi button not supported

Postby wazahuis » Sun Jun 14, 2015 11:17 pm

Well that works great, thank you! :-)

Lantis
Moderator
Posts: 5211
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: WiFi button not supported

Postby Lantis » Sun Jun 14, 2015 11:17 pm

i'm so very glad we could get you sorted :) its been a nice break from studying also!
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

Lantis
Moderator
Posts: 5211
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: WiFi button not supported

Postby Lantis » Mon Jan 11, 2016 1:15 am

I've got an updated script for installing onto the latest 1.9.X versions of Gargoyle for those that are interested.
The default script is set up to use BTN_2 for WNDR3X00 routers, but it is easily modifiable by following the instructions at the beginning of this thread.

Code: Select all

wget -O /tmp/install.sh http://lantisproject.com/gargoyle_scripts/installwifitoggleCC.sh
sh /tmp/install.sh
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

yabba235
Posts: 26
Joined: Sun Nov 25, 2012 4:57 pm

Re: WiFi button not supported

Postby yabba235 » Mon Jan 11, 2016 5:26 pm

Not work on my wndr3700v2 :(
If I press BTN_2 button, nothing happend :twisted:

With Lantis modification script now working - thank you !

Aragorn_Strider
Posts: 16
Joined: Fri Mar 18, 2016 5:47 pm
Location: south of Paris area, France

Re: WiFi button not supported

Postby Aragorn_Strider » Mon May 30, 2016 4:46 pm

Hi all,

I bought a Netgear WNDR4300v1, and having read the posts above I thought in first that the wifi button would not be supported by default, and that I should add the script discussed.

But to my surprise, either with version 1.8.1 or 1.9.0, the wifi button is supported with no further script.

Is it intentional ?

Frederic
Netgear WNDR4300v1 with Gargoyle v1.9.2 (formerly 1.8.1)

proper88
Posts: 13
Joined: Thu Feb 18, 2016 9:36 am

Re: WiFi button not supported

Postby proper88 » Fri Feb 03, 2017 2:17 pm

Same here.
Running latest build gargoyle-ispy 2017-January-27 and the script is not working.
Please can anybody of the experts take a look on this problem ?
My device Netgear WNDR3700v4

Lantis
Moderator
Posts: 5211
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: WiFi button not supported

Postby Lantis » Fri Feb 03, 2017 3:44 pm

It's not a problem. You're supposed to set it up yourself.
I have provided very detailed instructions throughout this thread. Is there part of it that you can't follow? What have you tried?
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

proper88
Posts: 13
Joined: Thu Feb 18, 2016 9:36 am

Re: WiFi button not supported

Postby proper88 » Fri Feb 03, 2017 5:16 pm

i do not understand how this button handling works.
for example in the in the directory /etc/hotplug.d/
there is no subdirectory button.
so i create the directory and use your instructions in your first post.
i used logread but nothings happens when i press a button.
may the newer builds have other buttons handling ?

Lantis
Moderator
Posts: 5211
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: WiFi button not supported

Postby Lantis » Fri Feb 03, 2017 5:20 pm

Try /etc/rc.button instead

I linked a script earlier on this page which was updated for the latest versions. You can probably use it as a scaffold.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

proper88
Posts: 13
Joined: Thu Feb 18, 2016 9:36 am

Re: WiFi button not supported

Postby proper88 » Tue Mar 21, 2017 1:41 am

Hi Lantis,
i found the problem.
I have an Netgear WNDR3700v4, it is a NAND Router.
In the build process the module
CONFIG_PACKAGE_kmod-input-polldev=y
is not included
https://github.com/ericpaulbishop/gargo ... and/config

Thanks,
proper88


Return to “Feature Requests”

Who is online

Users browsing this forum: No registered users and 4 guests