Page 4 of 7

Re: compile build failed

Posted: Wed Feb 27, 2019 8:26 am
by Lantis
If you save your new custom config (which is now at /gargoyle/targets/mvebu/profiles/default/config) in a safe location, you can use it to override this file again at a later date.

If that config file is updated by changes in Gargoyle, it may be important to do the steps again to make sure you have the latest changes, as well as your custom ones. You would need to keep an eye on github to know if that config is changed.

Re: compile build failed

Posted: Wed Feb 27, 2019 9:07 am
by Armik
that something not clear is going.web interface is constantly falling off and even the internet disappears completely.in magazines only have time to see these records:

Code: Select all

nf_conntrack: nf_conntrack: table full, dropping packet
] net_ratelimit: 3 callbacks suppressed
I reset it several times to the factory ones and reflash two times does not help.probably you should try your finished firmware.

Re: compile build failed

Posted: Thu Feb 28, 2019 5:40 am
by Armik
With the finished firmware, the same thing in 5 minutes, everything starts to fail.
I have a relay tor on another virtual machine and it occupies ports (443,80) it can interfere with work?
Also yesterday I assembled firmware on openwrt,12 hours while everything works.
On your firmware, it is possible to combine one of lan ports with a wan by editing network config and whether it will work?
I also collected a new config and already gave errors:plagin qos,plagin webcam,plagin upnp.I deleted them from the assembly but the problem persists.

Re: compile build failed

Posted: Thu Feb 28, 2019 6:40 am
by Lantis
I won't have time to check it until the weekend. All i will be able to do is try to compile you a version which may or may not work.

Re: compile build failed

Posted: Thu Feb 28, 2019 8:48 am
by Armik
clear.thanks for your help.

Re: compile build failed

Posted: Tue Mar 05, 2019 6:13 am
by Lantis
Try this one:
http://lantisproject.com/gargoyle_custom/mvebu-1.11.x/

Sorry for the late reply. I did actually compile it on the weekend but ran out of time to upload it.

Re: compile build failed

Posted: Thu Mar 07, 2019 6:00 am
by Armik
everything seems to work, thanks, but why did not it work for me?

Re: compile build failed

Posted: Thu Mar 07, 2019 6:35 am
by Lantis
I don't know. Your build may have been corrupted. It is not easy, but once you know how

Re: compile build failed

Posted: Wed Mar 13, 2019 12:19 pm
by Armik
Hi.there was no time to properly check and here I am back to the test.unfortunately i found the problem persists.web interface still crashes and the router completely freezes.I can not understand what causes the problem.there is an assumption that this is because of the server "uhttpd".
Could you send your network and server configs (/etc/config/network,/etc/config/uhttpd)
for comparison, I will send working configs on openwrt(core 4.14.105).

Code: Select all

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 5t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 4 6t'
	option vid '2'

Code: Select all

config uhttpd 'main'
	option redirect_https '1'
	option home '/www'
	option rfc1918_filter '1'
	option max_requests '1'
	option max_connections '100'
	option cert '/etc/uhttpd.crt'
	option key '/etc/uhttpd.key'
	option cgi_prefix '/cgi-bin'
	list lua_prefix '/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua'
	option script_timeout '60'
	option network_timeout '30'
	option http_keepalive '20'
	option tcp_keepalive '1'
	list listen_http '192.168.1.1:80'
	list listen_https '192.168.1.1:443'

config cert 'defaults'
	option days '730'
	option bits '2048'
	option country 'ZZ'
	option state 'Somewhere'
	option location 'Unknown'
	option commonname 'OpenWrt'

Re: compile build failed

Posted: Wed Mar 13, 2019 3:07 pm
by RomanHK
I ask, this eth1.2 is correct?

Code: Select all

config interface 'wan'
   option ifname 'eth1.2'
   option proto 'dhcp'
Shouldn't there be eth0.2?

Code: Select all

config interface 'wan'
   option ifname 'eth0.2'
   option proto 'dhcp'