Page 20 of 28

Re: Gargoyle 1.15.x BETA - 2024-11-13 - Based on OpenWrt 23.05

Posted: Fri Nov 22, 2024 5:35 am
by Lantis
What router? I’m a bit perplexed why it wouldn’t work.
What does
ls -al /sys/class/net/eth0/
cat /sys/class/net/eth0/*

Bring back?

Re: Gargoyle 1.15.x BETA - 2024-11-13 - Based on OpenWrt 23.05

Posted: Mon Nov 25, 2024 10:58 am
by ViBE
Lantis wrote:
Fri Nov 22, 2024 5:35 am
What router? I’m a bit perplexed why it wouldn’t work.
What does
ls -al /sys/class/net/eth0/
cat /sys/class/net/eth0/*

Bring back?
it is a Nexx WT3020F

Code: Select all

~#  ls -al /sys/class/net/eth0/
drwxr-xr-x    4 root     root             0 Nov 25 15:55 .
drwxr-xr-x    3 root     root             0 Nov 25 15:55 ..
-r--r--r--    1 root     root          4096 Nov 25 15:55 addr_assign_type
-r--r--r--    1 root     root          4096 Nov 25 15:55 addr_len
-r--r--r--    1 root     root          4096 Nov 25 15:55 address
-r--r--r--    1 root     root          4096 Nov 25 15:55 broadcast
-rw-r--r--    1 root     root          4096 Nov 25 15:55 carrier
-r--r--r--    1 root     root          4096 Nov 25 15:55 carrier_changes
-r--r--r--    1 root     root          4096 Nov 25 15:55 carrier_down_count
-r--r--r--    1 root     root          4096 Nov 25 15:55 carrier_up_count
-r--r--r--    1 root     root          4096 Nov 25 15:55 dev_id
-r--r--r--    1 root     root          4096 Nov 25 15:55 dev_port
lrwxrwxrwx    1 root     root             0 Nov 25 15:55 device -> ../../../10100000.ethernet
-r--r--r--    1 root     root          4096 Nov 25 15:55 dormant
-r--r--r--    1 root     root          4096 Nov 25 15:55 duplex
-rw-r--r--    1 root     root          4096 Nov 25 15:55 flags
-rw-r--r--    1 root     root          4096 Nov 25 15:55 gro_flush_timeout
-rw-r--r--    1 root     root          4096 Nov 25 15:55 ifalias
-r--r--r--    1 root     root          4096 Nov 25 15:55 ifindex
-r--r--r--    1 root     root          4096 Nov 25 15:55 iflink
-r--r--r--    1 root     root          4096 Nov 25 15:55 link_mode
-rw-r--r--    1 root     root          4096 Nov 25 15:55 mtu
-r--r--r--    1 root     root          4096 Nov 25 15:55 name_assign_type
-rw-r--r--    1 root     root          4096 Nov 25 15:55 napi_defer_hard_irqs
-rw-r--r--    1 root     root          4096 Nov 25 15:55 netdev_group
-r--r--r--    1 root     root          4096 Nov 25 15:55 operstate
-r--r--r--    1 root     root          4096 Nov 25 15:55 phys_port_id
-r--r--r--    1 root     root          4096 Nov 25 15:55 phys_port_name
-r--r--r--    1 root     root          4096 Nov 25 15:55 phys_switch_id
-rw-r--r--    1 root     root          4096 Nov 25 15:55 proto_down
drwxr-xr-x    3 root     root             0 Nov 25 15:55 queues
-r--r--r--    1 root     root          4096 Nov 25 15:55 speed
drwxr-xr-x    2 root     root             0 Nov 25 15:55 statistics
lrwxrwxrwx    1 root     root             0 Nov 25 15:55 subsystem -> ../../../../../class/net
-r--r--r--    1 root     root          4096 Nov 25 15:55 testing
-rw-r--r--    1 root     root          4096 Nov 25 15:55 threaded
-rw-r--r--    1 root     root          4096 Nov 25 15:55 tx_queue_len
-r--r--r--    1 root     root          4096 Nov 25 15:55 type
-rw-r--r--    1 root     root          4096 Nov 25 15:55 uevent
lrwxrwxrwx    1 root     root             0 Nov 25 15:55 upper_eth0.1 -> ../../../../virtual/net/eth0.1
lrwxrwxrwx    1 root     root             0 Nov 25 15:55 upper_eth0.2 -> ../../../../virtual/net/eth0.2

Code: Select all

~#  cat /sys/class/net/eth0/*
0
6
20:28:xx:xx:xx:xx
ff:ff:ff:ff:ff:ff
1
0
0
0
0x0
0
cat: read error: Is a directory
0
cat: read error: Invalid argument
0x1303
0
2
2
0
1500
cat: read error: Invalid argument
0
0
unknown
cat: read error: Not supported
cat: read error: Not supported
cat: read error: Not supported
0
cat: read error: Is a directory
cat: read error: Invalid argument
cat: read error: Is a directory
cat: read error: Is a directory
0
0
1000
1
INTERFACE=eth0
IFINDEX=2
cat: read error: Is a directory
cat: read error: Is a directory

Re: Gargoyle 1.15.x BETA - 2024-11-13 - Based on OpenWrt 23.05

Posted: Tue Nov 26, 2024 5:52 am
by Lantis
It's still using swconfig. Can you post your entire /etc/config/network please?
I don't know if I can support the WAN speed of it simply, but I will look at it.

Re: Gargoyle 1.15.x BETA - 2024-11-13 - Based on OpenWrt 23.05

Posted: Tue Nov 26, 2024 9:07 am
by ViBE
Lantis wrote:
Tue Nov 26, 2024 5:52 am
It's still using swconfig. Can you post your entire /etc/config/network please?
I don't know if I can support the WAN speed of it simply, but I will look at it.

Code: Select all

~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd4a:xxxx:xxxx::/48'

config device 'brlan_dev'
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.8.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ip6ifaceid '::1'
	option dns '192.168.8.1'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr '20:28:xx:xx:xx:xx'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'
	option ipv6 '0'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'none'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan 'switch_lan_vlan'
	option device 'switch0'
	option vlan '1'
	option ports '4 6t'

config switch_vlan 'switch_wan_vlan'
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

Re: Gargoyle 1.15.x BETA - 2024-11-13 - Based on OpenWrt 23.05

Posted: Tue Nov 26, 2024 9:57 pm
by Lantis
Your earlier post showed it returning “eth0”. Config shows “eth0.2”.
No idea why or how this can happen.

For now, assume it does not work on your device.

Re: Gargoyle 1.15.x BETA - 2024-11-13 - Based on OpenWrt 23.05

Posted: Wed Nov 27, 2024 6:13 pm
by ViBE
Lantis wrote:
Tue Nov 26, 2024 9:57 pm
Your earlier post showed it returning “eth0”. Config shows “eth0.2”.
No idea why or how this can happen.

For now, assume it does not work on your device.
what can cause this?

Re: Gargoyle 1.15.x BETA - 2024-11-13 - Based on OpenWrt 23.05

Posted: Wed Nov 27, 2024 10:14 pm
by pythonic
Lantis wrote:
Tue Nov 26, 2024 9:57 pm
Your earlier post showed it returning “eth0”. Config shows “eth0.2”.
No idea why or how this can happen.
Does this possibly arise on those swconfig devices which have to explicitly use VLAN IDs to set the WAN and LAN connectivity within the switch? I think I've seen the same symptom (no reported speed) but don't recall on which devices...

Re: Gargoyle 1.15.x BETA - 2024-11-13 - Based on OpenWrt 23.05

Posted: Sat Nov 30, 2024 1:58 am
by Lantis
I think that is correct. I just have no idea why uci get would report a completely different value.
Unless it is looking in a runtime spot like /var/etc/ or something…
I will need to break out my wndr3800 and look, although it is a slightly different case.

Re: Gargoyle 1.15.x BETA - 2024-11-13 - Based on OpenWrt 23.05

Posted: Wed Dec 11, 2024 2:22 am
by coits
Hi All,

Just want to ask if linksys wrt3200ACM will work on this build.
please advise as I have a router that's using the 1.13 build and the firmware is quite outdated already.

Thanks

Re: Gargoyle 1.15.x BETA - 2024-11-13 - Based on OpenWrt 23.05

Posted: Wed Dec 11, 2024 7:10 am
by Lantis
Per the release notes, yes.
mvebu devices are back! These were previously disabled due to an upstream issue which has now been resolved