Re: x86 installation
Posted: Tue May 28, 2024 6:52 am
Maybe I should start new topic, but I think I have the same problem. I've installed Gargoyle 1.14 on VirtualBox VM. I used gargoyle_1.14.0-x86-64-generic-ext4-combined.img.gz. VM with to NICs.
Network configuration after first run:
So LAN assigned to eth0, no WAN at all.
When I set in Internet/WAN Connect Via to DHCP (Wired) the configuration changed to:
The result: Neither WAN nor LAN works 
I've changed manually from console to:
Works, but if I changed configuration in web interface, LAN IP to 192.168.1.2 the configuration changed to:
And again: Nothing works 
The only help: restore configuration in console/terminal.
Network configuration after first run:
Code: Select all
config device 'brlan_dev'
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
When I set in Internet/WAN Connect Via to DHCP (Wired) the configuration changed to:
Code: Select all
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option ip6ifaceid '::1'
option dns '192.168.1.1'
config device 'wan_eth0_dev'
option name 'eth0'
option macaddr '08:00:27:d7:e6:3e'
config interface 'wan'
list device 'eth0'
option proto 'dhcp'
option ipv6 '0'

I've changed manually from console to:
Code: Select all
config device 'brlan_dev'
option name 'br-lan'
option type 'bridge'
list ports 'eth1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option ip6ifaceid '::1'
option dns '192.168.1.1'
config device 'wan_eth0_dev'
option name 'eth0'
option macaddr '08:00:27:d7:e6:3e'
config interface 'wan'
option device 'eth0'
option proto 'dhcp'
option ipv6 '0'
Code: Select all
config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ip6ifaceid '::1'
option dns '192.168.1.2'
option ipaddr '192.168.1.2'
config device 'wan_eth0_dev'
option name 'eth0'
option macaddr '08:00:27:d7:e6:3e'
config interface 'wan'
option proto 'dhcp'
option ipv6 '0'
list device 'eth0'

The only help: restore configuration in console/terminal.