Failed to build 1.12

Report problems and success stories with Gargoyle on various hardware platforms.

Moderator: Moderators

raven
Posts: 33
Joined: Mon Mar 25, 2019 12:25 am

Failed to build 1.12

Post by raven »

Hello, I was trying to build version 1.12 for my gl-ar150 with my vm. I was using Ubuntu 14.04 64 bit. I've done what is in the following link viewtopic.php?f=14&t=11883&sid=45ecc9ed ... fa1a3a6681, this viewtopic.php?f=8&t=11430&hilit=youku+yk+l1c&start=30, and this viewtopic.php?t=11793, switched the branch to 1.12, created a config file using make custom and save it to my own folder, created my own profile images, and ran 'Make ar71xx.glar150', and also I always tried to do 'make clean' but it always failed and got an error like this

Code: Select all

renameat2.c:81:22: note: each undeclared identifier is reported only once for each function it appears in
make[8]: *** [renameat2.o] Error 1
make[8]: Leaving directory `/home/test/gargoyle/ar71xx-src/build_dir/host/patch-2.7.6/lib'
make[7]: *** [all] Error 2
make[7]: Leaving directory `/home/test/gargoyle/ar71xx-src/build_dir/host/patch-2.7.6/lib'
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory `/home/test/gargoyle/ar71xx-src/build_dir/host/patch-2.7.6'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/home/test/gargoyle/ar71xx-src/build_dir/host/patch-2.7.6'
make[4]: *** [/home/test/gargoyle/ar71xx-src/build_dir/host/patch-2.7.6/.built] Error 2
make[4]: Leaving directory `/home/test/gargoyle/ar71xx-src/tools/patch'
time: tools/patch/compile#105.90#36.68#158.54
make[3]: *** [tools/patch/compile] Error 2
make[3]: Leaving directory `/home/test/gargoyle/ar71xx-src'
make[2]: *** [/home/test/gargoyle/ar71xx-src/staging_dir/target-mips_24kc_musl/stamp/.tools_compile_yynyyyyynyyyyynyynnyyyyyyyyyyyyyyyyyyyynyynynyyyynnyy] Error 2
make[2]: Leaving directory `/home/test/gargoyle/ar71xx-src'
make[1]: *** [world] Error 2
make[1]: Leaving directory `/home/test/gargoyle/ar71xx-src'
find: `bin/packages/mips_24kc': No such file or directory
find: cannot search `': No such file or directory
find: cannot search `': No such file or directory
find: `bin/targets/ar71xx/generic': No such file or directory
find: cannot search `': No such file or directory
find: cannot search `': No such file or directory
ls: cannot access bin/targets: No such file or directory
Did I miss something, so that it always fails and gets an error like that?
Please advise if there is a way to successfully build the image.
Thanks in advance for your help.

ispyisail
Moderator
Posts: 4926
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Failed to build 1.12

Post by ispyisail »

Does you VM have enough disk space?

Lantis
Moderator
Posts: 5950
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Failed to build 1.12

Post by Lantis »

You didn't include enough lines in the error.
In either case, high chance that your old Ubuntu version is to blame. Move to 18.04 or 20.04 if possible.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

raven
Posts: 33
Joined: Mon Mar 25, 2019 12:25 am

Re: Failed to build 1.12

Post by raven »

ispyisail wrote:
Wed Sep 16, 2020 3:04 pm
Does you VM have enough disk space?
Yes, because no errors regarding low disk space

raven
Posts: 33
Joined: Mon Mar 25, 2019 12:25 am

Re: Failed to build 1.12

Post by raven »

Lantis wrote:
Wed Sep 16, 2020 5:58 pm
You didn't include enough lines in the error.
In either case, high chance that your old Ubuntu version is to blame. Move to 18.04 or 20.04 if possible.
Which lines do you mean ?. Because the error that I posted is all the last error lines after failed to build. I will try with the latest version of Ubuntu.

Lantis
Moderator
Posts: 5950
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Failed to build 1.12

Post by Lantis »

Code: Select all

renameat2.c:81:22: note: each undeclared identifier is reported only once for each function it appears in
Typically lines like this are preceeded by

Code: Select all

renameat2.c:81:22: foo = bar;
renameat2.c:81:22: Undeclared foo
So you're at least 2 lines short of showing what the actual error is. You only showed the help part which reminds us that we won't see this error again for the same issue in the same file.
But there would be significantly more contextual information in the 50 to 500 lines preceding that one.


With Ubuntu 20.04, make sure you install the python-is-python3 package.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

raven
Posts: 33
Joined: Mon Mar 25, 2019 12:25 am

Re: Failed to build 1.12

Post by raven »

Hi Lantis, now I'm using ubuntu 20.04 and got error messages like this

Code: Select all

WARNING: Makefile 'package/network/utils/curl/Makefile' has a dependency on 'libidn2', which does not exist
WARNING: Makefile 'package/gargoyle-firewall-util/Makefile' has a dependency on 'iptables-mod-bandwidth', which does not exist
WARNING: Makefile 'package/gargoyle-firewall-util/Makefile' has a dependency on 'iptables-mod-timerange', which does not exist
WARNING: Makefile 'package/gargoyle-firewall-util/Makefile' has a dependency on 'iptables-mod-weburl', which does not exist
WARNING: Makefile 'package/gnutls/Makefile' has a dependency on 'kmod-cryptodev', which does not exist
WARNING: Makefile 'package/libiptbwctl/Makefile' has a dependency on 'iptables-mod-bandwidth', which does not exist
WARNING: Makefile 'package/qos-gargoyle/Makefile' has a dependency on 'iptables-mod-imq', which does not exist
WARNING: Makefile 'package/webmon-gargoyle/Makefile' has a dependency on 'iptables-mod-webmon', which does not exist
, this happened on the first start building the image

and this

Code: Select all

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for bwmon-gargoyle:
 * 	iptables-mod-bandwidth
 * 	iptables-mod-timerange
 * 	iptables-mod-weburl
 * opkg_install_cmd: Cannot install package bwmon-gargoyle.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for gargoyle:
 * 	iptables-mod-webmon
 * opkg_install_cmd: Cannot install package gargoyle.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for plugin-gargoyle-qos:
 * 	iptables-mod-imq
 * opkg_install_cmd: Cannot install package plugin-gargoyle-qos.
make[3]: *** [package/Makefile:68: package/install] Error 255
make[3]: Leaving directory '/home/test/gargoyle/ar71xx-src'
make[2]: *** [package/Makefile:108: /home/test/gargoyle/ar71xx-src/staging_dir/target-mips_24kc_musl/stamp/.package_install] Error 2
make[2]: Leaving directory '/home/test/gargoyle/ar71xx-src'
make[1]: *** [/home/test/gargoyle/ar71xx-src/include/toplevel.mk:218: world] Error 2
make[1]: Leaving directory '/home/test/gargoyle/ar71xx-src'
, this happened on the last when failed to build the image.

What are the cause of the problem?

Lantis
Moderator
Posts: 5950
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Failed to build 1.12

Post by Lantis »

It looks like you have not selected all of the required iptables mods. These are all the custom modules that Gargoyle patches into the build root.

So checking a few things
1. Are you still using the Gargoyle build process or are you attempting to shortcut this?
2. Did you select the appropriate iptables modules?

You should check one of the existing config files for guidance.
If you get stuck, post your full config here and I'll try to help.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

raven
Posts: 33
Joined: Mon Mar 25, 2019 12:25 am

Re: Failed to build 1.12

Post by raven »

Hi Lantis,
1. Sorry if I misunderstood your question but I think yes, I still using the gargoyle process build
2. I think I already selected all appropriate iptables modules
I tried to post my full config here but can not and it said my message contains characters exceed than 60000 characters. Is there any other way to submit my full config?

Lantis
Moderator
Posts: 5950
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Failed to build 1.12

Post by Lantis »

https://pastebin.com/ and link it here :)
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Post Reply