Openwrt 19.07 based Gargoyle

Discuss the technical details of Gargoyle and ongoing development

Moderator: Moderators

papka__
Posts: 38
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Hi,

Got problem with building latest on git. When I'm flashing image after successful building, I'm getting "undefined" in a lot of places. Tried to google and found that it could be config fault. Checked this and 3 required plugins (gargoyle, gargoyle-i18n and English-EN) are set to "y". Rebuilt multiple times, even full. Nothing. There were no such problem before. Only thing is, that I changed building server from Debian to Ubuntu.
Browser cache was cleaned multiple times.
Need help.
Thank you in advance.

PS. Another interesting thing, when doing first login, language option not appear at all. Whenever only one language "pre-loaded".

PSS. Even trying default git config, problem stays.

Lantis
Moderator
Posts: 5947
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

Sounds like the scripts that run all of the internationalization aren't running.
Very early in the build process some python scripts get called, I would look for errors there.
If you get "Warning Python not found" that would be a giveaway.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

papka__
Posts: 38
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Lantis wrote:
Sat Aug 22, 2020 8:14 pm
Sounds like the scripts that run all of the internationalization aren't running.
Very early in the build process some python scripts get called, I would look for errors there.
If you get "Warning Python not found" that would be a giveaway.
This problem was also in build from around 10.08.2020, not only now. I got the only yesterday to retry and same problem.

Lantis
Moderator
Posts: 5947
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

I rewrote the scripts to support python 2 and 3 on May 31st. This was specifically to suit Ubuntu 20.
It also builds fine on my machine and clearly ispyisail is able to build it too.

So, do you have all build requisites installed? Which version of python do you have installed? And are you going to provide some kind of build log and config file?
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

papka__
Posts: 38
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

I tried to attach config as zip file. Not allowed.
Link to config file - https://itjcloud.dedyn.io/s/LoZzpFtCDEfW6HG

Maybe this was what I missed

Code: Select all

sudo ln -s /usr/bin/python3 /usr/bin/python
PS. Yes. This was a problem. There are no symlink by default.

Lantis
Moderator
Posts: 5947
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

That's perfectly fine, but on Ubuntu i'd install "python-is-python3" (or "python-is-python2").
This does exactly what you've done, but it is the more official method and allows some automatic package upgrades to take place more effectively.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

papka__
Posts: 38
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Thank you for advice. Will do!

PS. Maybe not so bad idea to note something about that in build description/dependencies on git?

pythonic
Posts: 82
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by pythonic »

I'm trying to build a recent master (git 75565a7f) for ipq40xx and getting what appears to be a shell error as the build starts to assemble the final images. The problem seems related to creating the FIT format images used for many ipq40xx targets and I didn't encounter this issue with the 1.12.0 build I've made available. I also don't have any problems building ipq806x images (none of which use FIT images) from the same checkout, nor do I see a problem building OpenWrt 19.07 of similar vintage. All building is on a Debian 9 x64 Virtualbox VM which has been kept reasonably up to date.

The first actual error reported in the log is

Code: Select all

sh: 1 Syntax error: Unterminated quoted string
Googling this message suggests it's either a quoting issue specifically or a file name with an embedded apostrophe... but this doesn't seem to make sense from the directory structure or the log.

As best I can tell, the error occurs in the Build/fit definition in ipq40xx-src/include/image-commands.mk but I can't make out whether it is in the Make command sequence or the mkits.sh (from U-Boot 2018.03) script it calls, though I note that mkits.sh should be executed with bash so that seems not to be a match with the error message.

I've put a 7z archive with the target config files, make log and copy of mkits.sh here if anyone wants to take a look.

I'd appreciate any advice about how to figure out what's wrong as I'm stumped :(

Frew
Posts: 5
Joined: Sun Sep 13, 2020 8:09 pm

Re: Openwrt 19.07 based Gargoyle

Post by Frew »

Hello, I've tried to install Gargoyle 1.13 on my Xiaomi Router 3Gv1 and I had some bugs.
1. In GUI I can't see Hostnames of some devices, instead of it I see only it's ip.
2. In B/W Distribution page instead of volume of MB I see "Nan%". I think this happed because my phone has too long Hostname "HUAWEI_Mate_20-b76425e..." like this.
I have screenshots of these bugs, but I couldn't attach it here.
Last edited by Frew on Sun Sep 13, 2020 8:21 pm, edited 1 time in total.

Lantis
Moderator
Posts: 5947
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

Hi, please host the screenshots elsewhere and link to them here.
Can you please confirm that you installed without preserving settings?
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Post Reply