Version 1.11.0 : Based on OpenWrt 18.06

The latest news about Gargoyle

Moderator: Moderators

Eric
Site Admin
Posts: 1436
Joined: Sat Jun 14, 2008 1:14 pm

Version 1.11.0 : Based on OpenWrt 18.06

Postby Eric » Thu Feb 21, 2019 12:51 pm

Important: See upgrade notes at bottom of post

New in 1.11.0:
  • Update to Openwrt 18.06 branch (Kernels 4.14.99 and 4.9.156)
  • Add x86 profile
  • Fixes to Samba network sharing
  • Fixes to Tor (server config)
  • Timezone changes (add Iran, rearrange Brazil, realign Turkey, fix regional server pools not updating)
  • Fix button handlers for Archer series routers
  • Add Quad9 DNS
  • Fix Connection -> Basic page for devices with no wireless capabilities
  • Add custom month bandwidth monitor (for aligning to ISP billing date)
  • Fixes to restrictions module (not working on a single IP and not whitelisting URLs)
  • Rework of OpenVPN config handling (certificates can now be permanently revoked. Disabled certificates will not be able to be connected with, but can be reinstated). Also add ability to generate single .ovpn file as config. Add new config options to assist mobile devices. Default cipher updated to more secure version
  • New QoS default ruleset as per forum input
  • QOSMON v2.3 with improved handling of dropped pings, smoother control algorithm and more user information displayed. Button added to reset the Fair Link Limit back to initial values
  • Fixes to custom MAC Address setting not sticking
  • Various GUI updates and cleanups
  • Update DDNS Cloudflare configuration to handle new upstream API (you need to install a Gargoyle plugin to enable this now)
  • Add HTTPS sniffing capabilities to Web URL Monitor and Restrictions sections
  • New Theme "Flat Blue"
  • Layer7 functionality disabled throughout firmware (it may return later...)
  • Add GeoIP wifi country setting to GUI (with very specific conditions. You may only set this setting ONCE, and some users may never see this option if they do not meet certain regulatory requirements)
  • Changes to Connected Hosts page (shows guests and upstream client connections separately)
  • Allow filtering of Connection List page
  • Translation updates for many languages
  • Major effort to reduce firmware size to maintain smaller device compatibility (sorry, 4MB devices are not salvageable!)
  • Fix WOL list being filled with unreachable entries
  • Fixed email plugin not working
  • Changed startup order of minidlna and usb_storage to try to prevent minidlna not finding external media directories
  • Separate usb-storage into 2 plugins. The "noshare" variant does not include SMB/CIFS/NFS/FTP support. To regain these, install plugin-gargoyle-usb-storage-full
  • Separate DDNS into a plugin
  • Separate QoS into a plugin. This also removes the ability to "throttle" quotas, leaving only the option to fully block devices once reaching the quota. This functionality can be restored by installing plugin-gargoyle-qos
  • Separate WOL into a plugin
  • Separate UPnP support into a plugin
  • Merge Alix target with new x86 target as a subprofile
  • Update to latest mt76 and mwlwifi drivers
  • Switch to a single SSL library to reduce firmware size
  • Support for many new devices


In summary do not use a backup file or preserve setting on upgrade.

edit:ispy

ispyisail
Moderator
Posts: 4462
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby ispyisail » Thu Feb 21, 2019 2:04 pm

+1

tapper
Moderator
Posts: 1051
Joined: Sun Oct 13, 2013 5:49 pm
Location: Stoke-on-trent UK

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby tapper » Thu Feb 21, 2019 3:14 pm

Verry nice! Thanks for all the hard work that has gon in to this relece.
Linksys WRT1900AC V2 Gargoyle 1.11
Linksys WRT3200ACM OpenWrt Snapshot

Oober
Posts: 14
Joined: Wed Nov 28, 2018 1:07 pm

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby Oober » Thu Feb 21, 2019 3:35 pm

Thank you guys for your hard work getting this out!

Can the settings be preserved when updating from 1.11.0 rc5?

Lantis
Moderator
Posts: 4771
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby Lantis » Thu Feb 21, 2019 4:08 pm

Oober wrote:Thank you guys for your hard work getting this out!

Can the settings be preserved when updating from 1.11.0 rc5?


Yes that should be ok.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

Oober
Posts: 14
Joined: Wed Nov 28, 2018 1:07 pm

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby Oober » Thu Feb 21, 2019 4:31 pm

Thanks, all worked!

top_s
Posts: 37
Joined: Mon Aug 13, 2018 10:09 pm
Location: Brazil

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby top_s » Thu Feb 21, 2019 4:59 pm

♥♥♥
WDR4300 v1 (stock)
WR941nd v2 (1.9.2)
WA901nd v2 (1.6.2)
2x WR741nd (1.6.2)

(Up to) 1gbps up/down link

fifonik
Posts: 81
Joined: Fri Dec 02, 2016 3:52 am
Location: Brisbane, AU

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby fifonik » Thu Feb 21, 2019 5:05 pm

THANK YOU! You are awesome!

lesbinary
Posts: 5
Joined: Fri Jan 12, 2018 6:48 am

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby lesbinary » Thu Feb 21, 2019 6:15 pm

Hi! Just today I was going to try latest RC and I found this! Great job!

I installed 1.11.0 in my TP-Link TL-WR1043N/ND v2 as a gateway at home. Just some notes.

- "Login" button in Gargoyle entry page doesn't work with 'Enter' key, only if I click on it or I tab and then 'Enter', but not when I am typing the password.
- Disabling DHCP gets an infinite loop with the "Please Wait While Settings Are Applied" message with the classic waiting spiral. Refreshing page solves it, but still, not good waiting for nothing.
- "About" page shows "2008-2016" instead of "2008-2019"
- Biggest regression compared to 1.10.0 is related to OpenVPN. I think this is the only plugin I think I need from the repo and the only missing thing I noticed when I installed this new version. Well, it doesn't work with my router. When I install it, looks like everything worked but OpenVPN menu is not shown anywhere. Trying to uninstall doesn't work either, it is always shown as installed, and when I log in with SSH it shows this message:

Code: Select all

Your JFFS2-partition seems full and overlayfs is mounted read-only.
Please try to remove files from /overlay/upper/... and reboot!


This last issue is the biggest one. Maybe it is related with partitions, because it is not usual to have this huge tmpfs and small /overlay (this is with a clean install, not after trying to install openvpn plugin):

Code: Select all

root@Gargoyle:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 5.5M      5.5M         0 100% /rom
tmpfs                    29.4M     80.0K     29.3M   0% /tmp
/dev/mtdblock3          960.0K    244.0K    716.0K  25% /overlay
overlayfs:/overlay      960.0K    244.0K    716.0K  25% /
tmpfs                   512.0K         0    512.0K   0% /dev


After "installing" openvpn plugin (but it doesn't work) it looks like this:

Code: Select all

root@Gargoyle:/# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 5.5M      5.5M         0 100% /rom
tmpfs                    29.4M     88.0K     29.3M   0% /tmp
/dev/mtdblock3          960.0K    912.0K     48.0K  95% /overlay
overlayfs:/overlay      960.0K    912.0K     48.0K  95% /
tmpfs                   512.0K         0    512.0K   0% /dev



If you want me to report or move this anywhere else or test anything, just let me know.

LMP
Posts: 15
Joined: Sun Feb 23, 2014 11:09 am

Re: Version 1.11.0 : Based on OpenWrt 18.06

Postby LMP » Thu Feb 21, 2019 6:50 pm

I can't find download for wr741 and wr740.


Return to “News”

Who is online

Users browsing this forum: No registered users and 3 guests