Gargoyle 1.11.0 Release Candidate 4

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

bluegravy
Posts: 26
Joined: Mon Jul 10, 2017 12:50 pm
Location: Eastern Panhandle West Virginia, USA

Re: Gargoyle 1.11.0 Release Candidate 4

Postby bluegravy » Thu Nov 22, 2018 11:34 pm

Lantis wrote:Can you use the proper gargoyle network restarter to make sure all dependencies are loaded and report back?

/usrs/lib/gargoyle/restart_firewall.sh


Yes...

root@Gargoyle:/usr/lib/gargoyle# ./restart_firewall.sh
root@Gargoyle:/usr/lib/gargoyle#

No errors. Port forwarding still does not work from WAN:80 to LAN:3389.

ispyisail
Moderator
Posts: 4624
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Gargoyle 1.11.0 Release Candidate 4

Postby ispyisail » Fri Nov 23, 2018 1:27 am

screen shots please

Lantis
Moderator
Posts: 5010
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle 1.11.0 Release Candidate 4

Postby Lantis » Fri Nov 23, 2018 3:02 am

You've changed too many things using assumptions that aren't correct and we need to reset. The main one is reversing the forwarding stanza, which should always be lan -> wan as far as i understand.
Please revert to factory defaults, and establish the port forwarding rules via the GUI, and confirm that they work.
If they work, please export a copy of /etc/config/firewall & network.

If/when the router stops forwarding between the two ports, please export the same files to check for changes.

Do not manually restart the firewall using the init.d scripts. If you must restart the firewall by hand, only use the gargoyle helper scripts.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

rseiler
Posts: 179
Joined: Sun Dec 15, 2013 12:31 am

Re: Gargoyle 1.11.0 Release Candidate 4

Postby rseiler » Fri Nov 23, 2018 2:45 pm

Did the email script change recently? If it didn't, something else is influencing it weirdly. This definitely didn't happen the last time that I used it, which was perhaps two months ago (or any time before, that I recall).

Bandwidth usage lags a day (i.e. today's is reported tomorrow). Download/upload format.

Router reports:
Nov 20: 5.29 GB 299.82 MB
Nov 21: 5.22 GB 1.50 GB
Nov 22: 2.60 GB 200 MB

Email reports (report sent just before midnight, as always, and the time is correct in the router):
Nov 20: 5.45 GB 423.43 MB
Nov 21: 5.29 GB 299.82 MB
Nov 22: 5.22 GB 1.50 GB

BTW, an unrelated suggestion: Put the Bandwidth usage first in the report, not last. Otherwise, it can be buried by the other items, many of which tend to be lengthy. Plus, Bandwidth usage may be the most important piece of the report.

melquiferreira
Posts: 17
Joined: Sat Oct 05, 2013 7:14 am

Re: Gargoyle 1.11.0 Release Candidate 4

Postby melquiferreira » Fri Nov 23, 2018 4:35 pm

Is this firmware compatible with TP-Link Archer C20 V4.1?

It has OpenWRT support (/targets/ramips/mt76x8/):

https://downloads.openwrt.org/releases/ ... covery.bin

Waterspuwer
Posts: 32
Joined: Mon Nov 12, 2018 6:04 am

Re: Gargoyle 1.11.0 Release Candidate 4

Postby Waterspuwer » Sat Nov 24, 2018 10:12 am

d3fz wrote:
Waterspuwer wrote:Yes, I can force the problem (just put on higher channel and reboot). Where are logread and dmesg located? It already took some effort for me to figure out how to retrieve the other file, but I don't know where this is.


viewtopic.php?f=8&t=8505

There you go.

Thank you. While working on it, I also noticed that I was now able to select channel 14 (this wasn't the case a few days ago I think, no idea what changed). Which I think should not be possible.

Anyway, the files.
dmesg:
https://pastebin.com/raw/bSRzJUzT

logread:
https://pastebin.com/raw/S6CFHh7i

I'm no expert or anything, but I've read a little through it and noticed this:

Sat Nov 24 14:59:32 2018 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Sat Nov 24 14:59:32 2018 daemon.notice hostapd: Channel 13 (primary) not allowed for AP mode
Sat Nov 24 14:59:32 2018 daemon.warn hostapd: wlan1: IEEE 802.11 Configured channel (13) not found from the channel list of current mode (1) IEEE 802.11g
Sat Nov 24 14:59:32 2018 daemon.warn hostapd: wlan1: IEEE 802.11 Hardware does not support configured channel

That's odd, as CH13 works fine in original firmware and it's also working if it has been started correctly once (I verified with WiFi Analyzer that it does indeed set it to CH13). When I tried OpenWRT (didn't like the complexity of it) I had no problems setting it to CH13 either.

Lantis
Moderator
Posts: 5010
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle 1.11.0 Release Candidate 4

Postby Lantis » Sat Nov 24, 2018 4:39 pm

Your config file sets the country specifically to NL right?
What appears to be happening is the device is reading the country code from EEPROM at boot as US, where channels 12-14 are not allowed. Thus the wifi can’t start.

Normally you would see another line indicating it is overriding the country based on user config.

If you checked a log after restarting the wifi to fix the issue, I think we would see this (happy to look if needed).

I don’t know that I can provide a good solution for this (yet). I don’t have any ath10k devices to test with myself, and I don’t see this behaviour in my own devices. The only thing I could suggest is creating an init script that runs last (or using rc.local) to kick start the wifi after boot to alleviate the issue.
Or switching to channels that would be allowed in the US.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

geochen2018
Posts: 6
Joined: Sun Nov 04, 2018 9:47 am

Re: Gargoyle 1.11.0 Release Candidate 4- Archer C7v5

Postby geochen2018 » Sun Nov 25, 2018 7:20 am

On archer C7v5 , EU version I was able to load via tftp openwrt v5 Development Snapshot build.
When I try to load via Luci web interface the last RC4 Gargoyle build, my router displays the message "The uploaded image does not contain a supported format. ""
I force loaded the image and the Router was bricked. I could recover it by tftp with factory image.
I can not load the Gargoyle image by tftp: I noted with wireshark that the first block of Gargoyle firmware has only zeros but the first block of TP-link or Openwrt contains a signature
Any suggestions ?
Thanks for a great job.

Lantis
Moderator
Posts: 5010
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle 1.11.0 Release Candidate 4- Archer C7v5

Postby Lantis » Sun Nov 25, 2018 7:52 am

geochen2018 wrote:On archer C7v5 , EU version I was able to load via tftp openwrt v5 Development Snapshot build.
When I try to load via Luci web interface the last RC4 Gargoyle build, my router displays the message "The uploaded image does not contain a supported format. ""
I force loaded the image and the Router was bricked. I could recover it by tftp with factory image.
I can not load the Gargoyle image by tftp: I noted with wireshark that the first block of Gargoyle firmware has only zeros but the first block of TP-link or Openwrt contains a signature
Any suggestions ?
Thanks for a great job.


This issue was only identified/fixed upstream in the last 48 hours:
https://git.openwrt.org/?p=openwrt/open ... 970e21972e

I'll look at trying to include it before release.

Note that Gargoyle is currently built off the 18.06 branch, and snapshot is built from Master, which may diverge significantly.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

Trailblazer
Posts: 111
Joined: Wed Mar 09, 2011 3:12 am

Re: Gargoyle 1.11.0 Release Candidate 4

Postby Trailblazer » Sun Nov 25, 2018 2:30 pm

You're talking release...that's exciting!
My C7v4 is running so well on 20181114-1101 I'm going to wait for the release. Great work!
Netgear WNDR3700V2 Gargoyle 1.10.0
TP-LINK Archer C7 v4 Gargoyle 1.11.x RC4


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: Dodgy Bob and 3 guests