[BROKEN] Gargoyle 1.11.0 Release Candidate 3

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

Trailblazer
Posts: 111
Joined: Wed Mar 09, 2011 3:12 am

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Trailblazer » Tue Nov 13, 2018 1:45 pm

I also have a Archer C7 v4 and the problem I'm having is that I can't change to any other channel than 36 for 5Ghz. If I do, the 5Ghz wifi light blinks once and then goes out. I assume that it doesn't 'like' any other channel. There's plenty of open channels with nothing on them. I tried in the middle of the spectrum and both ends.

My Build is Built 20180908-1151

Is this by design? Am I doing something incorrectly?
Thanks!
Netgear WNDR3700V2 Gargoyle 1.10.0
TP-LINK Archer C7 v4 Gargoyle 1.11.x RC4

Lantis
Moderator
Posts: 5134
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Lantis » Tue Nov 13, 2018 4:27 pm

@buggers
Add the USB profile instead of default as per your device target and re test. Check that /usr/lib/opkg/status exists, and that a lists file is generated.

@trailblazer
Did you set a wifi country through the GUI or were you not given an option? If so, which country.
Be aware that choosing channels 52-144 will have a 60 second delay before they come online (if they pass the test).
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

buggers
Posts: 22
Joined: Mon Jan 30, 2012 7:47 am

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby buggers » Tue Nov 13, 2018 6:43 pm

Followed your advice Lantis and the plugin list is now fully populated; no reboot was necessary in order to get:

Code: Select all

root@Gargoyle:~# ls -RlX /usr/lib/opkg/
/usr/lib/opkg/:
drwxr-xr-x    2 root     root           270 Sep  7 18:22 info
-rw-r--r--    1 root     root         52758 Sep  7 18:22 status

/usr/lib/opkg/info:
-rw-r--r--    1 root     root            38 Sep  7 18:22 dnsmasq.control
-rw-r--r--    1 root     root          1407 Sep  7 18:22 plugin-gargoyle-i18n-English-EN.list
-rw-r--r--    1 root     root           352 Sep  7 18:22 plugin-gargoyle-usb-storage-noshare.list
-rwxr-xr-x    1 root     root           355 Sep  7 18:22 plugin-gargoyle-i18n-English-EN.postrm
-rwxr-xr-x    1 root     root           117 Sep  7 18:22 plugin-gargoyle-i18n-English-EN.prerm
-rwxr-xr-x    1 root     root           117 Sep  7 18:22 plugin-gargoyle-usb-storage-noshare.prerm


When I unsuccessfully attempted to install:

Code: Select all

Webcam Support for Gargoyle
Version: 20130630-1
Status: Not Installed
Required Disk Space: 99.174 kBytes

I noticed the following log entry:

Code: Select all

daemon.err uhttpd[1866]: ERROR: Dependency kmod-video-uvc of package plugin-gargoyle-webcam cannot be found, try updating your package lists

Perhaps a LEDE/OpenWRT glitch?

Nevertheless, I would like to sincerely thank you for your invaluable contribution; my nine-year-old router feels brand new thanks to Gargoyle!

Lantis
Moderator
Posts: 5134
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Lantis » Wed Nov 14, 2018 1:31 am

I'll fix that one up for the next release.
All kmods that are required (even if not in use) should be included by default.

Alternatively, all kmods should be exported to another plugins repository so they can be installed. The only problem with that is that kmods are very specific as to which system they can be installed on. The kernel version must be right, and the checksum calculated at build time must also match.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

Trailblazer
Posts: 111
Joined: Wed Mar 09, 2011 3:12 am

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Trailblazer » Wed Nov 14, 2018 1:58 am

Lantis wrote:@trailblazer
Did you set a wifi country through the GUI or were you not given an option? If so, which country.
Be aware that choosing channels 52-144 will have a 60 second delay before they come online (if they pass the test).


I did get that prompt to set the country on first boot, which I believe 'Global' was the only option?? Okay, I did not know about the 60 second delay, so I will try again and give it some time. Thanks Lantis.
Netgear WNDR3700V2 Gargoyle 1.10.0
TP-LINK Archer C7 v4 Gargoyle 1.11.x RC4

Trailblazer
Posts: 111
Joined: Wed Mar 09, 2011 3:12 am

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Trailblazer » Wed Nov 14, 2018 2:00 am

buggers wrote:Nevertheless, I would like to sincerely thank you for your invaluable contribution; my nine-year-old router feels brand new thanks to Gargoyle!


Yeah, I've been around the block a time or two and I keep coming back to Gargoyle. It just fits my needs while others seem lacking.
Netgear WNDR3700V2 Gargoyle 1.10.0
TP-LINK Archer C7 v4 Gargoyle 1.11.x RC4

Waterspuwer
Posts: 32
Joined: Mon Nov 12, 2018 6:04 am

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Waterspuwer » Wed Nov 14, 2018 4:52 am

I just updated to RC4 and the plugins are indeed working.

I also kept the config from RC1. The other issues I've previously reported still exist.
It would also be nice if the (non-built in) plugin sources would migrate on update.

User avatar
danielwritesback
Posts: 23
Joined: Sun Sep 23, 2018 8:55 am
Contact:

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby danielwritesback » Thu Nov 15, 2018 2:43 am

You may have heard some negative. However, what you have accomplished amazes. Had someone told me that a mid level atheros could do low lag routinely and that QOS would be easy to do, I'd never believed it. Yet you have achieved it already.
Last edited by danielwritesback on Thu Nov 15, 2018 10:37 am, edited 1 time in total.

Lantis
Moderator
Posts: 5134
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby Lantis » Thu Nov 15, 2018 3:59 am

buggers wrote:Followed your advice Lantis and the plugin list is now fully populated; no reboot was necessary in order to get:

Code: Select all

root@Gargoyle:~# ls -RlX /usr/lib/opkg/
/usr/lib/opkg/:
drwxr-xr-x    2 root     root           270 Sep  7 18:22 info
-rw-r--r--    1 root     root         52758 Sep  7 18:22 status

/usr/lib/opkg/info:
-rw-r--r--    1 root     root            38 Sep  7 18:22 dnsmasq.control
-rw-r--r--    1 root     root          1407 Sep  7 18:22 plugin-gargoyle-i18n-English-EN.list
-rw-r--r--    1 root     root           352 Sep  7 18:22 plugin-gargoyle-usb-storage-noshare.list
-rwxr-xr-x    1 root     root           355 Sep  7 18:22 plugin-gargoyle-i18n-English-EN.postrm
-rwxr-xr-x    1 root     root           117 Sep  7 18:22 plugin-gargoyle-i18n-English-EN.prerm
-rwxr-xr-x    1 root     root           117 Sep  7 18:22 plugin-gargoyle-usb-storage-noshare.prerm


When I unsuccessfully attempted to install:

Code: Select all

Webcam Support for Gargoyle
Version: 20130630-1
Status: Not Installed
Required Disk Space: 99.174 kBytes

I noticed the following log entry:

Code: Select all

daemon.err uhttpd[1866]: ERROR: Dependency kmod-video-uvc of package plugin-gargoyle-webcam cannot be found, try updating your package lists

Perhaps a LEDE/OpenWRT glitch?

Nevertheless, I would like to sincerely thank you for your invaluable contribution; my nine-year-old router feels brand new thanks to Gargoyle!


Try adding this one as a plugin repository as well:
http://lantisproject.com/gargoyle_1.11. ... elspecific
Hopefully that fixes your issue.
(note that if you read this in the next 5 minutes it will still be uploading, so hopefully you're not that quick).
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

buggers
Posts: 22
Joined: Mon Jan 30, 2012 7:47 am

Re: [BROKEN] Gargoyle 1.11.0 Release Candidate 3

Postby buggers » Thu Nov 15, 2018 5:41 am

Hi Lantis and thanks for the follow-up.
I added the new repository without removing the previous one:

Code: Select all

root@Gargoyle:~# gpkg update
Downloading package list for openwrt_18.06-snapshot_telephony source...
Package list for openwrt_18.06-snapshot_telephony downloaded successfully.

Downloading package list for openwrt_18.06-snapshot_routing source...
Package list for openwrt_18.06-snapshot_routing downloaded successfully.

Downloading package list for gargoyle_1-11-x_rc4_ar71xx_usb_large_kernelspecific source...
Package list for gargoyle_1-11-x_rc4_ar71xx_usb_large_kernelspecific downloaded successfully.

Downloading package list for gargoyle source...
Package list for gargoyle downloaded successfully.

Downloading package list for openwrt_18.06-snapshot_packages source...
Package list for openwrt_18.06-snapshot_packages downloaded successfully.

Downloading package list for openwrt_18.06-snapshot_base source...
Package list for openwrt_18.06-snapshot_base downloaded successfully.

Downloading package list for gargoyle_1-11-x_rc4_ar71xx_usb source...
Package list for gargoyle_1-11-x_rc4_ar71xx_usb downloaded successfully.

Downloading package list for openwrt_18.06-snapshot_management source...
Package list for openwrt_18.06-snapshot_management downloaded successfully.


But still:

Code: Select all

root@Gargoyle:~# gpkg install plugin-gargoyle-webcam
ERROR: Dependency kmod-video-uvc of package plugin-gargoyle-webcam cannot be found, try updating your package lists



For me it is not a big issue at all; I am pretty certain that you have much higher priorities that could benefit a far larger portion of Gargoyle's community.
I strongly believe that those of us who are stuck with 8 MB routers ought to thank you for taking the external root initiative, allowing us to enjoy the latest Gargoyle release!


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 25 guests