gargoyle-ispy 2017-December-22 08:13

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

Lantis
Moderator
Posts: 5009
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2017-December-22 08:13

Postby Lantis » Tue Dec 26, 2017 11:24 pm

ektus wrote:
Lantis wrote:Which version did it last work with?
I fixed some share issues in the last few months

It works with 1.10.0. I just confirmed it by downgrading to that version, again preserving settings.

It's a very basic share, no passwords or users apart from the default anonymous, with full access from the local network. It has been installed just a couple months ago, replacing a 10+ year old dedicated NAS.

Regards
Ektus.


Can you please provide your exact settings so I can test?
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

ektus
Posts: 166
Joined: Sun Aug 11, 2013 2:26 am
Location: Germany

Re: gargoyle-ispy 2017-December-22 08:13

Postby ektus » Wed Dec 27, 2017 2:32 am

Lantis wrote:
ektus wrote:It's a very basic share, no passwords or users apart from the default anonymous, with full access from the local network. It has been installed just a couple months ago, replacing a 10+ year old dedicated NAS.


Can you please provide your exact settings so I can test?


Sure. Currently working installation of 1.10.0, file /tmp/etc/smb.conf

Code: Select all

[global]
        netbios name = Gargoyle
        display charset = UTF-8
        interfaces = 127.0.0.1/8 lo 192.168.0.180/24 br-lan
        server string = Samba on Gargoyle
        unix charset = UTF-8
        workgroup = AHORNBERG
        browseable = yes
        deadtime = 30
        domain master = yes
        encrypt passwords = true
        enable core files = no
        guest account = root
        guest ok = yes
        local master = yes
        load printers = no
        map to guest = Bad User
        max protocol = SMB2
        min receivefile size = 16384
        null passwords = yes
        obey pam restrictions = yes
        os level = 20
        passdb backend = smbpasswd
        preferred master = yes
        printable = no
        security = user
        smb encrypt = disabled
        smb passwd file = /etc/samba/smbpasswd
        socket options = TCP_NODELAY IPTOS_LOWDELAY
        syslog = 2
        use sendfile = yes
        writeable = yes


[PUBLIC]
        path = /tmp/usb_mount/bfc6aa91-01
        write list = admin
        read only = no
        guest ok = yes
        create mask = 0777
        directory mask = 0777
        browseable = yes


Are there more config files? The password file exists and contains some encrypted string for user "admin", but that shouldn't matter as anonymous access is allowed.

What I did:
- Attach new HDD.
- Format as EXT4.
- Create share for the root directory with full access from the local network.
- Copy over some 250GB of data from the old NAS

The command "mount" shows

Code: Select all

/dev/sda1 on /tmp/share_home/anonymous/PUBLIC type ext4 (rw,noatime,data=ordered)


After updating to 1.10.X from this thread, the share was still visible (both size and contents of root directory), but accessing any files or folders was denied.


Regards
Ektus.

Lantis
Moderator
Posts: 5009
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2017-December-22 08:13

Postby Lantis » Wed Dec 27, 2017 5:08 am

Have you tried setting up the config from scratch on 1.10.x?
your config looks incompatible with the changes that occurred.

I would try this first.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

ektus
Posts: 166
Joined: Sun Aug 11, 2013 2:26 am
Location: Germany

Re: gargoyle-ispy 2017-December-22 08:13

Postby ektus » Wed Dec 27, 2017 6:57 am

Lantis wrote:Have you tried setting up the config from scratch on 1.10.x?
your config looks incompatible with the changes that occurred.

I would try this first.

I'm a little reluctant at doing so, as when I was first configuring it, I somehow lost access soon after copying the data and upon re-entering the config lost all data on the drive.

I've got the impression the GUI would format the drive if it didn't recognize it correctly at the first try, but didn't investigate further.

I'll try and take a USB stick for testing, perhaps later today.


Regards
Ektus.

ektus
Posts: 166
Joined: Sun Aug 11, 2013 2:26 am
Location: Germany

Re: gargoyle-ispy 2017-December-22 08:13

Postby ektus » Wed Dec 27, 2017 2:50 pm

Okay, got a spare USB stick (4GB) to test. It works with 1.10.0 but doesn't with 1.10.X, same as before. Deleting the share and creating a new one didn't change anything. Still only the root directory visible, access denied to files and folders.

Current SMB.CONF, created with 1.10.X:

Code: Select all

[global]
        netbios name = Gargoyle
        display charset = UTF-8
        interfaces = 127.0.0.1/8 lo 192.168.0.180/24 br-lan
        server string = Samba on Gargoyle
        unix charset = UTF-8
        workgroup = AHORNBERG
        browseable = yes
        deadtime = 30
        domain master = yes
        encrypt passwords = true
        enable core files = no
        guest account = nobody
        guest ok = yes
        local master = yes
        load printers = no
        map to guest = Bad User
        max protocol = SMB2
        min receivefile size = 16384
        null passwords = yes
        obey pam restrictions = yes
        os level = 20
        passdb backend = smbpasswd
        preferred master = yes
        printable = no
        security = user
        smb encrypt = disabled
        smb passwd file = /etc/samba/smbpasswd
        socket options = TCP_NODELAY IPTOS_LOWDELAY
        syslog = 2
        use sendfile = yes
        writeable = yes


[PUBLIC]
        path = /tmp/usb_mount/dev_sda1
        valid users = admin, nobody
        write list = admin
        read only = no
        guest ok = yes
        create mask = 0777
        directory mask = 0777
        browseable = yes



Regards
Ektus.

Lantis
Moderator
Posts: 5009
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2017-December-22 08:13

Postby Lantis » Sun Dec 31, 2017 11:00 pm

ektus wrote:Okay, got a spare USB stick (4GB) to test. It works with 1.10.0 but doesn't with 1.10.X, same as before. Deleting the share and creating a new one didn't change anything. Still only the root directory visible, access denied to files and folders.

Current SMB.CONF, created with 1.10.X:

Code: Select all

[global]
        netbios name = Gargoyle
        display charset = UTF-8
        interfaces = 127.0.0.1/8 lo 192.168.0.180/24 br-lan
        server string = Samba on Gargoyle
        unix charset = UTF-8
        workgroup = AHORNBERG
        browseable = yes
        deadtime = 30
        domain master = yes
        encrypt passwords = true
        enable core files = no
        guest account = nobody
        guest ok = yes
        local master = yes
        load printers = no
        map to guest = Bad User
        max protocol = SMB2
        min receivefile size = 16384
        null passwords = yes
        obey pam restrictions = yes
        os level = 20
        passdb backend = smbpasswd
        preferred master = yes
        printable = no
        security = user
        smb encrypt = disabled
        smb passwd file = /etc/samba/smbpasswd
        socket options = TCP_NODELAY IPTOS_LOWDELAY
        syslog = 2
        use sendfile = yes
        writeable = yes


[PUBLIC]
        path = /tmp/usb_mount/dev_sda1
        valid users = admin, nobody
        write list = admin
        read only = no
        guest ok = yes
        create mask = 0777
        directory mask = 0777
        browseable = yes



Regards
Ektus.



I tested the exact same settings and it behaved as expected. Is your client misbehaving?
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

ektus
Posts: 166
Joined: Sun Aug 11, 2013 2:26 am
Location: Germany

Re: gargoyle-ispy 2017-December-22 08:13

Postby ektus » Mon Jan 01, 2018 11:39 am

Lantis wrote:I tested the exact same settings and it behaved as expected. Is your client misbehaving?


I don't know, but with three different clients (Win XP, Win 7 and Android)? Unlikely.

Has there been an update of the kernel or smb module, perhaps trying to enforce password protection and/or encryption? There must be some difference between 1.10.0 and 1.10.X, but where?

Happy New Year!

Ektus.

Lantis
Moderator
Posts: 5009
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: gargoyle-ispy 2017-December-22 08:13

Postby Lantis » Mon Jan 01, 2018 5:29 pm

The changes made fixed an error I created a while ago where ANY valid user could login to ANY share even if that user was not allowed. Bad stuff.

I wouldn’t trust the way windows handles SMB. The android should be fine.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 2 guests