1.3.8 300Mbps Wireless Link

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

Gingernut
Posts: 28
Joined: Fri Jun 05, 2009 9:51 am

1.3.8 300Mbps Wireless Link

Postby Gingernut » Sat Nov 27, 2010 5:59 pm

A WZR-HP-G300NH on Gargoyle 1.3.8, I'm unable to get a 300Mbps link, with Original, Backfire, and DD-Wrt firmwares I can with the same wireless settings.

It seems like it's transmitting in 20MHz mode instead of 40MHz.

Here is how I have it set on Connection--Basic--Wireless:

Code: Select all

Access Point (AP)
N+G+B
40MHz
WPA-PSK Encryption


Output from cat /etc/config/wireless:

Code: Select all

config 'wifi-device' 'radio0'
   option 'type' 'mac80211'
   option 'macaddr' '*******'
   option 'hwmode' '11ng'
   list 'ht_capab' 'SHORT-GI-40'
   list 'ht_capab' 'DSSS_CCK-40'
   option 'channel' '6'
   option 'htmode' 'HT40+'

config 'wifi-iface' 'cfg2'
   option 'device' 'radio0'
   option 'mode' 'ap'
   option 'network' 'lan'
   option 'ssid' 'Gargoyle'
   option 'encryption' 'psk'
   option 'key' '****'


Code: Select all

cat /etc/hostapd.conf
cat: can't open '/etc/hostapd.conf': No such file or directory

vplessky
Posts: 60
Joined: Sun Oct 31, 2010 10:31 am
Location: Moscow, Russia
Contact:

Re: 1.3.8 300Mbps Wireless Link

Postby vplessky » Sat Nov 27, 2010 6:02 pm

Try
option 'htmode' 'HT40-'
instead of
option 'htmode' 'HT40+'

BTW: how you decided on using Channel 6?
What channel is selected in factory firmware/Auto mode?

Gingernut
Posts: 28
Joined: Fri Jun 05, 2009 9:51 am

Re: 1.3.8 300Mbps Wireless Link

Postby Gingernut » Sat Nov 27, 2010 7:50 pm

vplessky wrote:Try
option 'htmode' 'HT40-'
instead of
option 'htmode' 'HT40+'


I've tried that but with no luck. When I manually change this in wireless config in Gargoyle's web gui channel width gets set to 20MHz and if I set it back to 40MHz in web gui, in wireless config it goes back to HT40+.

BTW: how you decided on using Channel 6?
What channel is selected in factory firmware/Auto mod?


I have it set to channel 6 because it gives me better coverage than others. I also have another AP on channel 11.

Thanks

r0ck
Posts: 9
Joined: Wed Nov 17, 2010 9:57 pm

Re: 1.3.8 300Mbps Wireless Link

Postby r0ck » Sun Nov 28, 2010 12:33 am

I had a similar problem on the same model of router. Turned out there was another router operating at 40MHz on the same channel in the vicinity. Try 'wifi up' from the command line and see if that gives an error. Can't remember exactly what the error said, something about overlapping BSSID maybe?

Changing the channel in /etc/config/wireless, saving it and issuing the 'wifi up' command helped. Trial and error needed here.

User avatar
DoesItMatter
Moderator
Posts: 1373
Joined: Thu May 21, 2009 3:56 pm

Re: 1.3.8 300Mbps Wireless Link

Postby DoesItMatter » Tue Nov 30, 2010 2:08 am

root@Gargoyle:~# wifi up
Configuration file: /var/run/hostapd-phy0.conf
20/40 MHz operation not permitted on channel pri=2 sec=6 based on overlapping BSSes
Using interface wlan0 with hwaddr 00:1d:73:b4:68:65 and ssid 'Gargoyle'
root@Gargoyle:~# wifi up
Configuration file: /var/run/hostapd-phy0.conf
20/40 MHz operation not permitted on channel pri=3 sec=7 based on overlapping BSSes
Using interface wlan0 with hwaddr 00:1d:73:b4:68:65 and ssid 'Gargoyle'
root@Gargoyle:~# wifi up
Configuration file: /var/run/hostapd-phy0.conf
20/40 MHz operation not permitted on channel pri=7 sec=11 based on overlapping BSSes
Using interface wlan0 with hwaddr 00:1d:73:b4:68:65 and ssid 'Gargoyle'
root@Gargoyle:~# wifi up
Configuration file: /var/run/hostapd-phy0.conf
20/40 MHz operation not permitted on channel pri=1 sec=5 based on overlapping BSSes
Using interface wlan0 with hwaddr 00:1d:73:b4:68:65 and ssid 'Gargoyle'
root@Gargoyle:~# wifi up
Configuration file: /var/run/hostapd-phy0.conf
20/40 MHz operation not permitted on channel pri=6 sec=10 based on overlapping BSSes
Using interface wlan0 with hwaddr 00:1d:73:b4:68:65 and ssid 'Gargoyle'
root@Gargoyle:~#

-------------------------

I am getting the same errors - tried a lot of channels.

Is there a way to force it even though there is overlap?
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43 Merlin
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.9.x / LEDE 17.01.x
2x Engenius - ESR900 Stock 1.4.0 / OpenWRT Trunk 49400

r0ck
Posts: 9
Joined: Wed Nov 17, 2010 9:57 pm

Re: 1.3.8 300Mbps Wireless Link

Postby r0ck » Tue Nov 30, 2010 8:20 am

http://wiki.openwrt.org/doc/uci/wireless

Look at option 'noscan' under the Wifi-Devices Common Options section. You'll have to set it to '1' from the default '0'. However, it's not recommended and it seems to get overwritten by any changes in the GUI.

User avatar
DoesItMatter
Moderator
Posts: 1373
Joined: Thu May 21, 2009 3:56 pm

Re: 1.3.8 300Mbps Wireless Link

Postby DoesItMatter » Fri Dec 03, 2010 12:39 pm

The NoScan setting worked and allowed it to do the 40 mhz

With DD-WRT - it just goes ahead and allows whatever channel
you choose - I guess they don't follow the 'regulatory' settings
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43 Merlin
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.9.x / LEDE 17.01.x
2x Engenius - ESR900 Stock 1.4.0 / OpenWRT Trunk 49400


Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 0 guests