Version 1.9.1

The latest news about Gargoyle

Moderator: Moderators

LHoust
Posts: 18
Joined: Fri May 27, 2011 1:22 pm
Location: Canada

Re: Version 1.9.1

Post by LHoust »

Following the initial upgraded my TP-WR1043ND V2.1 from V1.9.0 (with Setting Preserved), I had been able to Save the Router's Configuration. A month later all of my Attempts to Save the Router's Configuration Fail, the result being the Router would Reboot itself each time! Web Browsers used for these attempts were Firefox, Chrome, IE 11 and Edge under Window 10 Home.

I Reset the TP-WR1043ND V2.1 using the Router's Reset Button (30 Seconds), Reconfigured the Router and I am now able to Save the Router's Configuration???

Particularities of my Configuration are: No Wireless, PPPoE, 105 DHCP (Ethers) Entries, 3 Inbound Ports and an External USB Drive. The only changes since the Initial Configuration had been successfully saved were related to re-entering Password for the Shared Folders (which Lantis told me was expected since I had upgraded from 1.9.0 with settings preserved) and changes to the DHCP Entries.

NOTE: With so many DHCP Entries I did have problems with my DHCP Table being Truncated when I was running V1.8.0 and V1.8.1 on a TP-WR941ND V3.6 Router, although with the V1.9.X Series on the TP-WR1043ND V2.1 Router that has NOT been an "Issue"...

gumball3000
Posts: 28
Joined: Mon Apr 08, 2013 8:20 am

Re: Version 1.9.1

Post by gumball3000 »

I upgraded my 1043nd v2.1 from 1.9.0 to 1.9.1 without preserving settings, and everything goes smoothly.

If you preserved settings from previous versions, for God's sake, please stop whining here.

sajjadhalai
Posts: 108
Joined: Sun Apr 08, 2012 6:54 am

Re: Version 1.9.1

Post by sajjadhalai »

Thanx for a very improved form of gargoyle. your work is appriciateable.

I have Bufallo WZR-600-DHP
but i got some problem, when i enable Qos Upload stream then i can not have internet access.
i saw rply posts that the problem is in layer 7.

is there any update so i can preserve settings. or any downgrade version so settings could b preserved.

2. in Firewall Quota page. table sorting is not working in WZR 600DHP, but it was working in 1043 v2

3. In Status Qouta Usage Page have Percent used /bytes use/ limit is selectable of any one... can it be all in one collumns. as it is in Login page.

reditburd
Posts: 12
Joined: Sat Jan 25, 2014 3:45 pm

Re: Version 1.9.1

Post by reditburd »

Just like to chime in here and say that I read the shortlist of updates and upgraded from 1.8 and was surprised when the kids started complaining that the Xbox was talking about a lack of UPNP.

If you are going to remove major features on an upgrade mention it boldly in the short list of upgrade notes.

:?

Lantis
Moderator
Posts: 5767
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.9.1

Post by Lantis »

reditburd wrote:Just like to chime in here and say that I read the shortlist of updates and upgraded from 1.8 and was surprised when the kids started complaining that the Xbox was talking about a lack of UPNP.

If you are going to remove major features on an upgrade mention it boldly in the short list of upgrade notes.

:?


viewtopic.php?f=3&t=7859#p33222
It was mentioned in the last version.

http://www.gargoyle-router.com/wiki/doku.php?id=1.9.x
And it was mentioned on the change log page
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Lantis
Moderator
Posts: 5767
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.9.1

Post by Lantis »

petbrau wrote:The german translation of TOR is defective.

Workaround:
If the english file /www/i18n/English-EN/tor.js is copied into the folder /plugin_root/www/i18n/German-DE the TOR page is usable.
If the english text of this tor.js file is exchanged by the german text (the german tor.js file was saved before) the german translation works as expected.


I have addressed this issue for the next version.
https://github.com/lantis1008/gargoyle/ ... 3dcf3bca79

The BOM was missing at the beginning of the file.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

frosty
Posts: 8
Joined: Wed Jul 13, 2016 7:02 am
Location: Germany

Re: Version 1.9.1

Post by frosty »

gumball3000 wrote:I upgraded my 1043nd v2.1 from 1.9.0 to 1.9.1 without preserving settings, and everything goes smoothly.

If you preserved settings from previous versions, for God's sake, please stop whining here.


jeez, that post is quite ignorant...

this is the discussion forum for the current release of the gargoyle firmware, the point of this forum is to actually talk about problems and issues regarding that release.
as the 'preserve settings' option is a part of that release, it is only natural to point out flaws in the implementation.

furthermore: the perceived consensus here was that you shouldn't preserve when flashing upgrades with major differences. a reversion change 1.9.0 -> 1.9.1 does not qualify for me as a major upgrade.

in short: this is not about 'whining' as you have so eloquently put it, this is about letting the devs know that there is something wrong with that option, especially for the last release on wr1043nd, as most of the bricks have occurred on that device.

so just be happy that couple of people have tried to flash before you and have given their input. if anything you should be thankful that users are letting others know what to expect so that you won't have to serial unbrick..., or whine..., or anything...

ispyisail
Moderator
Posts: 4882
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.9.1

Post by ispyisail »

@frosty

The Dev's know about the problem


You can attempt to preserve your old settings by ticking Attempt to Preserve Settings below. Be aware that this can potentially lead to problems if the new version is significantly newer than the old version, but for small, incremental differences this will likely work. It is always best to keep a backup just in case.


.......likely work


Not always



My advice is to any user who attempts to use "Attempt to Preserve Settings" before posting anywhere about any problems, first do a failsafe reset to check the problem still exists.


"Attempt to Preserve Settings" is a known problem

ctsffd
Posts: 3
Joined: Tue Aug 16, 2016 9:02 pm

Re: Version 1.9.1

Post by ctsffd »

Hi:
Linksys WRT400n
flashed ok 1.9.1 from 1.6.2
Reboot or power cycle will lost configurations and router return to factory default.
This not happen on 1.6.2.

Any suggestion?

Ron

Lantis
Moderator
Posts: 5767
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.9.1

Post by Lantis »

Firstboot reset or reflashing 1.9.1 then try again.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Post Reply