Version 1.9.1

The latest news about Gargoyle

Moderator: Moderators

Eric
Site Admin
Posts: 1433
Joined: Sat Jun 14, 2008 1:14 pm

Version 1.9.1

Postby Eric » Wed Jul 06, 2016 3:08 pm

New in 1.9.1:

  • New rampis architecture is supported
  • Handle wireless AC routers properly
  • Allow SSH access using public key authentication
  • Quota usage table can be displayed by percentage or usage, with colors
  • Fixes guest access in Samba & preserve Samba passwords through upgrade
  • Fixes guest network routing by including proper ebtables module
  • Fixes issues with (simple) Quota QoS limits
  • Properly preserve time/date format through upgrade
  • Web server and dynamic DNS utilities now linked to polarssl instead of cyassl
  • OpenWRT Chaos Calmer version bumped to r49261 (git commit eadf19c0b43d2f75f196ea8d875a08c7c348530c)
  • Tor updated to version 0.2.7.6

ispyisail
Moderator
Posts: 3325
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Version 1.9.1

Postby ispyisail » Wed Jul 06, 2016 3:16 pm

+1

petbrau
Posts: 28
Joined: Fri Jan 29, 2016 2:08 pm

Re: Version 1.9.1

Postby petbrau » Wed Jul 06, 2016 4:17 pm

The german translation of TOR is defective.

Workaround:
If the english file /www/i18n/English-EN/tor.js is copied into the folder /plugin_root/www/i18n/German-DE the TOR page is usable.
If the english text of this tor.js file is exchanged by the german text (the german tor.js file was saved before) the german translation works as expected.

Adri
Posts: 46
Joined: Wed Jul 20, 2011 4:03 am

Re: Version 1.9.1

Postby Adri » Thu Jul 07, 2016 7:44 am

Both the factory and sysupgrade images for the wrt160nl are corrupt.
Size is less then 1Kb.

I just bricked my router flashing!

tapper
Moderator
Posts: 992
Joined: Sun Oct 13, 2013 5:49 pm
Location: Stoke-on-trent UK

Re: Version 1.9.1

Postby tapper » Thu Jul 07, 2016 9:53 am

flashed my c7 and had no 5 ghz had to go back to last 1.9.x
TP-Link WR1043ND v2.1 Gargoyle 1.6.2
Western Digital My Net N750 Gargoyle 1.9x
TP-Link TL-WDR3600 V1.5 Gargoyle 1.9x
TP-Link Archer C7 Gargoyle 1.9x
Linksys WRT1900AC V2 Gargoyle 1.9x
Linksys WRT3200ACM LEDE 17.1

Eric
Site Admin
Posts: 1433
Joined: Sat Jun 14, 2008 1:14 pm

Re: Version 1.9.1

Postby Eric » Thu Jul 07, 2016 12:53 pm

It looks like a few of the images are corrupt.. sorry about that.

I'm looking into what caused that and fixing it now.

Eric
Site Admin
Posts: 1433
Joined: Sat Jun 14, 2008 1:14 pm

Re: Version 1.9.1

Postby Eric » Thu Jul 07, 2016 8:33 pm

I'm not sure why, but for some reason when I did the initial build a few of the ar71xx devices including the 160nl produced invalid firmware images.

I did a new build, and re-uploaded, and this time everything seems fine.

Please let me know if you see any other images that are corrupted.

LHoust
Posts: 18
Joined: Fri May 27, 2011 1:22 pm
Location: Canada

Re: Version 1.9.1

Postby LHoust » Thu Jul 07, 2016 10:52 pm

After upgrading my TL-WR1043ND v2.1 from V1.9.0. to V1.9.1 with Parameters being saved, I found I had to re-Enter and Save the Password for the Shares Folders stored on the 1 GIG USB Drive plugged into the TP-Link's USB Port.

Once completed, I was once again able to access the Existing Shared Folders from my Windows Machines!

Lantis
Moderator
Posts: 3283
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Version 1.9.1

Postby Lantis » Fri Jul 08, 2016 12:09 am

LHoust wrote:After upgrading my TL-WR1043ND v2.1 from V1.9.0. to V1.9.1 with Parameters being saved, I found I had to re-Enter and Save the Password for the Shares Folders stored on the 1 GIG USB Drive plugged into the TP-Link's USB Port.

Once completed, I was once again able to access the Existing Shared Folders from my Windows Machines!


This is expected. 1.9.0 didn't properly respect the preservation of share passwords.
From now on when you upgrade it should be ok!
But certainly report back if you see otherwise so I can have another look at it.
WNDR3800 on 1.9.X
WRT1900AC V1 on 1.9.X
www.lantisproject.com for custom builds and other projects

Adri
Posts: 46
Joined: Wed Jul 20, 2011 4:03 am

Re: Version 1.9.1

Postby Adri » Fri Jul 08, 2016 7:36 am

Eric wrote:I'm not sure why, but for some reason when I did the initial build a few of the ar71xx devices including the 160nl produced invalid firmware images.

I did a new build, and re-uploaded, and this time everything seems fine.

Please let me know if you see any other images that are corrupted.

Thanks Eric,

I'll download the new images and try again.


Return to “News”

Who is online

Users browsing this forum: ku1185 and 1 guest