Hi...
I've only just stepped into the world of flashing modems after flashing an old TP-Link TL-WR1043ND v1 I found in the office. I've got openwrt installed on it at the moment, but really like the options in Gargoyle with regards to qos and family/parental control settings.
One thing I'm not sure is if Gargoyle supports dhcp options 60/61? In the UK we have a vdsl provider who uses this weird authentication method. It works fine on openwrt, but am hoping it works on Gargoyle.
Thanks
UK Sky Fibre & MER dhcp options 60/61
Moderator: Moderators
-
- Posts: 9
- Joined: Thu Apr 21, 2016 7:55 am
UK Sky Fibre & MER dhcp options 60/61
Last edited by spazmonkey on Sun Apr 24, 2016 4:14 pm, edited 1 time in total.
-
- Posts: 9
- Joined: Thu Apr 21, 2016 7:55 am
Re: Sky Fibre & MER dhcp options 60/61
Just to add in openwrt I get the following 2 options...
Client ID to send when requesting DHCP
Vendor Class to send when requesting DHCP
Those options allow me to connect using a hex username and password.
Do these options exist in Gargoyle?
Client ID to send when requesting DHCP
Vendor Class to send when requesting DHCP
Those options allow me to connect using a hex username and password.
Do these options exist in Gargoyle?
-
- Posts: 14
- Joined: Sun Jun 02, 2013 6:51 am
Re: Sky Fibre & MER dhcp options 60/61
They don't exist as an extra option in the Web interface, but I am quite sure that you can achieve the same result if you log in via SSH and then edit the appropriate file. I would guess that would be /etc/config/network.spazmonkey wrote:Just to add in openwrt I get the following 2 options...
Client ID to send when requesting DHCP
Vendor Class to send when requesting DHCP
Those options allow me to connect using a hex username and password.
Do these options exist in Gargoyle?
If you have a working OpenWRT installation, you can easily check for this by going through the files in the /etc/config directory and see where the hexadecimal string has ended up. If you copy the relevant section and make the same edits in a Gargoyle installation, I think you'll find that everything is working hunky-dory.
If you document the process for others to follow here then it will be useful for other who want to achieve the same.
-
- Posts: 9
- Joined: Thu Apr 21, 2016 7:55 am
Re: Sky Fibre & MER dhcp options 60/61
Would you be able to help me?
Here is the /etc/config/network file with the client id and vendorid details removed...
Would you be able to add the two options under WAN and let me know if they show up in your gui, or would that not work?
I'd rather not flash the router with a new firmware without knowing if it will work.
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.0.253'
option dns '8.8.8.8 8.8.4.4'
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option clientid
option vendorid
config switch
option reset '1'
option enable_vlan '1'
option name 'switch0'
config switch_vlan
option vlan '1'
option ports '1 2 3 4 5t'
option device 'switch0'
config switch_vlan
option vlan '2'
option ports '0 5t'
option device 'switch0'
config route
Here is the /etc/config/network file with the client id and vendorid details removed...
Would you be able to add the two options under WAN and let me know if they show up in your gui, or would that not work?
I'd rather not flash the router with a new firmware without knowing if it will work.
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.0.253'
option dns '8.8.8.8 8.8.4.4'
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option clientid
option vendorid
config switch
option reset '1'
option enable_vlan '1'
option name 'switch0'
config switch_vlan
option vlan '1'
option ports '1 2 3 4 5t'
option device 'switch0'
config switch_vlan
option vlan '2'
option ports '0 5t'
option device 'switch0'
config route
-
- Posts: 14
- Joined: Sun Jun 02, 2013 6:51 am
Re: Sky Fibre & MER dhcp options 60/61
Well, perhaps I didn't phrase my suggestion properly, but what I meant to say that on your new Gargoyle installation, you should add exactly those two options clientid and vendor id.spazmonkey wrote:Would you be able to help me?
Would you be able to add the two options under WAN and let me know if they show up in your gui, or would that not work?
I'd rather not flash the router with a new firmware without knowing if it will work.
[...]
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option clientid
option vendorid
At least, those two options I assume are the ones that were added by OpenWRT if you follow the same guide that I found on-line.
There is nothing in the GUI (webinterface) you can see about this, but this doesn't mean that it won't work of course. In fact, I am quite sure it will.
For example, my installation is tweaked heavily through a customised dnsmasq.conf and I've installed additional services that don't exist as a plugin on Gargoyle. None of these show up in the GUI, but they do work as expected.
In my case, the GUI for Gargoyle is just great for presenting traffic totals and graphs in a useful manner and to have a VPN to my house without too much effort.
That's the beauty I guess, with OpenWRT and Gargoyle we a have a very nice base to work from and customise to our heart's content.
Good luck and do report back how you got on!

-
- Posts: 9
- Joined: Thu Apr 21, 2016 7:55 am
Re: Sky Fibre & MER dhcp options 60/61
Thanks.
I may give it a go in the morning.
I may give it a go in the morning.
-
- Posts: 9
- Joined: Thu Apr 21, 2016 7:55 am
Re: Sky Fibre & MER dhcp options 60/61
Just to report back that I was able to edit the Gargoyle network file with the required parameters and I'm now up and running.
For anyone that has to do the same update, add the following strings:
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option dns '8.8.8.8 8.8.4.4'
option peerdns '0'
option clientid 'your hex password here'
option vendorid '6.14.1aN_UNI|PCBAFAST2504Nv1.0'
If you need help obtaining your password, follow this thread:
http://www.skyuser.co.uk/forum/printthread.php?t=50483
Thanks for the advice. Much prefer Gargoyle to openwrt.
For anyone that has to do the same update, add the following strings:
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option dns '8.8.8.8 8.8.4.4'
option peerdns '0'
option clientid 'your hex password here'
option vendorid '6.14.1aN_UNI|PCBAFAST2504Nv1.0'
If you need help obtaining your password, follow this thread:
http://www.skyuser.co.uk/forum/printthread.php?t=50483
Thanks for the advice. Much prefer Gargoyle to openwrt.