Plugin List not updating: plugin-gargoyle-tor missing

Report problems and success stories with Gargoyle on various hardware platforms.

Moderator: Moderators

portion
Posts: 8
Joined: Sat Dec 31, 2016 8:20 am

Plugin List not updating: plugin-gargoyle-tor missing

Post by portion »

Hi,

I wanted to install the plugin-gargoyle-tor, but no (other exept the default installed plugins) are listed in the webinterface.

Running opkg update on the shell reveals:
root@Gargoyle:~# opkg update
Downloading package list for barrier_breaker_routing source...
Package list for barrier_breaker_routing downloaded successfully.

Downloading package list for gargoyle source...
Package list for gargoyle downloaded successfully.

The gargole source is http://www.gargoyle-router.com/packages ... xx/default.

opkg list shows only the following plugins:
plugin-gargoyle-i18n-English-EN - 1.0.0-1
plugin-gargoyle-openvpn - 1.8.1-1
plugin-gargoyle-usb-printer - 1.8.1-1
plugin-gargoyle-usb-storage - 1.8.1-1


Is it the wrong package source? Or are plugins not included in 1.8.1 anymore and I have to add another source?
Or is the repository down? Because I also get a 404 at https://www.gargoyle-router.com/gargoyl ... rgoyle-tor and a 403 on http://www.gargoyle-router.com/packages ... /default...

Thanks for your help!

ispyisail
Moderator
Posts: 4809
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Plugin List not updating: plugin-gargoyle-tor missing

Post by ispyisail »

you need one of the more powerful routers?

Lantis
Moderator
Posts: 5525
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Plugin List not updating: plugin-gargoyle-tor missing

Post by Lantis »

What router? And what internet connection setup?

I'd have to downgrade a router to test, but the package repository is still online.
You get a 403 because you're not supposed to poke around there.
The router can grab packages from it no problem.

https://www.gargoyle-router.com/package ... t/Packages
You are allowed to navigate to that file, which shows what is available.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

portion
Posts: 8
Joined: Sat Dec 31, 2016 8:20 am

Re: Plugin List not updating: plugin-gargoyle-tor missing

Post by portion »

I am running the TL-WR1043ND v2 firmware on the TL-WR1043ND v3. Same issue with 1.9.1 and 1.8.1.
External USB-Drive is present, recognized and the plugin_path set to the Drive.

Internet connection is wireless through my main router and working. I get no error as you see in my previous post when updating the package sources.

Lantis
Moderator
Posts: 5525
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Plugin List not updating: plugin-gargoyle-tor missing

Post by Lantis »

Can you use a browser like Chrome or Firefox and press F12 to bring up the developer console.
Then refresh the page and see if any errors?
Also check a logread after refreshing the page.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

portion
Posts: 8
Joined: Sat Dec 31, 2016 8:20 am

Re: Plugin List not updating: plugin-gargoyle-tor missing

Post by portion »

I do not think it is a problem of the webinterface.

After using opkg update on the shell, i get:
root@Gargoyle:/# opkg update
[...]
Downloading package list for gargoyle source...
Package list for gargoyle downloaded successfully.
[...]
root@Gargoyle:/#

But when looking at the /tmp/opkg-lists/gargoyle file, its contents should be the file Lantis directly linked in his earlier post. But my contents are:
root@Gargoyle:/tmp/opkg-lists# cat gargoyle
<html>
<head><title>301 Moved Permanently</title></head>
<body bgcolor="white">
<center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx</center>
</body>
</html>
root@Gargoyle:/tmp/opkg-lists#


The gargoyle source in my /etc/opkg.conf is the default one:


And when I manually do the following in /tmp/opkg-lists/ on the shell:
wget http://www.gargoyle-router.com/packages ... t/Packages
rm -rf gargoyle
mv Packages gargoyle

The packages are found with opkg list and the Plugin-Page of the webiface.

So it seems to be that opkg or wget do not accept the 301 moved permanently to the new destination. I think you use the 301 to forward to the https version?

portion
Posts: 8
Joined: Sat Dec 31, 2016 8:20 am

Re: Plugin List not updating: plugin-gargoyle-tor missing

Post by portion »

This appears to be a double post, but it is a followup and a solution to the problem:

I installed the real wget version as mentioned in https://wiki.openwrt.org/doc/howto/wget-ssl-certs.
So after opkg install wget I can now update the gargoyle packages with the 301 forward to SSL.
Updating plugins in webiface also works.

But now, the next problem:
When trying to hit install on the "Tor Anonymizer Support for Gargoyle" on the webiface, it does not get installed.
Logread says:
Sun Jan 1 15:58:17 2017 daemon.err uhttpd[1467]: ERROR: Could not download package obfsproxy
Sun Jan 1 15:58:17 2017 daemon.err uhttpd[1467]: An error occurred during Installation, removing partially installed packages.

Same on the shell:
root@Gargoyle:~# opkg install obfsproxy
Preparing to install the following packages, which will require 21898 bytes:
obfsproxy

Preparing to install package obfsproxy...
Downloading...
ERROR: Could not download package obfsproxy
An error occurred during Installation, removing partially installed packages.
[...]


What todo now?

I also noticed that opkg -d plugin_root install obfsproxy just pops up the help of the gpkg.

Maybe df -h is also interesting to you?
root@Gargoyle:~# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 768.0K 536.0K 232.0K 70% /
/dev/root 6.0M 6.0M 0 100% /rom
tmpfs 29.9M 760.0K 29.1M 2% /tmp
/dev/mtdblock3 768.0K 536.0K 232.0K 70% /overlay
overlayfs:/overlay 768.0K 536.0K 232.0K 70% /
tmpfs 512.0K 0 512.0K 0% /dev
/dev/sda1 1.4G 2.2M 1.3G 0% /tmp/usb_mount/0c2351e6-a1ca-4329-b87d-16924d2f5f08

portion
Posts: 8
Joined: Sat Dec 31, 2016 8:20 am

Re: Plugin List not updating: plugin-gargoyle-tor missing

Post by portion »

ok, third post in a row, sorry.

I have to revert the success I reported in my previous post.
Installing the GNU wget with ssl support does not the trick.
gpkg still does not follow the 301.

I just had installed GNU wget AND copied the /var/opkg-lists/Packages file from the repository to /var/opkg-lists/gargolye AND given the https address in opkg.conf, which resulted in an error when gpkg wanted to update and did not overwrite the /var/opkg-lists/gargolye...

So back to the Problem: How do I get gpkg to follow the 301 of the repository instead of downloading the 301-html-error page of ngnix?

Good night and thanks for your help!
-Peter

jorgecorazondeleon
Posts: 48
Joined: Tue Oct 02, 2012 5:27 pm

Re: Plugin List not updating: plugin-gargoyle-tor missing

Post by jorgecorazondeleon »

I have the same problem as portion
router:wr1043nd v1
gargoyle 1.6.2

Lantis
Moderator
Posts: 5525
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Plugin List not updating: plugin-gargoyle-tor missing

Post by Lantis »

Thanks for your investigation. I'll look into it
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

Post Reply