WR941ND v5 - Bricked downgrading 1.10 to 1.6.2

Report problems and success stories with Gargoyle on various hardware platforms.

Moderator: Moderators

top_s
Posts: 3
Joined: Mon Aug 13, 2018 10:09 pm

WR941ND v5 - Bricked downgrading 1.10 to 1.6.2

Postby top_s » Mon Aug 13, 2018 10:31 pm

Hello everyone!

Longstory short, I bricked my TP-Link WR941ND V5, witch is running as a WR841ND V8.
It was running Gargoyle 1.10.0 with minor stability issues, so I decided to "improve" it by downgrading to 1.6.2 WR841ND V8 sysupgrade image, and got a brick.

Normal bricked status is only PWR led on.

I can enter recovery mode with WPS/reset + Power On. In this cenario, PWR + WPS leds are on, but TFTP won't work.

When in recovery mode, Wireshark (network sniffer) tells me the router asks for something:

Code: Select all

No.     Time           Source                Destination           Protocol Length Info
      3 0.101446       ba:be:fa:ce:08:41     Broadcast             ARP      60     Who has 192.168.0.66? Tell 192.168.0.86


But there are no TFTP requests for a recovery file.

I could try and WinSCP it, but I have no idea if it would help or make it worst. I'd also need some instructions, as I have limited networking skills.

Any help will be very much appreciated!

ispyisail
Moderator
Posts: 4194
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: WR941ND v5 - Bricked downgrading 1.10 to 1.6.2

Postby ispyisail » Tue Aug 14, 2018 5:38 am

OpenWRT wiki is the best place to look for a solution

top_s
Posts: 3
Joined: Mon Aug 13, 2018 10:09 pm

Re: WR941ND v5 - Bricked downgrading 1.10 to 1.6.2

Postby top_s » Tue Aug 14, 2018 12:13 pm

Thank you, will take a deeper look into it.

Also, thanks a lot ispyisail for the great job at keeping Gargoyle!

top_s
Posts: 3
Joined: Mon Aug 13, 2018 10:09 pm

Re: WR941ND v5 - Bricked downgrading 1.10 to 1.6.2

Postby top_s » Thu Nov 08, 2018 11:17 am

So, after a lot of pain, found the answer:

1- Openning way for wireshark/TFTP in Windows firewall wasn't enough. Shutting windows firewall off entirely did the trick;

2- Brick reason is: WR941ND v5 is not supported by WR841ND v8 1.6.2 firmware. Used WR841ND v8 1.9.2 firmware instead. Working like a charm.


Return to “Hardware / Installation Issues”

Who is online

Users browsing this forum: No registered users and 7 guests