Page 1 of 1

[TST] TP-Link WDR4300 - Testing Support

Posted: Fri Aug 24, 2012 8:12 pm
by flakattack
Good Morning / Evening Forum,

I have just picked up the TP-Link WDR4300 wireless router, and it is pretty awesome!

Testing OpenWRT on it at the moment and from initial tests it seems quite stable. Looking to push it further I want to see if I can get gargoyle to work.

So went to this page: http://www.gargoyle-router.com/wiki/doku.php?id=set_of_packages

However noticed that the instructions are quite out of date.
Then started to search the net and stumbled upon this: http://engeresting.blogspot.com.au/2011/06/gargoyle-on-openwrt-backfire-1003.html

Tried to follow this guide but still no avail :(

So what I am asking is, is there something blatantly obvious I have missed? I mean is there a page somewhere here that gives me all this info?

In Summary:
What I am after:
  • A list of packages that need to be installed
  • Any additional configuration that needs to be performed

I guess that is it. Oh and I guess this is sort of important: I am currently using: Backfire [ATTITUDE ADJUSTMENT (Bleeding Edge, r33235)]

Re: [TST] TP-Link WDR4300 - Testing Support

Posted: Sun Aug 26, 2012 5:00 pm
by wilsonhlacerda
:shock:
Nice and cheap router! Think it'll be my next one!
128MB RAM
8MB FLASH
2 USB
2.4Ghz + 5Ghz Simultaneous
CPU 560MHz AR9344
US$70 to US$100 almost worldwide

MUCH better than wr1043nd for only a few bucks more.
This one does deserve Gargoyle firmware images. ;)

OpenWrt Wiki:
http://wiki.openwrt.org/toh/tp-link/tl-wdr4300

Re: [TST] TP-Link WDR4300 - Testing Support

Posted: Mon Aug 27, 2012 6:02 am
by pbix
OpenWRT support for this router is only in trunk. Gargoyle works with released versions of OpenWRT.

Rumors abound that the next release of OpenWRT "Attitude Adjustment" is imminent. Expect Gargoyle releases short there after.

Re: [TST] TP-Link WDR4300 - Testing Support

Posted: Tue Aug 28, 2012 9:29 am
by wilsonhlacerda
pbix wrote:OpenWRT support for this router is only in trunk. Gargoyle works with released versions of OpenWRT.

Rumors abound that the next release of OpenWRT "Attitude Adjustment" is imminent. Expect Gargoyle releases short there after.


pbix thanks for reply!
Yes, I know Gargoyle only support released openwrt. That's a good strategy.
Please just not forget to add WDR4300 as soon as it is released ;) , probably it'll be a very demanding model next months.

By the way, is there any updated tutorial of how to install Gargoyle as packages (on top of openwrt trunk)? Could only find this:
http://www.gargoyle-router.com/wiki/dok ... f_packages
I have not tried it in fact, but I read in forum that it is not not functional.

Re: [TST] TP-Link WDR4300 - Testing Support

Posted: Wed Oct 10, 2012 1:41 pm
by wilsonhlacerda
Have anyone tried Gargoyle v1.5.7 (or newer) on TP-LINK WDR4300 or WDR4310?

Which hardware version? v1.0, 1.1, 1.2....?
Any comments?

I don't have one (yet), nice to hear from people that have already tried. Thanks.

Re: [TST] TP-Link WDR4300 - Testing Support

Posted: Wed Oct 10, 2012 5:34 pm
by DoesItMatter
gargoyle_1.5.7-ar71xx-generic-tl-wdr4300-v1-squashfs-factory.bin c8eef2f2eebc24ad29478ef27d064f85
gargoyle_1.5.7-ar71xx-generic-tl-wdr4300-v1-squashfs-sysupgrade.bin 7a56002a6c507bcd3a5532c620fbbdb4

The images already exist for this router - note that there is a
V1 and V1.1 - if you have the V1 - you should be able to flash this
and test for yourself.

http://wiki.openwrt.org/toh/tp-link/tl-wdr4300

Has instructions on how to recover if for some reason the flash
doesn't work for you.

The TL-WDR4310 also has V1 firmware images and should work as well.

I would NOT try to install Gargoyle as a set of packages because it
involves a lot of work and editing/tweaking on your part to get
it working correctly - much easier and safer to flash the firmware.

Re: [TST] TP-Link WDR4300 - Testing Support

Posted: Sat Feb 09, 2013 12:42 am
by bali
I bought the TP-Link WDR 4300 in the reverse auction on this site.

Cool router. Thanks Uniterm.

I am having issues with the media server though, and am having quite inconsistent behavior.

I first tested it, got it up and running in no time - could access the media no problem. I had to do a proper install, so took it down etc, set it up clean, proper wiring etc. Didnt change the settings. This time around can see the folders on the media server, but none of the content.

No stress, decide I will use a different HDD, plug that in, same problem. Unplug it, connect it to the second USB port, setup the folders and bobs your uncle, its working.

I rebooted the router to change the security settings, and back to the same problem, can see the media server, and the folders, but no content.

Then I tried putting the security settings back to the original way. I tried swapping the USB port again etc - no luck.

Anybody has some suggestions on how to resolve or what I could be doing wrong?

Re: [TST] TP-Link WDR4300 - Testing Support

Posted: Tue Jun 04, 2013 10:34 am
by lioux
I have one and it's working like a charm with Gargoyle 1.5.10.

Re: [TST] TP-Link WDR4300 - Testing Support

Posted: Wed Jun 12, 2013 6:42 pm
by smyr
Same here! Working flawless after flashing my 4300v1. Havent tried all the options yet however but so far no complaints. :D Great router btw, recommend it!

Re: [TST] TP-Link WDR4300 - Testing Support

Posted: Fri Mar 07, 2014 7:21 pm
by yc3948
Device Name:Gargoyle
Gargoyle Version:1.6.0
Model:TP-Link TL-WDR4310 v1
Device Configuration:Gateway
Memory Usage:16.1MB / 123.7MB (13%)
Connections:132/4096
CPU Load Averages:1.02 / 0.45 / 0.17 (1/5/15 minute)

HW: V1.1

I test form 1.5.9 to 1.6.0, it only about 1 MBytes Total(the 1.6.0 is biggest 1.438 MBytes Total), anyone have the issues same as me? how can I fix it? Thanks