Openwrt 19.07 based Gargoyle

Discuss the technical details of Gargoyle and ongoing development

Moderator: Moderators

Lantis
Moderator
Posts: 5622
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

Then have you tried saving connection settings to try?
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Lantis wrote:Then have you tried saving connection settings to try?


If you about bandwidth monitors - yes. Not help.
If you talking about modem and web usage case - will test and will let you know.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

In case of usb modem usage, saving connection settings solving problem with web usage monitor.
Is it possible to fix this permanently or only workaround with late firewall restart should be used?

Lantis
Moderator
Posts: 5622
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

A full boot log when the problem occurs should be fine, or if it occurs after saving the connection settings a logread there is ok.

This is not normal behaviour, and even a late firewall should not really trigger it, as the scripts are triggered by the firewall itself.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Lantis wrote:A full boot log when the problem occurs should be fine, or if it occurs after saving the connection settings a logread there is ok.

This is not normal behaviour, and even a late firewall should not really trigger it, as the scripts are triggered by the firewall itself.


Saving connection information exactly fixing web usage, when using modem connection.
When it's simple reboot, web usage not working on modem connection.
So I'll try to get logread and boot log.

Lantis
Moderator
Posts: 5622
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Openwrt 19.07 based Gargoyle

Post by Lantis »

I'm more interested in the bandwidth issue which you said was not fixed.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Lantis wrote:I'm more interested in the bandwidth issue which you said was not fixed.


This issue not working even on regular WAN connection. I noted this pretty long time ago and was sure I wrote this question.

Here is my post about this issue: viewtopic.php?f=7&t=12041&p=55155#p55155

PS. I was not able to attach logs. You can pick them from https://pucina.dedyn.io/nextcloud/s/SYeZbypQGickbm5

PSS. USB modem + web usage. It started to work fully correct after saving connection after reboot as you suggested. Now it should not be done each reboot. Really strange, but looks like some information missed first time connection settled up.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Lantis wrote:In your Gargoyle git folder, run the following

Code: Select all

git fetch --all
git pull



Build went fine after that. Thank you. Will note for future builds.

papka__
Posts: 34
Joined: Tue Nov 19, 2019 4:07 pm

Re: Openwrt 19.07 based Gargoyle

Post by papka__ »

Lantis wrote:I'm more interested in the bandwidth issue which you said was not fixed.


Please skip looking on this. I'm really sorry. It was probably my builds fault. After this

Code: Select all

git fetch --all
git pull


I made a build and all monitors working there without any issue. I'm really confused about that.

lukasz1992m
Posts: 2
Joined: Sun Jan 05, 2020 11:47 am

Re: Openwrt 19.07 based Gargoyle

Post by lukasz1992m »

Lantis wrote:That doesn't sound right.
I think what they are trying to say is that usb3 is enabled by default. However. In our config we quite clearly have it disabled.

So yes while setting it to "=y" is not strictly required, setting it to "is not set" overrides the default and turns it off.

And no, there is still a kmod-usb3 and there's no indication I can see that this functionality has been merged elsewhere (why would they?)
Please seek some clarification.


plugin-gargoyle-usb-storage-noshare requires USB2 module (DEPENDS+=+kmod-usb2); however some devices with USB3 will not have usb2 kernel module. I don't know how, but only one of the modules: kmod-usb2, kmod-usb3 should satisfy dependances.

Post Reply