Building a x86 VM image but gargoyle ram doesn't scale

Discuss the technical details of Gargoyle and ongoing development

Moderator: Moderators

User avatar
powerlogy
Posts: 66
Joined: Wed Aug 22, 2012 12:04 pm
Location: Turkey

Building a x86 VM image but gargoyle ram doesn't scale

Postby powerlogy » Fri Apr 06, 2018 3:10 am

Hello, i'm having a after build problem with lastest version 1.10.x 68ce297 with gargoyle.The problem is the gargoyle system seems to not seeing more ram than 916728k total ram.If i set ram size from vmware workstation 2 gb, that value still doesn't change.

https://pasteboard.co/Hfk4WVs.png

Is there a kernel build option that i don't choose, any help would be good

Here is the build config
https://paste.ofcode.org/3aHmGC3jBD3EUpxNkYJ36ns

Best regards.

Lantis
Moderator
Posts: 4134
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Building a x86 VM image but gargoyle ram doesn't scale

Postby Lantis » Fri Apr 06, 2018 5:11 am

If you want to stick with x86_generic, then you should set:

Code: Select all

CONFIG_HIGHMEM=y
CONFIG_HIGHMEM4G=y

Maybe also check that CONFIG_NOHIGHMEM is not set.

I think switching to x86_64 would achieve the same result (obviously by switching to a 64 bit architecture)
WRT1900AC V1 on 1.10.X
WNDR3800/WRT3200ACM in a constant state of flux
www.lantisproject.com for custom builds and other projects
www.lantisproject.com/gargoyle_ispyisail/ for the latest releases

User avatar
powerlogy
Posts: 66
Joined: Wed Aug 22, 2012 12:04 pm
Location: Turkey

Re: Building a x86 VM image but gargoyle ram doesn't scale

Postby powerlogy » Mon Apr 09, 2018 4:24 pm

Thanks for suggestion, i tried with x86 with

Code: Select all

CONFIG_HIGHMEM=y
CONFIG_HIGHMEM4G=y

but no luck, then i tried x64 build but x64 didn't even boot, on vmware halted on waiting for root device.VirtualBox doesn't get ahead from grub loader.

How can i build an older version, will try if someone helps.

Anyway some folks asked for images, here they are.
https://www.oguska.com/gargoyle/x86/

fengchen_gf
Posts: 25
Joined: Sun Dec 13, 2015 12:53 am

Re: Building a x86 VM image but gargoyle ram doesn't scale

Postby fengchen_gf » Tue May 08, 2018 4:36 am

https://github.com/fengchen-github/gargoyle
It's my git above.Fixed somethings with target x86 and x86-64.

And your image i tryed is booting ok with gargoyle_1.10.x-x86-generic-combined-ext4.vdi.
J1900 x86-64 fanless computer: Gargoyle 1.10.X
Netgear wndr4300v1&wndr3700v4: sold out
ASUS ACRH17 :asuswrt as AP

N270 x86 fanless computer: Gargoyle 1.10.X
TP-LINK C7V2:LEDE 17.01.4 as AP
TP-LINK TL-WR741V4:switch


Return to “Gargoyle Development”

Who is online

Users browsing this forum: No registered users and 2 guests