Page 1 of 1

enabling boot_wait

Posted: Thu Apr 12, 2012 12:03 pm
by jwhipp
I'm having issues downgrading from 1.5.4 to 1.4.7. Gargoyle keeps getting stuck at "uploading firmware". I've researched this some, and it appears the best thing to do is return to the stock firmware and then to Gargoyle again.

Can someone please let me know how to enable boot_wait and set it to say 20 or so to give it time for tftp terminal to connect? I don't believe there's anyway to enable it and set the time from the Gargoyle interface.

I appreciate the help.

Linksys WRT54GL
Gargoyle 1.5.4 (needing to downgrade)

Re: enabling boot_wait

Posted: Fri Apr 13, 2012 4:51 pm
by mix
Returning to the stock firmware is pretty pointless. You can tftp any firmware you want that ends in the .bin. You can also use the command line to flash the firmware (I have to do this every time myself) because the WRT54GL runs out of memory (supposedly) during the flash. In any case, here is how to enable boot wait.

ssh into the router. Run commands:

nvram set boot_wait=on
nvram set wait_time=10
nvram commit

Then reboot your router and boot_wait will work.

I can give you instructions on flashing the firmware from ssh using mtd commands if you can't get tftp to work.

Re: enabling boot_wait

Posted: Mon Apr 16, 2012 12:21 pm
by jwhipp
I got it to work through tftp. I really appreciate the help enabling boot wait and setting the wait time.

I notice you are running the same version I am now 1.4.7 on the same device. I wonder if you've experienced drops in the wireless? After only two days on this version, I've had to reset the device 3 times because of the wireless dropping. I'm surprised that I might have to revert back to 1.2.5, which is the version prior to all my upgrade attempts. It was stable for me, but obviously lacks some of the cool new features.

Thanks again for the help.

WRT54GL v1.1
Gargoyle 1.4.7

Re: enabling boot_wait

Posted: Mon Apr 16, 2012 5:10 pm
by mix
I think the wireless dropout issue might have a bit to do with how much you load up the router. For instance, sometimes if I run a program like netalyzer over wifi, I can get the wifi to lockup:

However, I normally have no problems at all... the caveat being I only have a 2Mbps internet connection, so I really don't push the router to it's throughput and cpu limits. The issue might be a wifi driver one, where there is some problem with a various manufacturer(s) that is uncovered, but I don't experience using Ralink and Intel wireless cards. These are just wild guesses though.

In the off chance it makes any difference, I use WPA-PSK (a/k/a WPA TKIP) as my wireless encryption type. I don't use QoS or anything else, though I do have the UPnP server enabled. I have my router overclocked to 206 Mhz also.

This router won't push more than about 10 Mbps at the very best across wireless with the b43 driver. I have verified this with Larry Finger of the b43 project as he also has a WRT54GL and confirmed my results with his own throughput tests.

Re: enabling boot_wait

Posted: Mon Apr 16, 2012 7:41 pm
by jwhipp
I wish I could run netalyzer to see if it causes to lock things up, but the link you provided appears to be down.

I don't feel that I really push the router to it's limits either, although I'm not certain how to determine if I do. I too, have a low connection, 3Mbps maximum, and for the most part, find myself using it for sending email (no attachments), browsing the web for news, etc. Really nothing more than that. I don't use it for gaming, video streaming, or anything of the like. If the router limit is 10Mbps, my connection limit doesn't even come close to it at 3Mbps.

I also use WPA-PSK encryption, no QoS, and no uPnP server enabled. Again, I really feel that I use it for "basic" purposes. I'm not even forwarding ports for any services right now. :) Main reason I choose to go with Gargoyle is the great web filtering capabilities for my kids.

Your suggestion that it may be a wifi driver is an interesting one, although I wonder why it would work fine on a previous version release and not 1.4.7. I have a MacBook Pro, with an Airport Extreme card (0x14E4, 0x8D).

I might try reverting back to v1.2.5 to see if the stability I experienced before making changes returns. I really like the wake on LAN and search engine history though, so it seems I'll have to give up functionality for stability. Unfortunate. I appreciate your advice.

WRT54GL v1.1
Gargoyle 1.4.7

Re: enabling boot_wait

Posted: Wed Apr 18, 2012 11:46 am
by DoesItMatter
Try Gargoyle 1.3.9 for your WRT54GL

That was the last version that used old style Broadcom drivers.

1.3.10 and later uses a new driver set which does seem to have
more wireless instability, but it is constantly being worked on.

The wireless dropouts are NOT a Gargoyle issue, its an OpenWRT issue

Re: enabling boot_wait

Posted: Thu Apr 19, 2012 11:48 am
by jwhipp
Thank you for the suggestion regarding 1.3.9. I should have noticed the new driver set in the release notes. This would still give me the WOL and search engine history too :) I'm on my third version attempt since upgrading from v1.2.5 and hence, I agree with you that it seems to be something with OpenWRT, not Gargoyle. I'll let you know the outcome.

*update...1.3.9 is working like a charm. At times the memory seems to be maxed out and if I change restriction setting in the firewall, it overloads it. It ends up rebooting itself and all is well though.

Thank you