Openvpn

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

RomanHK
Posts: 647
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: Openvpn

Post by RomanHK »

This confirms to me that you are behind NAT.

I'll ask again - if you leave OpenVPN on default on port 1194 then it works?

If so, reset the router to default and set only OpenVPN to port 443 and test the connection.

Test open ports with some external service, eg: https://www.yougetsignal.com/tools/open-ports/
Turris Omnia with Gargoyle 1.12.0
Linksys WRT3200ACM with Gargoyle 1.12.0
TL-WR1043ND v2 with Gargoyle 1.10.0

Cybereu
Posts: 9
Joined: Thu Jun 04, 2020 2:08 pm

Re: Openvpn

Post by Cybereu »

Openvpn works normal on 1194.

Changed gargoyle to default and then seted to port 443 and doesn't work either.

RomanHK
Posts: 647
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: Openvpn

Post by RomanHK »

So otherwise. Make sure you have port 443 forwarding enabled.

Shut down the VPN server (or re-reset the router to default) and enable remote access to the Gargoyle router and try to connect from the outside to the Gargoyle via https (set the Gargoyle according to the screen):
Image

Can you access the Gargoyle web interface from the outside?
Turris Omnia with Gargoyle 1.12.0
Linksys WRT3200ACM with Gargoyle 1.12.0
TL-WR1043ND v2 with Gargoyle 1.10.0

Cybereu
Posts: 9
Joined: Thu Jun 04, 2020 2:08 pm

Re: Openvpn

Post by Cybereu »

I couldn't access outside the LAN, even inside I needed to create a port forward to the router. Tried found what rule in the firewall was blocking connections but failed.

By now I give up, already came back to DD-WRT where it worked. I learned something about Linux firewall, someday I'll try again.

Thanks for your patience and attention.

Post Reply