Bug in 1.11.0 creating .ovpn file.

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

rickwookie
Posts: 9
Joined: Thu Mar 07, 2013 9:49 am

Bug in 1.11.0 creating .ovpn file.

Postby rickwookie » Mon Aug 19, 2019 4:29 pm

When downloading OpenVPN client configuration as a single .ovpn file, the penultimate line of the static key is missing (so the 2048 bit key only has 15 instead of 16 lines of 32, or 480 hex characters instead of the required 512!).
Downloading the multiple files as a zip and then copying the missing line from the ta.key file (it is the one before last line of the Static key, very strange) into the .ovpn file then fixes the problem.

This behaviour wasn't there in 1.10.0.

ispyisail
Moderator
Posts: 4633
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Bug in 1.11.0 creating .ovpn file.

Postby ispyisail » Mon Aug 19, 2019 7:16 pm

I use OpenVPN on 1.11.0.x and use both connection methods successfully?

Wonder why yours is different?

or

Why mine woks without the last line?

What is you router hardware and exact gargoyle version?

Lantis
Moderator
Posts: 5057
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Bug in 1.11.0 creating .ovpn file.

Postby Lantis » Mon Aug 19, 2019 7:38 pm

Does this happen every time?
I've never seen this, and it doesn't make a lot of sense as the lines aren't really read in individually.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

rickwookie
Posts: 9
Joined: Thu Mar 07, 2013 9:49 am

Re: Bug in 1.11.0 creating .ovpn file.

Postby rickwookie » Tue Sep 10, 2019 4:33 pm

Sorry for the late reply.
Device Name:
Gargoyle
Gargoyle Version:
1.11.0
Model:
Buffalo WZR-HP-G300NH

I deleted and recreated the client and then downloaded the .ovpn again and it was the same issue. Individual files within the .zip had the correct line that was missing from the combined file.

Lantis
Moderator
Posts: 5057
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Bug in 1.11.0 creating .ovpn file.

Postby Lantis » Tue Sep 10, 2019 4:58 pm

Can you provide a system log after pressing the download button please?

You wouldn't be willing to send me a zipped copy of your /etc/openvpn folder would you? This would require you to rebuild your CA after for security.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases


Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 2 guests