compile build failed

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

Lantis
Moderator
Posts: 4850
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: compile build failed

Postby Lantis » Wed Mar 13, 2019 4:14 pm

Eth1.2 is fine.

Are you using the build I provided or back to yours?
It is highly unlikely uhttpd is crashing. It is more likely kernel panic.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

Armik
Posts: 40
Joined: Mon Mar 28, 2016 7:59 am

Re: compile build failed

Postby Armik » Thu Mar 14, 2019 6:05 am

I tried yours and I still don’t understand my new problem. Why does web interface fall off and everything stops working happens approximately 5 minutes after the router loads.
WRT3200ACM

Lantis
Moderator
Posts: 4850
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: compile build failed

Postby Lantis » Thu Mar 14, 2019 6:17 am

I don't know. Clearly there is something incompatible or conflicting.
You would need to debug it yourself, probably with a serial to catch the crash and the reason.

I can't fix it for you unless i know why it is not working.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

Armik
Posts: 40
Joined: Mon Mar 28, 2016 7:59 am

Re: compile build failed

Postby Armik » Thu Mar 14, 2019 6:42 am

I see. Thanks.
WRT3200ACM

User avatar
RomanHK
Posts: 265
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: compile build failed

Postby RomanHK » Thu Mar 14, 2019 6:54 am

First try changing the ports.

Then try running via ssh service:

Code: Select all

/etc/init.d/uhttpd start

and watch what they write.

Then, use the ssh command:

Code: Select all

logread

and here posts.
Turris Omnia with Gargoyle 1.11.x
Linksys WRT3200ACM with Gargoyle 1.11.x
TL-WR1043ND v2 with Gargoyle 1.10.0

Armik
Posts: 40
Joined: Mon Mar 28, 2016 7:59 am

Re: compile build failed

Postby Armik » Thu Mar 14, 2019 7:03 am

I have already changed the ports and the service has restarted problems remains.
In logs only this:

Code: Select all

nf_conntrack: nf_conntrack: table full, dropping packet
] net_ratelimit: 3 callbacks suppressed

if before that there was a problem only to make his assembly, then now the problem has become much deeper and what else is strange at openwrt everything works.
WRT3200ACM

Lantis
Moderator
Posts: 4850
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: compile build failed

Postby Lantis » Thu Mar 14, 2019 8:01 am

I'm almost guaranteeing you that it is not uhttpd. You should look elsewhere.
Boot it and take a logread and dmesg and post them here.

But you need to log the crash most importantly, which you won't be able to do without serial probably.

You should check your connection limits (firewall -> connection limits) are sane.
You should also disconnect the router from WAN to see if the connection flood is from there or the LAN
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

User avatar
RomanHK
Posts: 265
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: compile build failed

Postby RomanHK » Thu Mar 14, 2019 8:31 am

Armik wrote:I have already changed the ports and the service has restarted problems remains.
In logs only this:

Code: Select all

nf_conntrack: nf_conntrack: table full, dropping packet
] net_ratelimit: 3 callbacks suppressed

if before that there was a problem only to make his assembly, then now the problem has become much deeper and what else is strange at openwrt everything works.

1. If OpenWrt works, compare it with OpenWrt and Gargoyle files:

Code: Select all

cat /etc/sysctl.conf
cat /etc/sysctl.d/10-default.conf
cat /etc/sysctl.d/11-br-netfilter.conf
cat /etc/sysctl.d/11-nf-conntrack.conf

2. Post the result from the commands:

Code: Select all

sysctl -a | grep conntrack
sysctl -a | grep ratelimit

EDIT: See if you have all the necessary kernel modules:

Code: Select all

opkg list-installed|grep conn

For me it looks like this:

Code: Select all

root@TurrisOmnia:~# opkg list-installed|grep conn
iptables-mod-conntrack-extra - 1.6.2-1
iptables-mod-conntrack-label - 1.6.2-1
kmod-ipt-conntrack - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
kmod-ipt-conntrack-extra - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
kmod-ipt-conntrack-label - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
kmod-nf-conntrack - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
kmod-nf-conntrack-netlink - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
kmod-nf-conntrack6 - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
libnetfilter-conntrack - 2017-07-25-e8704326-1
Turris Omnia with Gargoyle 1.11.x
Linksys WRT3200ACM with Gargoyle 1.11.x
TL-WR1043ND v2 with Gargoyle 1.10.0

Armik
Posts: 40
Joined: Mon Mar 28, 2016 7:59 am

Re: compile build failed

Postby Armik » Wed Mar 20, 2019 5:53 am

put firmware from site.
here are conclusions of the teams:

Code: Select all

root@Gargoyle:~# opkg list-installed|grep conn
iptables-mod-conntrack-extra - 1.6.2-1
iptables-mod-conntrack-label - 1.6.2-1
kmod-ipt-conntrack - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
kmod-ipt-conntrack-extra - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
kmod-ipt-conntrack-label - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
kmod-nf-conntrack - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
kmod-nf-conntrack-netlink - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
kmod-nf-conntrack6 - 4.14.99-1-8f1f9dfd526ce5740e7d4b77c586be7e
libnetfilter-conntrack - 2017-07-25-e8704326-1





root@Gargoyle:~# sysctl -a | grep conntrack
sysctl: error reading key 'net.ipv6.conf.all.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.br-lan.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.default.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.erspan0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.eth0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.eth0.1.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.eth1.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.eth1.2.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.gretap0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.imq0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.imq1.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.lo.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.teql0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.wlan0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.wlan1.stable_secret': I/O error
net.netfilter.nf_conntrack_acct = 1
net.netfilter.nf_conntrack_buckets = 8192
net.netfilter.nf_conntrack_checksum = 0
net.netfilter.nf_conntrack_count = 2751
net.netfilter.nf_conntrack_events = 1
net.netfilter.nf_conntrack_expect_max = 128
net.netfilter.nf_conntrack_frag6_high_thresh = 4194304
net.netfilter.nf_conntrack_frag6_low_thresh = 3145728
net.netfilter.nf_conntrack_frag6_timeout = 60
net.netfilter.nf_conntrack_generic_timeout = 600
net.netfilter.nf_conntrack_helper = 0
net.netfilter.nf_conntrack_icmp_timeout = 30
net.netfilter.nf_conntrack_icmpv6_timeout = 30
net.netfilter.nf_conntrack_log_invalid = 0
net.netfilter.nf_conntrack_max = 4096
net.netfilter.nf_conntrack_tcp_be_liberal = 0
net.netfilter.nf_conntrack_tcp_loose = 1
net.netfilter.nf_conntrack_tcp_max_retrans = 3
net.netfilter.nf_conntrack_tcp_no_window_check = 1
net.netfilter.nf_conntrack_tcp_timeout_close = 10
net.netfilter.nf_conntrack_tcp_timeout_close_wait = 60
net.netfilter.nf_conntrack_tcp_timeout_established = 600
net.netfilter.nf_conntrack_tcp_timeout_fin_wait = 120
net.netfilter.nf_conntrack_tcp_timeout_last_ack = 30
net.netfilter.nf_conntrack_tcp_timeout_max_retrans = 300
net.netfilter.nf_conntrack_tcp_timeout_syn_recv = 60
net.netfilter.nf_conntrack_tcp_timeout_syn_sent = 120
net.netfilter.nf_conntrack_tcp_timeout_time_wait = 120
net.netfilter.nf_conntrack_tcp_timeout_unacknowledged = 300
net.netfilter.nf_conntrack_udp_timeout = 60
net.netfilter.nf_conntrack_udp_timeout_stream = 180
net.nf_conntrack_max = 4096




root@Gargoyle:~# sysctl -a | grep ratelimit
kernel.printk_devkmsg = ratelimit
kernel.printk_ratelimit = 5
kernel.printk_ratelimit_burst = 10
net.ipv4.icmp_ratelimit = 1000
net.ipv4.tcp_invalid_ratelimit = 500
sysctl: error reading key 'net.ipv6.conf.all.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.br-lan.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.default.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.erspan0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.eth0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.eth0.1.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.eth1.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.eth1.2.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.gretap0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.imq0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.imq1.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.lo.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.teql0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.wlan0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.wlan1.stable_secret': I/O error
net.ipv6.icmp.ratelimit = 1000

Most likely it is because of the virtual machine that it works on ports 443,80 and igmpproxy.
after turning them off, everything seems to be stabilizing. I’ll check for some time to be sure. But unfortunately, I can’t use a gargoyle then, and I’ll have to go back to openwrt.
WRT3200ACM

User avatar
RomanHK
Posts: 265
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: compile build failed

Postby RomanHK » Wed Mar 20, 2019 11:28 am

Armik wrote:Most likely it is because of the virtual machine that it works on ports 443,80 and igmpproxy.
after turning them off, everything seems to be stabilizing. I’ll check for some time to be sure. But unfortunately, I can’t use a gargoyle then, and I’ll have to go back to openwrt.

According to the statements, everything looks fine. Something is filling your network or having a collision of ports. Anyway, it's up to you. Try the excretion method.
Turris Omnia with Gargoyle 1.11.x
Linksys WRT3200ACM with Gargoyle 1.11.x
TL-WR1043ND v2 with Gargoyle 1.10.0


Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 5 guests