BUG: OpenVPN config is not being backed up.

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

lollapalooza
Posts: 62
Joined: Mon Jun 09, 2014 12:53 pm

BUG: OpenVPN config is not being backed up.

Postby lollapalooza » Thu Jan 10, 2019 12:46 pm

I had to uninstall and reinstall Gargoyle to make a few tests with OpenWRT.

Obviously I did a backup of the config via Gargoyle WebGUI, so it should have been easy to restore once reinstalled.

Unfortunately all configurations were backed up, except OpenVPN config (I had it configured as a client).

Now I'm getting crazy to restore VPN connection with my parent's house ;-)

ispyisail
Moderator
Posts: 4552
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: BUG: OpenVPN config is not being backed up.

Postby ispyisail » Sat Feb 02, 2019 6:22 am

yeah......

Even if the current backup worked for OpenVPN it won't work between major upgrades. Its a limitation of the Gargoyle/OpenWRT design.

It would be nice to backup only OpenVPN config settings for major upgrades.

jki
Posts: 8
Joined: Sat Jul 14, 2012 3:00 pm

Re: BUG: OpenVPN config is not being backed up.

Postby jki » Sun May 05, 2019 9:51 am

I was about to use backup/restore for playing with a self-built master version when I realized this deficit: Can you elaborate on the incompatibility of the OpenVPN settings under /etc/openvpn/, even when doing just minor updates, but also across major ones? TIA.


Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 1 guest