[Solved] OpenVPN 1.10.0 reverse vpn problems

If your problem doesn't fall into one of the other categories, report it here.

Moderator: Moderators

ispyisail
Moderator
Posts: 3769
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

[Solved] OpenVPN 1.10.0 reverse vpn problems

Postby ispyisail » Thu Nov 23, 2017 9:41 pm

Hi all

VPN now only works from client to sever not the other way round.

Image

Routing table on the OpenVPN server

Image

Its missing an entry, in my case it should also have

Code: Select all

192.168.14.0/255.255.255.0           tun0          *             0


Makes me wonder if OpenVPN is picking up any commands from gargoyle GUI?

ispyisail
Moderator
Posts: 3769
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: OpenVPN 1.10.0 reverse vpn problems

Postby ispyisail » Fri Nov 24, 2017 12:57 am

Installed 1.9.2

Image

This is how it should look

Image

ispyisail
Moderator
Posts: 3769
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: OpenVPN 1.10.0 reverse vpn problems

Postby ispyisail » Fri Nov 24, 2017 12:59 am

for some reason the client setting aren't being pushed

Image

ispyisail
Moderator
Posts: 3769
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: [Solved] OpenVPN 1.10.0 reverse vpn problems

Postby ispyisail » Thu Dec 14, 2017 1:58 pm

Solved / Work around

When you first create a OpenVPN server config make sure you also add all the required client configs before hitting save.

In my mind you should be able to add clients latter and have the new client configs edit the routing table?

Lantis
Moderator
Posts: 3721
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [Solved] OpenVPN 1.10.0 reverse vpn problems

Postby Lantis » Thu Dec 14, 2017 3:52 pm

Agreed. Will add to list of things to do
WRT1900AC V1 on 1.10.X
WNDR3800/WRT3200ACM in a constant state of flux
www.lantisproject.com for custom builds and other projects
www.lantisproject.com/gargoyle_ispyisail/ for the latest releases

ispyisail
Moderator
Posts: 3769
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: [Solved] OpenVPN 1.10.0 reverse vpn problems

Postby ispyisail » Thu Dec 14, 2017 6:01 pm

One of the problems I was using two different config methods, (unknown to me) Sometimes it worked sometimes it didn't.

Lantis
Moderator
Posts: 3721
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [Solved] OpenVPN 1.10.0 reverse vpn problems

Postby Lantis » Fri Jan 05, 2018 2:44 am

Got this one fixed up now i believe.
The big patchset is ready for testing.
WRT1900AC V1 on 1.10.X
WNDR3800/WRT3200ACM in a constant state of flux
www.lantisproject.com for custom builds and other projects
www.lantisproject.com/gargoyle_ispyisail/ for the latest releases


Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 2 guests