Disable DHCP setting is keep turning on

General discussion about Gargoyle, OpenWrt or anything else even remotely related to the project

Moderator: Moderators

Siaunen2
Posts: 5
Joined: Fri Jan 13, 2017 2:40 pm

Disable DHCP setting is keep turning on

Post by Siaunen2 »

Dear Fellows,

I have TP-Link TL-WR841N v11 currently running gargoyle 1.9.2.
This router is configured as dumb ap (dhcp turned off), but when i change the wireless mac filter setting (add/remove/enable), dhcp is turned on again. Should i just disable wireless mac filter on both router and ap, while turning on Enforce dhcp assignments? We are on metered internet and somehow if the dhcp is turned on (and connected via ap) it can give different ip (that is already assigned in main router) thus bypassing "quota" settings (even when the main router have Enforce dhcp assignments turned on).

ispyisail
Moderator
Posts: 4809
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Disable DHCP setting is keep turning on

Post by ispyisail »

4MB router?

Many things are broken on 4 mb routers

Try 1.6.2 firmware

Siaunen2
Posts: 5
Joined: Fri Jan 13, 2017 2:40 pm

Re: Disable DHCP setting is keep turning on

Post by Siaunen2 »

The 1.6.2 firmware isnt available for v11....any suggestion?

ispyisail
Moderator
Posts: 4809
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Disable DHCP setting is keep turning on

Post by ispyisail »

its a catch 22

when the bumped the firmware to include more routers it also increased the firmware size.

Openwrt will be one of your better options

Siaunen2
Posts: 5
Joined: Fri Jan 13, 2017 2:40 pm

Re: Disable DHCP setting is keep turning on

Post by Siaunen2 »

Is there any way to include gargoyle quota and active congestion control in open wrt? I really like those feature :D

druu
Posts: 2
Joined: Sat Jun 10, 2017 12:01 am

Re: Disable DHCP setting is keep turning on

Post by druu »

Just wanted to mention I'm also having this issue on a TL-WDR3600 running 1.9.2. I'm running this as a dumb AP also and will disable "LAN DHCP Server Enabled" setting. But this setting keeps reverting to enabled.

Lantis
Moderator
Posts: 5525
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Disable DHCP setting is keep turning on

Post by Lantis »

It's just the way it works at the moment.
Set up your wireless settings, then disable DHCP.
Then don't touch either setting.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

druu
Posts: 2
Joined: Sat Jun 10, 2017 12:01 am

Re: Disable DHCP setting is keep turning on

Post by druu »

I noticed this wasn't fixed in the latest release yet either. Any ETA on when it will be sorted?

I would love to also not alter my wireless settings but without and Auto channel selection setting I'm forced to continually update channels as new networks pop up around my area..

Lantis
Moderator
Posts: 5525
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Disable DHCP setting is keep turning on

Post by Lantis »

It’s not currently on any plans I’m aware of.

ACS generally operates once when the wifi is first brought up. Not all chipsets support it hence it is not an option.
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.

chuckcol
Posts: 3
Joined: Thu Apr 23, 2015 3:48 pm

Re: Disable DHCP setting is keep turning on

Post by chuckcol »

I just posted a solution that worked for me at viewtopic.php?f=11&t=11176. Log in via command line shell and issue these commands:

Code: Select all

uci set dhcp.lan.ignore=1
uci commit dhcp
/etc/init.d/dnsmasq disable

I think that last line is the one that did the trick. At least it seems to have kept the DHCP server from turming on for more than 72 hours here so far. I hope this saves someone else some time!

Post Reply