Versions 1.9.0 & 1.8.1

The latest news about Gargoyle

Moderator: Moderators

Eric
Site Admin
Posts: 1433
Joined: Sat Jun 14, 2008 1:14 pm

Versions 1.9.0 & 1.8.1

Postby Eric » Sun Nov 08, 2015 5:09 pm

The new experimental version of Gargoyle based on Chaos Calmer, 1.9.0 is now available for download. Also, available is 1.8.1, a bugfix release for the stable 1.8 branch.

New in 1.9.0:
  • Now based on newer OpenWRT Chaos Calmer branch
  • Interface pages are now html5, not xml (users should see no difference)
  • New mvebu architecture is supported
  • UPNP is no longer supported on routers with only 4M of flash space

New in 1.8.1:
  • Fixes problems with resetting router to default settings
  • Fixes hardware modes on wireless N routers
  • No longer disable ani, as this seems to hurt wireless performance
  • Fix an issue with the wifi button functioning as a reset button on wr1043nd v2 routers



Do NOT preserve settings/restore config when upgrading to 1.9.0

Lantis
Moderator
Posts: 3043
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Versions 1.9.0 & 1.8.1

Postby Lantis » Sun Nov 08, 2015 8:07 pm

Thanks for your hard work on releasing this :)
WNDR3800 on 1.9.X
WRT1900AC V1 on 1.9.X
www.lantisproject.com for custom builds and other projects

emukim
Posts: 7
Joined: Fri Aug 21, 2015 1:22 am

Re: Versions 1.9.0 & 1.8.1

Postby emukim » Sun Nov 08, 2015 8:19 pm

1.9.0,TP-Link TL-WR941N/ND v3
at begining everything worked fine.
after hours using, something went wrong.
internet got stuck.

local network seems fine.

can't find out what happen,turn to use 1.8.1 now.
Last edited by emukim on Mon Nov 09, 2015 3:01 am, edited 6 times in total.

tbv
Posts: 3
Joined: Sun Nov 10, 2013 6:11 pm
Location: Brazil

Re: Versions 1.9.0 & 1.8.1

Postby tbv » Sun Nov 08, 2015 10:15 pm

There is still no support for the TP-Link WR842N/ND v2. OpenWRT supports it since Barrier Breaker.

Proud owners (myself included) are awaiting the release of Gargoyle for this model :-)

And thanks for all your work!

pmerrill
Posts: 250
Joined: Wed Feb 15, 2012 8:23 pm

Re: Versions 1.9.0 & 1.8.1

Postby pmerrill » Mon Nov 09, 2015 5:01 am

emukim wrote:1.9.0,TP-Link TL-WR941N/ND v3
at begining everything worked fine.
after hours using, something went wrong.
internet got stuck.

local network seems fine.

can't find out what happen,turn to use 1.8.1 now.


Similar to my problem I believe on a TL-WDR4300. Will work for some time and then dropouts occur.
Paul
Gargoyle 1.9.x on TP-Link Archer C7 V2 H/W

tapper
Moderator
Posts: 965
Joined: Sun Oct 13, 2013 5:49 pm
Location: Stoke-on-trent UK

Re: Versions 1.9.0 & 1.8.1

Postby tapper » Mon Nov 09, 2015 5:11 am

Hi thanks for all your hard work on 1.9 just flashed to my wdr3600 and all is good. Will test on my n750 in repeater bridge mode later.
TP-Link WR1043ND v2.1 Gargoyle 1.6.2
Western Digital My Net N750 Gargoyle 1.9x
TP-Link TL-WDR3600 V1.5 Gargoyle 1.9x
TP-Link Archer C7 Gargoyle 1.9x
Linksys WRT1900AC V2 Gargoyle 1.9x
Linksys WRT3200ACM LEDE 17.1

gumball3000
Posts: 28
Joined: Mon Apr 08, 2013 8:20 am

Re: Versions 1.9.0 & 1.8.1

Postby gumball3000 » Mon Nov 09, 2015 5:50 am

Just upgraded 1043nd v2 from 1.8.0 to 1.8.1, without preserving settings, factory reset still doesn't work from the router menu.

Also, on Wireless settings I cannot choose anymore B only or B+G, now I have only the N+G+B option in the drop down menu.

Image

justAguy
Posts: 8
Joined: Thu Feb 19, 2015 8:03 pm

Re: Versions 1.9.0 & 1.8.1

Postby justAguy » Mon Nov 09, 2015 6:32 am

Still broken, just like 1.7.2 and 1.8.0 (Archer C7 V2).

In the channel config, the 2.4Ghz channel select shows 5Ghz channels and vise versa.
5Ghz channels: 1-11
2.4Ghz channels: 36-165

If I try to change 5Gz to 40Mhz its available channels dropdown goes blank.

Currently showing 2.4Gz on channel 1 and 5Ghz enabled.
Wi-Fi snoop shows channel 6 and no 5Ghz.

----------------------------

ispyisail mentioned Eric tests with this router now and that it would likely be fixed. Anyone know if this is fixed in 1.9.X or do I switch to Openwrt?

Lantis
Moderator
Posts: 3043
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Versions 1.9.0 & 1.8.1

Postby Lantis » Mon Nov 09, 2015 6:50 am

justAguy wrote:ispyisail mentioned Eric tests with this router now and that it would likely be fixed. Anyone know if this is fixed in 1.9.X or do I switch to Openwrt?


If this is your only gripe with Gargoyle i suggest you open a bug report at the github.
And then set the channels manually in the command line.

It would be a shame to give up a firmware for such a visual bug that i'm sure can be fixed.
WNDR3800 on 1.9.X
WRT1900AC V1 on 1.9.X
www.lantisproject.com for custom builds and other projects

Lantis
Moderator
Posts: 3043
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Versions 1.9.0 & 1.8.1

Postby Lantis » Mon Nov 09, 2015 6:50 am

tbv wrote:There is still no support for the TP-Link WR842N/ND v2. OpenWRT supports it since Barrier Breaker.

Proud owners (myself included) are awaiting the release of Gargoyle for this model :-)

And thanks for all your work!


I have pm'd you.
WNDR3800 on 1.9.X
WRT1900AC V1 on 1.9.X
www.lantisproject.com for custom builds and other projects


Return to “News”

Who is online

Users browsing this forum: No registered users and 1 guest