Version 1.6.1 - Heartbleed Fix

The latest news about Gargoyle

Moderator: Moderators

theend
Posts: 2
Joined: Thu Jan 23, 2014 11:54 pm

Re: Version 1.6.1 - Heartbleed Fix

Postby theend » Tue Apr 22, 2014 12:59 am

seems V1.6.1 still not worked with my WHR-G301N, always restore configuration after a power off. :cry:

gumball3000
Posts: 28
Joined: Mon Apr 08, 2013 8:20 am

Re: Version 1.6.1 - Heartbleed Fix

Postby gumball3000 » Tue Apr 22, 2014 6:38 am

[BUG REPORT]
After i choose Restore Default Configuration the router doesn't reboot by itself, and if i try to access the default link, i receive the following message:
haserl CGI Error

The fallback language was not set for gargoyle.global.fallback_lang


I had to reboot the rooter via SSH.

tt99
Posts: 1
Joined: Tue Apr 22, 2014 8:02 am

Re: Version 1.6.1 - Heartbleed Fix

Postby tt99 » Tue Apr 22, 2014 8:06 am

gumball3000 wrote:[BUG REPORT]
After i choose Restore Default Configuration the router doesn't reboot by itself, and if i try to access the default link, i receive the following message:
haserl CGI Error

The fallback language was not set for gargoyle.global.fallback_lang


I had to reboot the rooter via SSH.

Bug confirmed on my 1043nd v1.

To me, the only solution was to put router in failsafe mode and digit "firstboot" command from telnet session. After that just run "reboot -p" command and config again the router.

tapper
Moderator
Posts: 1065
Joined: Sun Oct 13, 2013 5:49 pm
Location: Stoke-on-trent UK

Re: Version 1.6.1 - Heartbleed Fix

Postby tapper » Tue Apr 22, 2014 10:17 am

found a bug wen i turn on tor it looks like it is on but wen you go back to the page it is switched off again. and tor sites will not load.
Linksys WRT1900AC V2 Gargoyle 1.11
Linksys WRT3200ACM OpenWrt Snapshot

eponymous cowherd
Posts: 1
Joined: Tue Apr 22, 2014 2:35 pm

Re: Version 1.6.1 - Heartbleed Fix

Postby eponymous cowherd » Tue Apr 22, 2014 2:47 pm

Applied 1.6.1 to my TP-Link TL-WDR3600 v1. Update applied OK but TOR is now shown as not installed, and will not install.

If I hit "Install" on the Tor Plugin I get the "please wait" pop-up, then the screen refreshes but TOR is still shown as "Status: Not Installed".

Installed the system log plugin and tried to install TOR, nothing recorded.
Rebooted the router and tried to install TOR, still not installed.
restored from the backup I took before upgrading, retried installing TOR, still not installed. Power-cycled the router, retired install, TOR still not installed.

Anyone have any hints as to where to look next?

Eric
Site Admin
Posts: 1436
Joined: Sat Jun 14, 2008 1:14 pm

Re: Version 1.6.1 - Heartbleed Fix

Postby Eric » Wed Apr 23, 2014 7:13 am

gumball3000/tt99 : You are trying to restore a configuration from a much earlier version of Gargoyle, before internationalization support was added. This is not supported

tapper: I'm having trouble reproducing this error. Please clarify what router you are using, what version of Gargoyle you upgraded from, and how you have Tor configured (as a client only, or as a relay? Hidden Service only/Everything goes through tor/Selected by each host? ) The more information I have the more likely it is that I can figure out what might be going on.

eponymous cowherd: The WDR3600 only has 8MB of flash. I'm guessing you upgraded from 1.5.10 or before? Tor was removed from routers with less than 16MB of flash in 1.5.11, and needs to be installed as a separate plugin. In order to make Tor fit, you need to have a USB drive, and install the Tor plugin to that drive in the System/Plugins page.

tapper
Moderator
Posts: 1065
Joined: Sun Oct 13, 2013 5:49 pm
Location: Stoke-on-trent UK

Re: Version 1.6.1 - Heartbleed Fix

Postby tapper » Wed Apr 23, 2014 8:22 am

Hi Eric i am using 1.6.1 on a TP-Link WR1043ND
v2.1 with 128 swop file on a 256 meg USB stick.

plugin root /dev/sda1: 121.246 MBytes Total, 119.412 MBytes Free


Plugin Sources:

table with 2 columns and 3 rows
Name  
attitude_adjustment
http://downloads.openwrt.org/attitude_a ... c/packages
Preset 
gargoyle
http://www.gargoyle-router.com/packages ... xx/default
Preset
table end


Tor Anonymizer Support for Gargoyle

Version: 1.6.1-1
Status: Installed
 
Uninstall 

So i set it to
Hidden Service Access Only
and then hit save

Tor Data Drive:
/dev/sda1: 121.246 MBytes Total, 119.412 MBytes Free

then hit save.

Wtf it's started working now lol
Linksys WRT1900AC V2 Gargoyle 1.11
Linksys WRT3200ACM OpenWrt Snapshot

tapper
Moderator
Posts: 1065
Joined: Sun Oct 13, 2013 5:49 pm
Location: Stoke-on-trent UK

Re: Version 1.6.1 - Heartbleed Fix

Postby tapper » Wed Apr 23, 2014 9:14 am

No it's not working

URL/grams7enufi7jmdl.onion)
Linksys WRT1900AC V2 Gargoyle 1.11
Linksys WRT3200ACM OpenWrt Snapshot

gumball3000
Posts: 28
Joined: Mon Apr 08, 2013 8:20 am

Re: Version 1.6.1 - Heartbleed Fix

Postby gumball3000 » Wed Apr 23, 2014 12:01 pm

@Eric I triple checked, first i updated 1.6.0 to 1.6.1, the box "Attempt to Preserve Settings" was checked, and i received that error, after that i rebooted the router (via SSH) and i choose "Restore Default Configuration"
and I got the same error.

After that i reflashed the same firmware and I had unchecked the box "Attempt to Preserve Settings" the router still didn't rebooted by itself and i saw the same error, after that i rebooted it via SSH.

Gargoyle interface language was set to english all the time.
So, I'm pretty sure this is a bug.

1043nd v1.8

Dev_BR
Posts: 87
Joined: Fri Jan 27, 2012 6:55 am

Re: Version 1.6.1 - Heartbleed Fix

Postby Dev_BR » Wed Apr 23, 2014 7:27 pm

About TOR plug-in version

I think OpenWRT TOR version is 0.2.4.21
and Gargoyle version for it is 1.6.1-1

Right ?


Return to “News”

Who is online

Users browsing this forum: No registered users and 1 guest