Page 6 of 13

Re: Version 1.5.11 - Translations

Posted: Mon Oct 21, 2013 1:08 pm
by chigo58
ispyisail wrote:Not a lot of difference between r38260 and r38347
https://dev.openwrt.org/log/branches/at ... ?rev=38486
are you 100% sure its better?


yes ispyisail - for me this version solves the intermittent pauses on wireless streaming.. no probs over wireless whatsoever. Would be nice if other people could test and revert.

Re: Version 1.5.11 - Translations

Posted: Mon Oct 21, 2013 1:23 pm
by Cezary
E1705 wrote:Dear Eric,
In version 1.5.11 you use "block-mount". I find the Bug in this package.
http://forum.ixbt.com/topic.cgi?id=14:59307:1463#1463 Discussion in Russian. Please, see my solution of this problem in ticket #14213 https://dev.openwrt.org/ticket/14213#no1

Gargoyle uses block-mount only to mount extroot on first partition, not for mount other.

Re: Version 1.5.11 - Translations

Posted: Mon Oct 21, 2013 2:07 pm
by ispyisail

Re: Version 1.5.11 - Translations

Posted: Mon Oct 21, 2013 2:44 pm
by Garitius
Hello everybody,

I am fairly new to Gargoyole (or OpenWRT) and therefore still learning. I installed Gargoyle version 1.5.10 on my TP-Link WR1043ND router seven days ago and yesterday I upgraded to 1.5.11, so far so good.

However, 24 hours after the upgrade I encountered an issue of which I thought it was worth mentioning.

First of all, the setup of my home network looks like this:

Code: Select all

*internet* ---- ISP Modem/Router ---- 1043ND Gargoyle Router ---- PC


Code: Select all

Note:
My ISP provided the Modem/Router which is needed for television, phone and internet. Unfortunately my ISP made a lot of options impossible to configure, but I need to deal with this, otherwise I won't be able to watch television or call somebody.

My Gargoyole Router is placed in a central position of my house and is connected to the modem/router via an ethernet cable in the lan port. It now serves as acces point.

My modem/router serves as the DHCP server since my ISP made it impossible to turn off the DHCP function in the modem/router. The IP adress of my modem/router is 192.168.2.254 and the IP adress of my Gargoyle Router is 192.168.2.1.



Now, the problem I encountered looks like this:

The first 10 hours after the upgrade to 1.5.11 were totally fine. I was able to acces the Gargoyle GUI and configure everything I needed. But yet, 24 hours after the upgrade, I cannot ping the router anymore.

Everything works fine though. Every device connected to my home network can acces the internet. Also, I can ping the modem/router at 192.168.2.254 and login to the modem/router's GUI. And, I have acces to other devices in my home network which are connected to the Gargoyle Router.

So, actually, everything works as it should. Except that no device behind the Gargoyle Router can enter the Gargoyle GUI, nor ping the router at 192.168.2.1. Neither can I acces the router via SSH because it time-outs.

Another strange aspect of this problem is that I am able to acces the Gargoyle GUI via my OpenVPN Server. I am still struggling with setting op my OpenVPN server though, because I can connect to the server, but not to the internet or the LAN network (I am still learning how to make this work). But so far I have been able to ping the Gargoyle Router via OpenVPN and this is still possible, eventhough devices in my LAN Network cannot ping the router anymore.

I accessed the router via OpenVPN and rebooted it, but this did't work. My PC behind the Gargoyle Router was only able to ping the router for about 2 minutes after the reboot, then it timed out again.

I also tried to power-cycle the router, but with no succes.

I don't think the upgrade went wrong, because everything worked fine yesterday. I will try a hard reset later and start from scratch, see if that works.


P.S. English is not my mother tongue, so my apologies if I couldn't make myself understandable.

Re: Version 1.5.11 - Translations

Posted: Mon Oct 21, 2013 3:20 pm
by olo
Hi,
I cannot upgrade to 1.5.11 from 1.5.10 using gargoyle_1.5.11-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin. After pointing the correct bin file, I see the progress circle that won't stop. After about 25 minutes when closing the browser, cleaning up cookies etc., the status page states that router is running under v1.5.10 still.

How can I upgrade to 1.5.11? Should I try gargoyle_1.5.11-ar71xx-generic-tl-wr1043nd-v1-squashfs-factory.bin from GUI?

Re: Version 1.5.11 - Translations

Posted: Mon Oct 21, 2013 5:20 pm
by BashfulBladder
Try a different browser. I've given up using Safari for flashing, even though I use it for every other Gargoyle web page.

Re: Version 1.5.11 - Translations

Posted: Mon Oct 21, 2013 6:17 pm
by Garitius
Allright, my problem got much bigger.

After I encounterd the problem I described in my last post, I descided that I should hard reset my router and start from scratch, maby that would resolve my problem.

So I did a 30/30/30 hard reset on my router. But once I reconnected to my router after the reset, it appeared that all my configurations were still there.

In other words, my router did not hard reset at all, it only power cycled. Which means that the reset button is disabled on the router.

I panicked, because I could not acces the router GUI via the browser, neither could I access the router via SSH and neither could I hard reset my router.

Luckily for me, I partly set up an OpenVPN server and I was able to acces the router GUI through the VPN connection. So I was able to reset my router configuration to default and start from the beginning. My router is now up again and I can access the GUI from every location.


But,
The reset button of my router is still down. I don't know if it is a hardware failure or if the software update to Gargoyle 1.5.11 caused this problem. All I know is that if my previous problem occurs again and my VPN server is down, I'm pretty fucked.

I hope you guys can share some thoughts about this.

Re: Version 1.5.11 - Translations

Posted: Mon Oct 21, 2013 7:49 pm
by BashfulBladder
Garitius wrote:I'm pretty fucked.

I hope you guys can share some thoughts about this.


While I'm a lover of vernacular language, we don't really care you Bend & Befriend™.

30/30/30 voodoo - clearly you come from dd-wrt.

In the GUI, you can try Backup -> Restore Default Configuration or you can boot into failsafe mode:

http://wiki.openwrt.org/doc/howto/generic.failsafe

and

Code: Select all

mtd -r erase rootfs_data

Re: Version 1.5.11 - Translations

Posted: Mon Oct 21, 2013 11:25 pm
by Phoebus
Ok i've upgraded my Buffalo 300nh and my WNDR3700v2 from 1.5.10 to 1.5. 11 and preserved settings. No issues noted yet.

Just wondering how miniDLNA works with a rather large collection of music and movie files. I installed miniDLNA (or was it some other DLNA server) on Gargoyle about a year ago and it had problems 'cause not enough space to store the meta-data database when there are lots of media files. How does this implementation go? Is the database stored on the attached storage or on the very limited internal storage?

Re: Version 1.5.11 - Translations

Posted: Tue Oct 22, 2013 8:27 am
by Cezary
On the first selected data directory. If this is an external storage medium is there.