Page 8 of 15

Re: Version 1.5.8 - USB Storage with FTP

Posted: Fri Nov 02, 2012 5:36 pm
by SergeS
FTP server in internal network (other than on router) is not accessible from outside.

Router: WNDR3700v2 with Gartgoyle 1.5.8
No usb storage on router
FTP server is on the nas, accessible from internal network, but not accessible from outside. It was accessible on previous Garg version (1.4.x). Port forwarding looks like ok.

Somebody can confirm?

Re: Version 1.5.8 - USB Storage with FTP

Posted: Sat Nov 03, 2012 12:37 am
by yc3948
Can't upgrade from 1.5.7 TP-Link TL-WR1043ND
nothing happens after I use 1.5.8 FW upgrade my TP-Link TL-WR1043ND from 1.5.7, it suspend on "Upgrading, Please Wait."

Re: Version 1.5.8 - USB Storage with FTP

Posted: Sat Nov 03, 2012 3:24 am
by yc3948
If you router's power LED is flashing fast it means you are stuck in boot mode. Configure your computer's ethernet port to a manual IP address of 192.168.1.2. Then 'ping 192.168.1.1' if you get a response it means your bootloader will most likely accept a new image so get the appropriate image for your router.

telnet 192.168.1.1

then you enter

cd /tmp

To get the file into this directory enter:

wget ftp://192.168.1.2/ar​71xx-tl-wr1043nd-v1-squashfs-sysupgrade.bin

sysupgrade -n ar71xx-tl-wr1043nd-v1-squashfs-sysupgrade.bin

;)



alencarazevedo wrote:
DoesItMatter wrote:
alencarazevedo wrote:My WR1043ND bricked when I upgraded from 1.4.7 to 1.5.8 version.
:cry:

I uploaded the sysupdate file and I noticed that my wireless connection down. Then I thought it was reseting. But it remains stoped. I tried Failsafe mode but it doesnt answer for ping request.


Not bricked - you may have to try Linux method or a Windows XP machine

Failsafe / TFTP almost NEVER works with Windows Vista / Windows 7

Did you make sure to Un-check the box to save settings?
Flashing 1.5.7 or 1.5.8 needs to restore to defaults, you cannot upgrade
to either of those 2 versions and keep settings - the router config will
not work properly and you will have trouble accessing the router.


It didnt show the option to save setttings, but only the field to select the file to upgrade.
I tried the TFTP on Windows XP and also on Ubuntu:
ubuntu@ubuntu:~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.2 icmp_seq=1 Destination Host Unreachable
From 192.168.1.2 icmp_seq=2 Destination Host Unreachable
From 192.168.1.2 icmp_seq=3 Destination Host Unreachable
From 192.168.1.2 icmp_seq=4 Destination Host Unreachable
From 192.168.1.2 icmp_seq=5 Destination Host Unreachable
From 192.168.1.2 icmp_seq=6 Destination Host Unreachable
From 192.168.1.2 icmp_seq=7 Destination Host Unreachable
From 192.168.1.2 icmp_seq=8 Destination Host Unreachable
From 192.168.1.2 icmp_seq=9 Destination Host Unreachable
From 192.168.1.2 icmp_seq=10 Destination Host Unreachable
From 192.168.1.2 icmp_seq=11 Destination Host Unreachable
From 192.168.1.2 icmp_seq=12 Destination Host Unreachable
From 192.168.1.2 icmp_seq=13 Destination Host Unreachable
From 192.168.1.2 icmp_seq=14 Destination Host Unreachable
From 192.168.1.2 icmp_seq=15 Destination Host Unreachable
^C
--- 192.168.1.1 ping statistics ---
16 packets transmitted, 0 received, +15 errors, 100% packet loss, time 15079ms
pipe 3

Failsafe also didnt work.

Does it exists any router that has a safe recovery mode, as a recovery button or a recovery from USB method?

Re: Version 1.5.8 - USB Storage with FTP

Posted: Sat Nov 03, 2012 7:17 am
by alencarazevedo
Thank you yc3948 for your answer, but the power LED doesnt flash. It is always "on" and the sys LED always "off".

yc3948 wrote:If you router's power LED is flashing fast it means you are stuck in boot mode. Configure your computer's ethernet port to a manual IP address of 192.168.1.2. Then 'ping 192.168.1.1' if you get a response it means your bootloader will most likely accept a new image so get the appropriate image for your router.

telnet 192.168.1.1

then you enter

cd /tmp

To get the file into this directory enter:

wget ftp://192.168.1.2/ar​71xx-tl-wr1043nd-v1-squashfs-sysupgrade.bin

sysupgrade -n ar71xx-tl-wr1043nd-v1-squashfs-sysupgrade.bin

;)

Re: Version 1.5.8 - USB Storage with FTP

Posted: Sat Nov 03, 2012 1:35 pm
by raz
Thanks for the release! :)

Small bug in the "Current DHCP Leases" window:

http://i.imgur.com/yBSUQ.png

Image

Re: Version 1.5.8 - USB Storage with FTP

Posted: Sat Nov 03, 2012 5:19 pm
by pmerrill
marvinandro wrote:Thanks for 1.5.8. I almost never run MSIE so I'm still on the first 1.5.8 build. As reported under 1.5.7 first, I still have an issue whereby my devices start to drop out and would not reconnect anymore until I reboot the router. I never had to do that up to 1.5.6 and I've installed almost all versions for quite some time now. It seems to be more noticeable with devices that come in and out of my network, ie phones and tablets, also WD media devices that kids turn on and off a few times a day. In about 24hrs after I reboot my WNDR3700v2, our phones would no longer get an IP; so would our tablets if we took them out of the house and back a few times that day. All of those devices have static IPs assigned. I used to have "Block MAC addresses assigned a static IP that connect from a different IP" checked and it was never an issue up to and including 1.5.6. Now the error seems to happen regardless of this toggle. I've changed lease time to as low as 2hrs and up to 12 hrs - error is still persistent. As this was a clean install of 1.5.7, then upgraded to 1.5.X, then upgraded again with preserve settings to 1.5.8, I also did a clean 1.5.8 install hoping that would clear the bug. I only setup my subnet, DNS, assigned static IPs, not much more configured - error is still persists.
Any help is appreciated (yes, going to 1.5.6 will fix the errors but that's not helping the community :)
Marv


Strange, I have the same router but have not experienced any of these problems. All my devices are connected don't drop out. We have a number of phones and wired devices.

Re: Version 1.5.8 - USB Storage with FTP

Posted: Sat Nov 03, 2012 6:22 pm
by SergeS
raz wrote:Thanks for the release! :)
Small bug in the "Current DHCP Leases" window:
http://i.imgur.com/yBSUQ.png


Confirm, I have similar (WNDR3700v2, Garg 1.5.8, device is HP printer):
Image

Re: Version 1.5.8 - USB Storage with FTP

Posted: Sat Nov 03, 2012 6:53 pm
by marvinandro
Bugs that are not reproducible are the hardest to fix. Those strange lease times might be part of the same issue. The router shows the devices that cannot get back on my network as actively connected. I also see a few 10.* (unknown) entries under Hosts With Active Connections. The DHCP is buggy but who can squash those bugs.

Re: Version 1.5.8 - USB Storage with FTP

Posted: Sun Nov 04, 2012 1:24 am
by Dragon31337
I've just upgraded my wr1043nd from 1.5.7 to 1.5.8 with settings preserve without any issues.
Update went smoothly. It working properly after the restart.

PS. Updated via firefox 16.0.2

Thanks!

Re: Version 1.5.8 - USB Storage with FTP

Posted: Sun Nov 04, 2012 2:49 pm
by raz
marvinandro wrote:The DHCP is buggy but who can squash those bugs.


Oh noez, a superbug!

We need a superhero.

Now, seriously?