Page 6 of 9

Re: Version 1.12.0 : New stable version

Posted: Fri Jan 24, 2020 9:53 am
by derdon
Hi.
Why there is no USB Printer functionality in version 1.12 on TL-WRD4300

Re: Version 1.12.0 : New stable version

Posted: Fri Jan 24, 2020 6:02 pm
by Lantis
To save space on the initial install and allow us to keep supporting your device. You can install it as a plugin now.

Re: Version 1.12.0 : New stable version

Posted: Tue Jan 28, 2020 10:04 pm
by ysy
Thanks mates!
Two minor issues to report back:
1) Guest wifi user can access the admin page.
2) Disabled 2.4G and turned on 5G only. SSID won't show up for guests.
Cheers

Re: Version 1.12.0 : New stable version

Posted: Tue Jan 28, 2020 10:31 pm
by Lantis
ysy wrote:Thanks mates!
Two minor issues to report back:
1) Guest wifi user can access the admin page.
2) Disabled 2.4G and turned on 5G only. SSID won't show up for guests.
Cheers


1. so they can see a quota assigned to them.
2. As in your primary network is only enabled for 5G, or you have both 2.4 and 5, but guest is only set to 5?

Re: Version 1.12.0 : New stable version

Posted: Tue Jan 28, 2020 10:55 pm
by ysy
Lantis wrote:2. As in your primary network is only enabled for 5G, or you have both 2.4 and 5, but guest is only set to 5?

First set both 2.4 n 5 G radios on with SSID 'Gargoyle', and turned Guest 2.4 n 5 G on with SSID 'Gargoyle1'. Worked well.
Then disabled 2.4G radio, could login 'Gargoyle' but not for 'Gargoyle1' (correction: can see the SSID).
Cheers

ps. just tried disabling 5G radio instead of 2.4G, could login both 'Gargoyle' and 'Gargoyle1'.

Re: Version 1.12.0 : New stable version

Posted: Wed Jan 29, 2020 3:31 am
by Lantis
I'm reasonably certain that your issue is due to the browser autofilling a different password under the guest password box when you toggle certain settings.

Try the experiment again but tick the Reveal password box first and make sure both passwords are as you expect.

Re: Version 1.12.0 : New stable version

Posted: Wed Jan 29, 2020 6:03 pm
by fifonik
> issue is due to the browser autofilling

I've seen this quite a few times already. Have you tried to add autocomplete="off" to the input? I know this is not standardized, but it works at least for some browsers.

Re: Version 1.12.0 : New stable version

Posted: Wed Jan 29, 2020 7:28 pm
by Lantis
I looked at it a while ago, but being against standard means it is a bit of a no go.
Plus, for username/password type fields (which wifi password is), the browser overrides the behaviour anyway.

Re: Version 1.12.0 : New stable version

Posted: Sat Feb 01, 2020 1:26 pm
by Waterspuwer
Any chance of a 1.12.0 build based on OpenWrt 19.07.1? It supposedly fixes the 5 GHz issue I'm having (~2s delay on WiFi).

Re: Version 1.12.0 : New stable version

Posted: Sat Feb 01, 2020 6:28 pm
by Lantis
I will update the code, but at this stage no planned release.
You can compile yourself or ask someone else to do so.