Page 3 of 5

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Posted: Thu Oct 01, 2015 4:48 am
by Lantis
i wonder if this has anything to do with the fact that "11gn" and "11an" etc are no longer valid settings for wireless.
The setting should be "11g" with "n" activated by setting htmode to "HT40+" or similar.

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Posted: Thu Oct 01, 2015 4:23 pm
by Volaris
Lantis wrote:i wonder if this has anything to do with the fact that "11gn" and "11an" etc are no longer valid settings for wireless.
The setting should be "11g" with "n" activated by setting htmode to "HT40+" or similar.

Just to double check, this morning I checked the wireless config on Gargoyle 1.9. It's the same config as 1.7 and 1.8. Changing the GUI option between B, G, or N options doesn't change the 11ng (not sure if it should or not):

Image

I then installed the final build (previous screenshot in my last post was from a release candidate in August) of OpenWRT CC, its wireless config is:

Image
(ignore the country code, I installed a Polish/Eko build since it has Luci installed already)

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Posted: Thu Oct 01, 2015 8:09 pm
by Lantis
Are you comfortable manually changing the settings in gargolye to match openwrt?
If so I would suggest you do that and report back on stability.

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Posted: Mon Oct 05, 2015 3:40 pm
by Volaris
Lantis wrote:Are you comfortable manually changing the settings in gargolye to match openwrt?
If so I would suggest you do that and report back on stability.

Sorry for the late response. I wanted to do this before a weekend trip but 1.9 didn't cooperate (router stopped booting up - just a solid red light and no IP address given). I flashed 1.8 today with TFTP. I used WinSCP to copy the wireless config exactly as OpenWRT has it. I'll let you know if that fixes the wireless stability issues.

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Posted: Thu Oct 08, 2015 11:54 pm
by Volaris
Eric wrote:Please elaborate on this: "Still defaults to BG wireless and selecting different wireless options."

I have heard reports of instability, but have not heard reports of wireless defaulting to B/G. Please let me know your setup (with screenshots if possible) and how you tested this (how do you know it's defaulting to G only wireless?).

Also, if you could post *working* wireless configuration files from vanilla OpenWRT Chaos Calmer builds, since you say it is working there, that would be very helpful in tracking down what is going on. If it is working in default Chaos Calmer, it should be possible/straightforward to fix the issue.

Lantis wrote:i wonder if this has anything to do with the fact that "11gn" and "11an" etc are no longer valid settings for wireless.
The setting should be "11g" with "n" activated by setting htmode to "HT40+" or similar.

Lantis wrote:Are you comfortable manually changing the settings in gargolye to match openwrt?
If so I would suggest you do that and report back on stability.

Good news Eric and Lantis. It seems copying the wireless config contents from the OpenWRT wireless config has fixed wireless stability. I've ran the router for over three days without any issues whatsoever. No odd things in system log, either. In the past wireless would go bad within 1 to 12 hours.

Image

To fix the wireless stability issues, I changed this wireless config http://i.imgur.com/CttNAH4.png to match this one from OpenWRT http://i.imgur.com/LDf0gYM.png exactly (same spaces, words, letters, line order, you name it...). The only thing I changed was put channel 11 instead of auto.

So I'm happy. The only thing is if you do any changes in the wireless/WAN settings page, it'll switch your wireless config back to the unstable settings. And the GUI still shows wireless as BG even though the OpenWRT settings are BGN... wireless N works fine though. For now, I've removed the +ccmp option in the encryption line and bumped the power to 27 to see if that affects stability, but I'm guessing everything will be fine. Will let you know if it breaks.

Thanks for helping me out!

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Posted: Fri Oct 09, 2015 12:10 am
by Lantis
That is good news :)
Hopefully a fix can be implemented so that eventually you won't have to manually edit the config.

Thanks for reporting back :)

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Posted: Fri Oct 09, 2015 5:30 pm
by Eric
I think the most likely candidate for the problem is the hwmode, which now cannot be 11ng or 11na, but must be 11g or 11a. I've committed a fix for this (and only this) difference. I'm curious whether this is sufficient or whether the other differences are important for stability as well.

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Posted: Fri Oct 09, 2015 6:38 pm
by Volaris
I can definitely test that!

I went ahead and reset the wireless config to default by making a change in wireless settings, and I changed 11ng to 11g in hwmode. Resulting config is the following:

Image

I then rebooted the router and confirmed that the wireless config didn't change from 11g. I'll let you know if wireless stability is affected.

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Posted: Sat Oct 10, 2015 12:05 am
by ispyisail
building new image

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Posted: Sun Oct 11, 2015 11:50 am
by Volaris
Bad news, it seems changing hwmode to 11g alone did not fix wifi stability. It kicked off all my devices and refused to let them reconnect to WiFi at 8:08. Below is the system log of the event

Code: Select all

Sun Oct 11 07:58:32 2015 daemon.info hostapd: wlan0: STA 00:19:7d:26:d8:3c WPA: group key handshake completed (RSN)
Sun Oct 11 07:58:32 2015 daemon.info hostapd: wlan0: STA 00:0d:4b:87:a5:01 WPA: group key handshake completed (RSN)
Sun Oct 11 07:58:32 2015 daemon.info hostapd: wlan0: STA 1a:60:fa:e6:a4:58 WPA: group key handshake completed (RSN)
Sun Oct 11 07:58:32 2015 daemon.info hostapd: wlan0: STA b8:8d:12:10:95:50 WPA: group key handshake completed (RSN)
Sun Oct 11 07:58:32 2015 daemon.info hostapd: wlan0: STA 0c:3e:9f:a3:ad:ba WPA: group key handshake completed (RSN)
Sun Oct 11 07:58:32 2015 daemon.info hostapd: wlan0: STA 00:26:b0:36:cb:8f WPA: group key handshake completed (RSN)
Sun Oct 11 07:58:32 2015 daemon.info hostapd: wlan0: STA 9c:d9:17:6a:75:50 WPA: group key handshake completed (RSN)
Sun Oct 11 07:58:32 2015 daemon.info hostapd: wlan0: STA 34:bb:26:b8:f5:5f WPA: group key handshake completed (RSN)
Sun Oct 11 07:58:33 2015 daemon.info hostapd: wlan0: STA 2c:b4:3a:72:38:67 WPA: group key handshake completed (RSN)
Sun Oct 11 07:58:33 2015 daemon.info hostapd: wlan0: STA 84:8e:0c:7e:56:83 WPA: group key handshake completed (RSN)
Sun Oct 11 07:58:33 2015 daemon.info hostapd: wlan0: STA 10:bf:48:e9:32:2b WPA: group key handshake completed (RSN)
Sun Oct 11 08:06:58 2015 daemon.notice hostapd: wlan0: STA 1a:60:fa:e6:a4:58 IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:08:32 2015 daemon.info hostapd: wlan0: STA 9c:d9:17:6a:75:50 WPA: group key handshake completed (RSN)
Sun Oct 11 08:08:33 2015 daemon.info hostapd: wlan0: STA 84:8e:0c:7e:56:83 WPA: group key handshake completed (RSN)
Sun Oct 11 08:08:34 2015 daemon.info hostapd: wlan0: STA 10:bf:48:e9:32:2b WPA: group key handshake completed (RSN)
Sun Oct 11 08:08:41 2015 daemon.info hostapd: wlan0: STA b8:8d:12:10:95:50 IEEE 802.11: deauthenticated due to local deauth request
Sun Oct 11 08:08:41 2015 daemon.info hostapd: wlan0: STA 0c:3e:9f:a3:ad:ba IEEE 802.11: deauthenticated due to local deauth request
Sun Oct 11 08:08:41 2015 daemon.info hostapd: wlan0: STA 34:bb:26:b8:f5:5f IEEE 802.11: deauthenticated due to local deauth request
Sun Oct 11 08:08:41 2015 daemon.info hostapd: wlan0: STA 00:0d:4b:87:a5:01 IEEE 802.11: deauthenticated due to local deauth request
Sun Oct 11 08:08:41 2015 daemon.info hostapd: wlan0: STA 00:26:b0:36:cb:8f IEEE 802.11: deauthenticated due to local deauth request
Sun Oct 11 08:08:41 2015 daemon.info hostapd: wlan0: STA 00:19:7d:26:d8:3c IEEE 802.11: deauthenticated due to local deauth request
Sun Oct 11 08:08:41 2015 daemon.info hostapd: wlan0: STA 2c:b4:3a:72:38:67 IEEE 802.11: deauthenticated due to local deauth request
Sun Oct 11 08:08:41 2015 daemon.info hostapd: wlan0: STA 1a:60:fa:e6:a4:58 IEEE 802.11: deauthenticated due to local deauth request
Sun Oct 11 08:08:52 2015 daemon.notice hostapd: wlan0: STA 00:19:7d:26:d8:3c IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:10:11 2015 daemon.notice hostapd: wlan0: STA 00:0d:4b:87:a5:01 IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:11:02 2015 daemon.info hostapd: wlan0: STA 1a:60:fa:e6:a4:58 IEEE 802.11: authenticated
Sun Oct 11 08:11:02 2015 daemon.info hostapd: wlan0: STA 1a:60:fa:e6:a4:58 IEEE 802.11: associated (aid 1)
Sun Oct 11 08:11:05 2015 daemon.notice hostapd: wlan0: STA 00:19:7d:26:d8:3c IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:11:10 2015 daemon.info hostapd: wlan0: STA 1a:60:fa:e6:a4:58 IEEE 802.11: deauthenticated due to local deauth request
Sun Oct 11 08:11:17 2015 daemon.notice hostapd: wlan0: STA 00:0d:4b:87:a5:01 IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:11:37 2015 daemon.notice hostapd: wlan0: STA 00:0d:4b:87:a5:01 IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:12:12 2015 daemon.info hostapd: wlan0: STA 00:0d:4b:87:a5:01 IEEE 802.11: authenticated
Sun Oct 11 08:13:38 2015 daemon.info hostapd: wlan0: STA 10:bf:48:e9:32:2b IEEE 802.11: disassociated due to inactivity
Sun Oct 11 08:13:39 2015 daemon.info hostapd: wlan0: STA 10:bf:48:e9:32:2b IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Oct 11 08:13:53 2015 daemon.info hostapd: wlan0: STA 00:19:7d:26:d8:3c IEEE 802.11: disassociated due to inactivity
Sun Oct 11 08:13:54 2015 daemon.info hostapd: wlan0: STA 00:19:7d:26:d8:3c IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Oct 11 08:13:58 2015 daemon.notice hostapd: wlan0: STA 00:0d:4b:87:a5:01 IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:14:05 2015 daemon.info hostapd: wlan0: STA 1a:60:fa:e6:a4:58 IEEE 802.11: authenticated
Sun Oct 11 08:14:05 2015 daemon.info hostapd: wlan0: STA 1a:60:fa:e6:a4:58 IEEE 802.11: associated (aid 1)
Sun Oct 11 08:14:10 2015 daemon.notice hostapd: wlan0: STA 2c:b4:3a:72:38:67 IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:14:10 2015 daemon.notice hostapd: wlan0: STA 2c:b4:3a:72:38:67 IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:14:13 2015 daemon.notice hostapd: wlan0: STA 2c:b4:3a:72:38:67 IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:14:14 2015 daemon.info hostapd: wlan0: STA 1a:60:fa:e6:a4:58 IEEE 802.11: deauthenticated due to local deauth request
Sun Oct 11 08:14:33 2015 daemon.notice hostapd: wlan0: STA 00:0d:4b:87:a5:01 IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:14:37 2015 daemon.notice hostapd: wlan0: STA 00:0d:4b:87:a5:01 IEEE 802.11: did not acknowledge authentication response
Sun Oct 11 08:15:12 2015 daemon.info hostapd: wlan0: STA 00:0d:4b:87:a5:01 IEEE 802.11: disassociated due to inactivity
Sun Oct 11 08:15:13 2015 daemon.info hostapd: wlan0: STA 00:0d:4b:87:a5:01 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Any other suggestions to test? I saw the OpenWRT wireless configs only show " config wifi-iface ' instead of ' config wifi-iface 'ap_g' '... so I removed the 'ap_g' part and rebooted the router. Just trial and error problem solving.