CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

Eric
Site Admin
Posts: 1439
Joined: Sat Jun 14, 2008 1:14 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Eric » Sun Oct 11, 2015 12:36 pm

I seriously doubt the ap_g name of the section is the issue.

Next things to test (one at a time, in this order or probability that each is responsible):
(1) remove the dissassoc_low_ack '0' line and see if that makes a difference
(2) Add back the txpower line

Volaris
Posts: 165
Joined: Thu May 01, 2014 1:02 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Volaris » Sun Oct 11, 2015 3:25 pm

Eric wrote:I seriously doubt the ap_g name of the section is the issue.

Next things to test (one at a time, in this order or probability that each is responsible):
(1) remove the dissassoc_low_ack '0' line and see if that makes a difference
(2) Add back the txpower line

Got it. In that case, I reset the wireless config back to default and did two things: changed 11ng to 11g and removed the dissassoc_low_ack '0' line. Router rebooted and wireless config settings confirmed. Let's see how it does this time.
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.

tapper
Moderator
Posts: 1065
Joined: Sun Oct 13, 2013 5:49 pm
Location: Stoke-on-trent UK

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby tapper » Sun Oct 11, 2015 3:47 pm

Linksys WRT1900AC V2 Gargoyle 1.11
Linksys WRT3200ACM OpenWrt Snapshot

Volaris
Posts: 165
Joined: Thu May 01, 2014 1:02 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Volaris » Mon Oct 12, 2015 11:09 am

Eric wrote:I seriously doubt the ap_g name of the section is the issue.

Next things to test (one at a time, in this order or probability that each is responsible):
(1) remove the dissassoc_low_ack '0' line and see if that makes a difference
(2) Add back the txpower line

Volaris wrote:
Eric wrote:I seriously doubt the ap_g name of the section is the issue.

Next things to test (one at a time, in this order or probability that each is responsible):
(1) remove the dissassoc_low_ack '0' line and see if that makes a difference
(2) Add back the txpower line

Got it. In that case, I reset the wireless config back to default and did two things: changed 11ng to 11g and removed the dissassoc_low_ack '0' line. Router rebooted and wireless config settings confirmed. Let's see how it does this time.

Bad news. Doing the above did not work. Woke up with WiFi that wouldn't connect.

Added dissassc_low_ack '0' line back into config, and adding Eric's second suggestion; option txpower '18'.

Something I forgot to show in the past is that when this happens, the few devices that remain connected to WiFi show up as having weak signal in Gargoyle GUI:

Image

Even though connected the Internet is useless on those devices (Gargoyle says bit rate of 1Mbps) and once they disconnect for any reason they cannot reconnect.

I'll let you know if adding the txpower option fixes it.
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.

Volaris
Posts: 165
Joined: Thu May 01, 2014 1:02 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Volaris » Tue Oct 13, 2015 2:51 am

Eric wrote:I seriously doubt the ap_g name of the section is the issue.

Next things to test (one at a time, in this order or probability that each is responsible):
(1) remove the dissassoc_low_ack '0' line and see if that makes a difference
(2) Add back the txpower line

Wireless failed at 11pm again, so the txpower line didn't help. So both of those didn't help stability. :(

Any other recommendations? At a loss for options, I went ahead and removed the ap_g name from the wifi-iface line to match the OpenWRT config. I'm not sure what else could be causing it.

This http://i.imgur.com/LDf0gYM.png is the config that seemed to work for me (was stable for over 3 days). Could it be the +ccmp (AES only mode) in encryption that helped?

EDIT: Quickest wireless fail ever. Removing wifi-iface didn't work. Became unresponsive after half hour or less.

Trying the OpenWRT build in the link above without the +ccmp in encryption line.
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.

Eric
Site Admin
Posts: 1439
Joined: Sat Jun 14, 2008 1:14 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Eric » Tue Oct 13, 2015 1:59 pm

Another possibility: the channel.

Is it possible that there is a lot of interference on channel 11 where you live? What happens if you switch the channel to auto, which will make it default to the lowest channel (other end of the spectrum from channel 11)?

Volaris
Posts: 165
Joined: Thu May 01, 2014 1:02 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Volaris » Tue Oct 13, 2015 8:02 pm

Eric wrote:Another possibility: the channel.

Is it possible that there is a lot of interference on channel 11 where you live? What happens if you switch the channel to auto, which will make it default to the lowest channel (other end of the spectrum from channel 11)?

Sometime in the last week I switched it to channel 6 thinking the same thing (channel 6 is pretty much empty, just one other intermittent network and it's -95 dBm or weaker according to WiFi analyzer).

I had it on channel 11 but I noticed the second strongest WiFi network seen from my house is on that channel (-70 dBm) so I moved it to channel 6.

Channel 1 is completely crowded, and some AppleRouter that somehow manages to reach every spot of my house sits on that channel.

If I set it to auto, it loves to default to channel 4... not sure why since channel 1 is so busy. This was the reason I stopped using auto channel. Am I correct that only channels 1, 6, and 11 are optimal? All other channels are empty.
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.

ispyisail
Moderator
Posts: 4706
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby ispyisail » Tue Oct 13, 2015 9:09 pm

@Volaris

I assume it was your original statement (Have't checked the full thread) that stated that "OpenWRT CC wifi work perfect but gargoyle CC does not?"

What chanel where you using with Openwrt CC that worked perfect.

In my mind we need to copy that perfect setup?

Volaris
Posts: 165
Joined: Thu May 01, 2014 1:02 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Volaris » Wed Oct 14, 2015 11:49 am

ispyisail wrote:@Volaris

I assume it was your original statement (Have't checked the full thread) that stated that "OpenWRT CC wifi work perfect but gargoyle CC does not?"

What chanel where you using with Openwrt CC that worked perfect.

In my mind we need to copy that perfect setup?

Yes, wireless on OpenWRT BB and CC both work stable. On Gargoyle it has been broken since 1.7. On OpenWRT I've used auto channel and channel 11, while on Gargoyle I've used auto, 11, and 6. I really do not think there's any correlation between wireless channels. I've seen both stable and unstable on all those channels.

OpenWRT uses the following wireless config:

Image

I'm currently testing it again on Gargoyle. I've copied and pasted it to Gargoyle and the only changes I made was change auto channel to 6 (since Gargoyle doesn't do auto channel) and removed the +ccmp from encryption (since there's no force AES only option on Gargoyle GUI).

So far it's been up and stable for the past 32 hours. Will keep monitoring.
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.

Volaris
Posts: 165
Joined: Thu May 01, 2014 1:02 pm

Re: CC Build gargoyle-ispy 2015-September-28 06:43.torrent

Postby Volaris » Mon Oct 19, 2015 2:26 pm

Update: tried the slightly modified OpenWRT wireless config (changed channel from auto to 6 and removed +ccmp from encryption since Gargoyle doesn't use those).

Image

Unfortunately, that did not fix the issue completely, but it greatly improved the symptoms. The issue now happens every 3 days or so (happened on 3rd and 6th day) and the router fixes itself completely after about half hour. Still though... that's not perfect so I still consider it broken... but it's way better than the die forever after 1-2 days that I previously had with the Gargoyle wireless config.

Image

Another thing I discovered. When this issue happens and WiFi refuses to reconnect, I can set a DHCP manual IP address on my laptop and it'll connect fine. At least it helps me quickly log onto the router to read the log...

I just discovered how to get hostapd debug logs, so I set that up since I want to get to the real cause of this. Hopefully those logs will help the next time this happens. For now, I reset the wireless config back to the Gargoyle one (with 11ng changed to 11g) and I'll read the logs once this happens again.

Image
QoS Tip: Don't complicate your QoS settings. Gargoyle evenly splits available bandwidth between active devices as needed. Just delete all your classification rules and leave only one normal service class and you're done. No more arguing over bandwidth.


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 2 guests