Page 2 of 2

Re: gargoyle-ispy 2015-March-19 15:16.torrent

Posted: Fri Mar 20, 2015 2:13 pm
by Eric
Another good catch, can confirm the upgrade interface is broken in this version (another side-effect of switching to uhttpd). This issue should now be fixed with commit de46a2c.

To get around the upgrade limitation of the interface in the last version, ssh in with user=root,pass=[your_login_pass], and run sysupgrade (sysupgrade -n to prevent the system from trying to save setttings). Sysupgrade is better than mtd as it has a few extra precautions to prevent shooting yourself in the foot when doing the upgrade, including a check that the image is for the right router.

Re: gargoyle-ispy 2015-March-19 15:16.torrent

Posted: Fri Mar 20, 2015 2:38 pm
by ispyisail
http://wiki.openwrt.org/doc/howto/generic.sysupgrade

Code: Select all

cd /tmp
wget http://www.gargoyle-router.com/downloads/images/ar71xx/gargoyle_1.7.1-ar71xx-generic-tl-wdr3600-v1-squashfs-sysupgrade.bin
sysupgrade -v /tmp/gargoyle_1.7.1-ar71xx-generic-tl-wdr3600-v1-squashfs-sysupgrade.bin


Change for your router

haven't tested

Re: gargoyle-ispy 2015-March-19 15:16.torrent

Posted: Fri Mar 20, 2015 2:47 pm
by Eric
If you're downgrading back to 1.7.1, you should do a sysupgrade -n, so:

Code: Select all

cd /tmp
wget http://www.gargoyle-router.com/downloads/images/ar71xx/gargoyle_1.7.1-ar71xx-generic-tl-wdr3600-v1-squashfs-sysupgrade.bin
sysupgrade -n /tmp/gargoyle_1.7.1-ar71xx-generic-tl-wdr3600-v1-squashfs-sysupgrade.bin


There is a mechanism in place to ensure a smooth upgrade from 1.7.1 to later versions, but downgrading may cause problems unless you do not preserve settings.

Re: gargoyle-ispy 2015-March-19 15:16.torrent

Posted: Fri Mar 20, 2015 7:35 pm
by KREAT0R
I hve the same problem to upgrade or downgrade via gui in gargoyle-ispy 2015-March-18 10_33.
Reverted back to 1.6.x nov-9 via TFTP.

Waiting for new build fixed :D

Sorry for my spanglish :lol: