Page 1 of 2

Version 1.7.0 - Barrier Breaker Bugs

Posted: Thu Jan 08, 2015 2:15 pm
by ispyisail
Hi all

Eric would like some assistance in confirming bugs in 1.7.0

His list so far

Please do keep sending bug reports my way, especially if you can verify the problem yourself.

My bug investigation check-list on 1.7.0 that I've gotten from the forums is like this:

(1) Problems with Theme/Plugin installation -- Confirmed, but only after initial first boot. Rebooting after installation resolves this. I've seen this intermittent bug before. I think this has to do with a quirk of the filesystem, and I would have to get into some low level code to resolve it properly, and it can be addressed by simply rebooting once and never again, so it's not a top priority. (Status: Confirmed, Not Resolved, but not a high priority due to simple way to address it)

(2) Some posts implied that the images were too big for routers with 4MB of flash. I tried this but they installed fine for me. (Status: Cannot reproduce)

(3) OpenVPN issues, in particular lack of access to LAN hosts from VPN when routing configured. Not only could I confirm this bug, but there was another MAJOR bug with OpenVPN which prevented uploading of zipped config files, which I fixed along with this. (Status: Confirmed, fix applied)

(4) In Status/Overview page second band of dual band configurations is not displayed. (Status: Confirmed, fix applied)

(5) Several reports of problems with 3G (Status: Not yet investigated)

(6) Several reports of issues with USB Printer functionality (Status: Not yet investigated)

(7) Report of MiniDLNA not scanning proper media root (Status: Not yet investigated)

(8) (From your note below) Report of hotplug scripts for buttons not working correctly. (Status: Not yet investigated)


That's my current list of potential/reported bugs, and status of each, in case you're interested. If you can personally verify/confirm any of these bugs that I've marked as not yet investigated it would be helpful.


Thanks

Re: Version 1.7.0 - Barrier Breaker Bugs

Posted: Thu Jan 08, 2015 2:47 pm
by Eric
Thanks for posting this here.

I probably should have posted this list here as well as just sending it to ispyisail, when he inquired about the current status of BB bugs. This is, indeed, the current bug-report status for 1.7.0.

Worth Noting: if you test for any of the above bugs, and cannot reproduce the problem, i.e. everything works, REPORT THAT HERE TOO! Failure to reproduce a bug is also a useful result/worth knowing.

Re: Version 1.7.0 - Barrier Breaker Bugs

Posted: Thu Jan 08, 2015 7:59 pm
by Lantis
Issue 7, MiniDLNA

"Number of connections -1" bug.

Hardware: WNDR3800 on 1.7.0
2TB hard drive NTFS format

image.jpg
image.jpg (127.11 KiB) Viewed 7043 times

Re: Version 1.7.0 - Barrier Breaker Bugs

Posted: Fri Jan 09, 2015 4:16 am
by phgerin
Small bug,
After an upgrade on my WDR3600, the web search/history is not updated anymore. A "clear history" is needed to fix it.

Re: Version 1.7.0 - Barrier Breaker Bugs

Posted: Fri Jan 09, 2015 5:09 am
by tapper
Hi for the next build of Gargoyle, can you bump BB to 43889?

BB: openssl: update to v1.0.1k (8 CVEs)

Fixes CVE-2014-3571, CVE-2015-0206, CVE-2014-3569, CVE-2014-3572,
CVE-2015-0204, CVE-2015-0205, CVE-2014-8275 and CVE-2014-3570.

https://dev.openwrt.org/changeset/43889

Re: Version 1.7.0 - Barrier Breaker Bugs

Posted: Fri Jan 09, 2015 2:39 pm
by ispyisail
tapper wrote:Hi for the next build of Gargoyle, can you bump BB to 43889?

BB: openssl: update to v1.0.1k (8 CVEs)

Fixes CVE-2014-3571, CVE-2015-0206, CVE-2014-3569, CVE-2014-3572,
CVE-2015-0204, CVE-2015-0205, CVE-2014-8275 and CVE-2014-3570.

https://dev.openwrt.org/changeset/43889


http://www.pcworld.com/article/2867372/ ... ities.html

Re: Version 1.7.0 - Barrier Breaker Bugs

Posted: Tue Jan 20, 2015 9:31 pm
by papaskitch
ispyisail wrote:(1) Problems with Theme/Plugin installation -- Confirmed, but only after initial first boot. Rebooting after installation resolves this. I've seen this intermittent bug before. I think this has to do with a quirk of the filesystem, and I would have to get into some low level code to resolve it properly, and it can be addressed by simply rebooting once and never again, so it's not a top priority. (Status: Confirmed, Not Resolved, but not a high priority due to simple way to address it)



I'm running 1.7.X (Built 20150109-0720 git@da35789) on an Asus RT-N16 (BRCM47xx build) and under plugins I only see language packs and nothing else. A reboot doesn't resolve this. Is this related, or are there simply no plugins for this device?

I'm using the standard plugin sources:

Image

Re: Version 1.7.0 - Barrier Breaker Bugs

Posted: Wed Jan 21, 2015 2:10 am
by Andy
papaskitch wrote:
ispyisail wrote:(1) Problems with Theme/Plugin installation -- Confirmed, but only after initial first boot. Rebooting after installation resolves this. I've seen this intermittent bug before. I think this has to do with a quirk of the filesystem, and I would have to get into some low level code to resolve it properly, and it can be addressed by simply rebooting once and never again, so it's not a top priority. (Status: Confirmed, Not Resolved, but not a high priority due to simple way to address it)



I'm running 1.7.X (Built 20150109-0720 git@da35789) on an Asus RT-N16 (BRCM47xx build) and under plugins I only see language packs and nothing else. A reboot doesn't resolve this. Is this related, or are there simply no plugins for this device?


Did you try clicking the "Refresh Plugins" button?

Re: Version 1.7.0 - Barrier Breaker Bugs

Posted: Wed Jan 21, 2015 8:26 am
by papaskitch
Andy wrote:Did you try clicking the "Refresh Plugins" button?

Yes but still no non-language plugins.

Re: Version 1.7.0 - Barrier Breaker Bugs

Posted: Wed Jan 21, 2015 12:46 pm
by tapper
I can't bet dnscrypt to work any more in 1.7 but not shore why yet you can see more on this thread.
https://forum.openwrt.org/viewtopic.php?id=55216