Page 1 of 1

Help on building custom Gargoyle

Posted: Wed May 08, 2013 4:44 pm
by Swimmer
Hello all,

I'm trying to build a custom Gargoyle for me, nothing special but I would like to have some things removed from 1.5.9 and install others (like transmission).

I've tried to do this:

Ubuntu 13.04 64b

Installed the packages needed

Code: Select all

sudo apt-get install git 


Code: Select all

git clone git://gargoyle-router.com/gargoyle.git


Code: Select all

make custom


After running for a little while running with my defenitions, I've got this:

make[2]: *** [/home/swimmer/gargoyle/custom-src/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.tools_install_nnnnn] Error 2
make[2]: Leaving directory `/home/swimmer/gargoyle/custom-src'
make[1]: *** [world] Error 2
make[1]: Leaving directory `/home/swimmer/gargoyle/custom-src'
find: ‘bin’: No such file or directory
find: ‘bin’: No such file or directory
ls: cannot access bin: No such file or directory


Can anyone help? What have I did wrong? How can I overcome this error?

Re: Help on building custom Gargoyle

Posted: Thu May 09, 2013 7:44 am
by powerlogy
Check this page mate http://www.gargoyle-router.com/wiki/dok ... umentation
or

Code: Select all

make custom.default

Re: Help on building custom Gargoyle

Posted: Thu May 09, 2013 1:19 pm
by powerlogy
For build error :

Edit this line on both rebuild.sh and build.sh files.

Eric wrote:edit build.sh and change line 20 from:

Code: Select all

num_build_threads=$(($num_cores + 2))


to:

Code: Select all

num_build_threads=1


That will significantly slow down the build (especially on multi-core systems), but it will guarantee that any error messages you see are relevant to what the real problem is.

Re: Help on building custom Gargoyle

Posted: Thu May 09, 2013 2:32 pm
by Swimmer
Trying...

EDIT: I think it worked. Tomorrow I'll try to install it.

Thanks for the help

Re: Help on building custom Gargoyle

Posted: Sun Dec 29, 2013 6:16 am
by mates
Hi

I am trying build gargoyle

i install oracle vm virtualbox with 64b ubuntu 13.10
I install git

Code: Select all

sudo apt-get install git


and when i am using

Code: Select all

git clone git://gargoyle-router.com/gargoyle.git


then i got only message Cloning into gargoyle' ...
I waited abut 30 minutes ... nothing more ... what should be wrong?'