Page 1 of 2

1.11x gargoyle-ispy 2018-September-21 02:11

Posted: Thu Sep 20, 2018 3:05 pm
by ispyisail
same as last build but with x86



Now includes packages

Do not install on 4MB routers


1.11x gargoyle-ispy 2018-September-21 02:11



Re: 1.11x gargoyle-ispy 2018-September-21 02:11

Posted: Thu Sep 20, 2018 7:37 pm
by mojolacerator
x86 running smooth as silk !

Re: 1.11x gargoyle-ispy 2018-September-21 02:11

Posted: Fri Sep 21, 2018 9:42 am
by doug_porsche
Beginners question.

I love the Adblock plugin.

To get the Adblock plugin ( to work with 1.11 need to also install the plugin as per your earlier thread.

Will ever be standard, or do I just need to add installing the plugin to my standard procedure?

second question.

My 5GHz SSID seems to not be solid.
I am well withing range, about 10 ft away from the Wifi modem so I dont think its a signal strength/range issue. when searching for a network, its there one minuet and not the next then back, lather, rinse, repeat.

The 2.4GHz SSID seems to be solid. Always there for ever network search.

Thanks in advance

Re: 1.11x gargoyle-ispy 2018-September-21 02:11

Posted: Fri Sep 21, 2018 6:01 pm
by Lantis
On official releases it will be hosted on the Gargoyle site.
I don’t think it a good idea to hardcode a moving target into the image at this stage.

Also are you really using an x86-64 device? If not, make sure you’re adding the right plugin repository for your device.

Re: 1.11x gargoyle-ispy 2018-September-21 02:11

Posted: Fri Sep 21, 2018 9:58 pm
by doug_porsche
ok, I am embarrassed

I am running a NETGEAR WNDR3700v4
so the is not correct.

what should I be using?

Re: 1.11x gargoyle-ispy 2018-September-21 02:11

Posted: Sat Sep 22, 2018 4:22 am
by Lantis

Re: 1.11x gargoyle-ispy 2018-September-21 02:11

Posted: Tue Sep 25, 2018 5:30 pm
by danielwritesback
Thank you so much! This works on my Archer C7v2.

This is my first time to use Gargoyle.

The 5ghz wifi is fantastic, the QOS works really well, but the 2.4ghz wifi is at 1/5th of normal throughput. To double-check that, I plugged in my 150n Edimax AP, and it was three times faster than the 450n Archer. wt?

Notably, there was a [fixable] conflict with Google Home Mini and Gargoyle. That's because many iot's engage a hotspot/ap function for configuration, only until they are associated.
Of course that's going on during Gargoyle startup, while it is scanning for neighbor wifi. Oops!!! That function is so broken when modern wifi devices are nearby.

After that, was my first experience with Vi.

For the Archer, I changed to:
noscan 1 (don't cut the speed when you own iot's)
country_ie 0 (bandwidth-thrifty beacons)
beacon_int 300 (healthier 3hz rate)
dtim_period 2 (phone power save works)

That changed the Archer's 2.4ghz wifi, from 20% of normal performance to half. Well, that's quite serviceable! But, I have to wonder why it is software limited to far below U.S. regulatory max?

I couldn't find the documentation on how to set preamble to auto/long and to enable cts-to-self. But, I would like to try those. May I have a link to that documentation?

And here's great bit:
Previously with factory and dd firmware, I'd had wan instability, as well as dropped connections to the Google Home Mini.
Gargoyle QOS fixed it! KUDOS!!!!
After finding a hint about prioritize the device, I tried the Gargoyle QOS. The little documentation left a lot to guess, and here goes:
Static dhcp addresses for the two googles, and I put them in upload and download QOS Fast classification. I've changed the upload qos from 10/90 to 20/80. This I copied to the download qos (changing the normal from 100 to 20 and adding a fast at 80). For the fast groups, I've added minimums 128k upload and 384k download (for adjusting later, if needed).

Well, color me surprised!
Every multicast thing works uninterrupted: google home mini can play all day and wifi printer scanner is actually able to scan, and the wan drop problem is gone.

I actually had two likely replacement routers in the mail (mid-broadcom, tomato target) and on the way, because I thought my archer was unstable. Murphey's law?
Thanks to Gargoyle, my Archer works really well now.

Re: 1.11x gargoyle-ispy 2018-September-21 02:11

Posted: Wed Oct 03, 2018 5:18 pm
by apvm
Gargoyle is my favorite firmware for my WRT1900AC V2. Tested this build but have same problem with David's LEDE build. The problem is my ISP has assigned me an ip address which is expired and always renewing (according to my back up Asus router's firmware) what happen is in less than a minute all clients will lose internet connection, Wan still report connection with my DSL modem.

This problem does not happen with Asuswrt merlin build with my backup Asus router and DDWRT with WRT1900AC V2.

Looks like I have to wait for the final release before going back to Gargoyle.

Appreciate your hard work and please keep it up. Thanks again.

Re: 1.11x gargoyle-ispy 2018-September-21 02:11

Posted: Wed Oct 03, 2018 6:32 pm
by Lantis
I appreciate the issue you are facing and saw your post on the Openwrt forums.
Unfortunately, unless it gets fixed upstream in Openwrt, Gargoyle is unlikely to get a fix either.

You would be best reporting it as a bug in the Openwrt bug tracker and trying to find out why it works in ddwrt versus Openwrt.

Re: 1.11x gargoyle-ispy 2018-September-21 02:11

Posted: Thu Oct 04, 2018 6:13 am
by apvm
Jumped the gun too early, it did not work with ddwrt either. After looking at the settings of merlin's asuswrt, I think I found a solution (I hope, still testing). With asus, the always on is set at 0 seconds. I set Gargoyle keep alive "ping interval" and "failed ping before reconnect" both to zero. It is working for the past 10 minutes while I am typing this.

With DDWRT if I use "on demand" although it reported wan connection but no internet access, if I changed to keep alive, (no option for 0 seconds) the internet connection will reconnect whatever the seconds I input there, say if I put 30, internet connect will stop for a few seconds every 30 seconds.

For David's lede, couldn't find the option for the keep alive.

I think my problem is my ISP has assigned me a static ip and it is always trying to renew the lease time. emailed my ISP to see if they can do something on that.

Thanks again, I hope I finally fixed this by setting everything to zero seconds. really love Gargoyle.