Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

Lantis
Moderator
Posts: 5057
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Postby Lantis » Sun Aug 25, 2019 7:31 am

I recently sent a patch upstream to the ath10k-ct driver maintainer to fix 160MHz on this device and it was applied.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

pythonic
Posts: 31
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Postby pythonic » Sun Aug 25, 2019 8:57 am

Lantis wrote:I recently sent a patch upstream to the ath10k-ct driver maintainer to fix 160MHz on this device and it was applied.

This 1.11.0 build (18.06.x) is still on the original ath10k driver of course so would be missing the 160MHz support - the 1.13.x release (19.07) you have in development will use the ath10k-ct driver and will hopefully include your patch. There are still some reports of the -ct driver being unstable for some people though it seems to have improved considerably in the last few months.

Lantis
Moderator
Posts: 5057
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Postby Lantis » Sun Aug 25, 2019 9:16 am

Anyone who is adventurous can try it if they wish, but i make no guarantees.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

bluegravy
Posts: 29
Joined: Mon Jul 10, 2017 12:50 pm
Location: Eastern Panhandle West Virginia, USA

Re: Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Postby bluegravy » Sun Aug 25, 2019 11:50 pm

Thanks guys...Yes, the AdBlock Plug in is installed. I check the box to enable AdBlock and hit save config and when it is complete, the enable box unchecks itself. I'll try uninstall / reinstall of the plug-in. I have my 5G radio set for United States with its own SSID for A+N+C and 160 Mhz channel width. I am only able to select channels 36 and 100. Also is there any room to make 2.4G auto-channel selectable? I'll play around with it to see if I can get the radio to come on. I thought there was a manual option to change in the config. Also, as reported before Wifi LED's are dark.

Also, Lantis any ETA on 1.13.x?

Thanks,

Andy near WashDC USA

bluegravy
Posts: 29
Joined: Mon Jul 10, 2017 12:50 pm
Location: Eastern Panhandle West Virginia, USA

Re: Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Postby bluegravy » Sun Aug 25, 2019 11:55 pm

I played around with the settings and killed 160Mhz and dropped it down to 80Mhz and the 5G radio came up with the usual channels. Makes sense that this build doesn't have the 160Mhz support now.

Andy

ispyisail
Moderator
Posts: 4633
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Postby ispyisail » Mon Aug 26, 2019 2:48 am

Also, Lantis any ETA on 1.13.x?


If your brave you can build you own and have it now

https://github.com/lantis1008/gargoyle/ ... enwrt_1907

Lantis
Moderator
Posts: 5057
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Postby Lantis » Mon Aug 26, 2019 4:22 am

36 and 100 are the only valid 160mhz channels.
I added support for 80+80mhz too (You won't find that in OpenWrt!)

Auto channel is a bit of a misnomer. In OpenWrt it doesn't actually do anything.
For some ath9k and ath10k devices you can compile in ACS (auto channel selection), but I've never had much luck with it working. Best to choose your own.

Builds are available here:
https://lantisproject.com/gargoyle_custom/
Or build the latest as Spy suggested.
Routers: Various ar71xx/mvebu/x86-64
http://lantisproject.com/downloads/gargoyle_ispyisail.php for the latest releases

pythonic
Posts: 31
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Postby pythonic » Mon Aug 26, 2019 8:46 am

I've successfully flashed a new Linksys EA8500 with the 1.11.0 factory image via the web UI firmware update function and rebooted it into Gargoyle. I haven't used it as a gateway yet though - that will have to wait a bit.

The Netgear D7800 now has 76 days uptime.

bluegravy
Posts: 29
Joined: Mon Jul 10, 2017 12:50 pm
Location: Eastern Panhandle West Virginia, USA

Re: Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Postby bluegravy » Mon Aug 26, 2019 1:19 pm

Thanks for the info guys. As for compiling my own 1.13.x...I wholeheartedly admit I am NOT that brave, nor do I have the time! :D

pythonic
Posts: 31
Joined: Mon Mar 11, 2019 5:47 am
Location: Australia

Re: Experimental build of Gargoyle 1.11.0 for ipq806x architecture routers

Postby pythonic » Sun Sep 15, 2019 6:45 am

The EA8500 had been in and running nicely on the 1.11.0 build for me for over a week, so I plucked up the courage to try a sysupgrade to Lantis' 1.13.x custom build. This has now been running for nearly 24 hours so early days but so far so good.

The only slightly odd thing: the browser still had the spinning upgrade dialog running at least a minute after the router had successfully rebooted - when I jumped to the normal login URL I was able to login and configure it no problems so the issue may have just been Firefox (on Linux) having some cache issues (I did see a couple of other interface oddities while configuring that I now can't replicate... :roll: )


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 5 guests