Gargoyle 1.11.0 Release Candidate 5

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

ispyisail
Moderator
Posts: 4347
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Gargoyle 1.11.0 Release Candidate 5

Postby ispyisail » Wed Feb 06, 2019 5:41 pm

updated my quick and dirty how-to

viewtopic.php?f=14&t=11883&p=51971#p51971

ViBE
Posts: 123
Joined: Sun Apr 19, 2015 6:58 pm

Re: Gargoyle 1.11.0 Release Candidate 5

Postby ViBE » Thu Feb 07, 2019 3:00 am

ispyisail wrote:updated my quick and dirty how-to

viewtopic.php?f=14&t=11883&p=51971#p51971

thanks. thats pretty simplify things.

ViBE
Posts: 123
Joined: Sun Apr 19, 2015 6:58 pm

Re: Gargoyle 1.11.0 Release Candidate 5

Postby ViBE » Sun Feb 10, 2019 9:40 am

Lantis wrote:1. make custom
2. Select ipq40xx target
3. Select all Gargoyle packages and dependencies from the Administration menu (hint, there is more to be found than what is just shown initially, you may need to enable other dependencies first)
4. Exit and save config, then quit the build
5. Grab .config file from custom-src/.config and save it as targets/ipq40xx...../config. Add the other files as required to create a valid target
6. make clean
7. make FULL_BUILD=true ipq40xx

https://www.gargoyle-router.com/wiki/do ... umentation
https://openwrt.org/docs/guide-develope ... uildsystem
https://openwrt.org/docs/guide-user/add ... uild-guide


"3. Select all Gargoyle packages and dependencies from the Administration menu (hint, there is more to be found than what is just shown initially, you may need to enable other dependencies first)"

that's not clear. do i need to determinate what are the exact components to figure out the dependencies? or i can use this: https://wikidevi.com/wiki/ASUS_RT-AC58U

Lantis
Moderator
Posts: 4595
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle 1.11.0 Release Candidate 5

Postby Lantis » Sun Feb 10, 2019 3:59 pm

An example
To enable plugin_gargoyle_minidlna, you first need to enable build_patented
To enable plugin_gargoyle_email_notifications, you first need to enable smtp.

If you press “/“ while navigating the menu and then search for “gargoyle”, you can view each gargoyle package and what its dependencies are.
WRT32X on 1.11.X
Various ar71xx/mvebu boards in a constant state of flux
www.lantisproject.com for custom builds and other projects
www.lantisproject.com/gargoyle_ispyisail/ for the latest releases

ispyisail
Moderator
Posts: 4347
Joined: Mon Apr 06, 2009 3:15 am
Location: New Zealand

Re: Gargoyle 1.11.0 Release Candidate 5

Postby ispyisail » Mon Feb 11, 2019 5:02 am

ipq40xx target


I con't find ipq40xx either ?

Lantis
Moderator
Posts: 4595
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle 1.11.0 Release Candidate 5

Postby Lantis » Mon Feb 11, 2019 6:02 am

It’s referred to as “Qualcomm Atheros IPQ40XX”
https://git.openwrt.org/?p=openwrt/open ... nwrt-18.06
WRT32X on 1.11.X
Various ar71xx/mvebu boards in a constant state of flux
www.lantisproject.com for custom builds and other projects
www.lantisproject.com/gargoyle_ispyisail/ for the latest releases

Lantis
Moderator
Posts: 4595
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: Gargoyle 1.11.0 Release Candidate 5

Postby Lantis » Wed Feb 13, 2019 7:46 am

RomanHK wrote:
Lantis wrote:f2fs is possibly the only one that wouldn’t let it boot properly.
Including ath9/10k are both quite big for the sake of a single target.

If it works I may need to split it into a new target profile.

The main issue appears to be the initramfs.


I used initramfs from here: https://downloads.openwrt.org/releases/ ... mfs.tar.gz . It's just about mediating uploading and flash gargoyle_1.11.x-mvebu-cortexa9-turris-omnia-sysupgrade.img.gz . Perhaps the current version of OpenWrt is sufficient.

f2fs is the default OpenWrt file system on this router.
I fed it with the command: mkfs.ext4 /dev/loop0 and reboot, so the configuration was saved correctly (ext4 but not suitable for flash).

ath9 / 10k is inevitable for wireless network operation (it would be an additional manual installation via opkg, but it would have to be a permanent storage with the current kernel). The directory https://downloads.openwrt.org/releases/ ... -a9_vfpv3/ has already changed and so opkg can not be used.

If this helps, I did not use the gargoyle_1.11.x-mvebu-cortexa9-turris-omnia-kernel.bin file - the flash did without this file.


Please try the image at http://lantisproject.com/gargoyle_custom/turris-omnia/

I have included ath9k + ath10k, as well as some other pre-requisite files.
I have also corrected the corrupted medkit file which should now work properly.
WRT32X on 1.11.X
Various ar71xx/mvebu boards in a constant state of flux
www.lantisproject.com for custom builds and other projects
www.lantisproject.com/gargoyle_ispyisail/ for the latest releases

RomanHK
Posts: 41
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: Gargoyle 1.11.0 Release Candidate 5

Postby RomanHK » Wed Feb 13, 2019 2:19 pm

Lantis wrote:
Please try the image at http://lantisproject.com/gargoyle_custom/turris-omnia/

I have included ath9k + ath10k, as well as some other pre-requisite files.
I have also corrected the corrupted medkit file which should now work properly.

Wow, perfect +1. On the functional page, everything is fine. Result:

omnia-medkit-gargoyle_1.11.x-mvebu-cortexa9-turris-omnia-initramfs.tar.gz = O.K.
gargoyle_1.11.x-mvebu-cortexa9-turris-omnia-sysupgrade.img.gz = O.K.

Network (LAN, WAN) = O.K.
Wireless AP (2,4 and 5GHz) = O.K.
USB (Printer, HDD) = O.K.

Currently, you need to edit (add) Plugin Sources:
http://downloads.openwrt.org/releases/1 ... 9/packages = important for opkg
http://lantisproject.com/gargoyle_custo ... ia/default = temporary route for RC (custom)
http://lantisproject.com/gargoyle_custo ... elspecific = temporary route for RC (custom)
openwrt_18.06-snapshot = I have to warn that content is changing.

Now I will test stability - it will take a while.

P.S. In the future I will translate the GUI into the Czech language.

Good work, congratulations.

qzzipc
Posts: 1
Joined: Tue Feb 19, 2019 1:18 pm

Re: Gargoyle 1.11.0 Release Candidate 5

Postby qzzipc » Tue Feb 19, 2019 1:49 pm

I'm upgrade my TP-Link TL-WR1043N/ND v1 from 1.10 to 1.11 for the first time and i'm not very happy about the adblock plugin.

First what i did is to find how to install the adblock plugin, but i found the repository fast with the search engine in this forum.
http://lantisproject .com/gargoyle_1.11.x_rc3/ar71xx/usb_large_nand

After that I can install adblock plugin! :D
But then i going to ssh adding a hosts link in runadblock file from StevenBlack/hosts. I have add this hosts type: Unified hosts = (adware + malware) (1.2MB and 38,958 lines)
i Use the http version (not the httpS, httpS doesn't working with the gargoyle firmware and you know that)

But when i click on update Blocklist, then the Block list search results displaying on 0/0 :(

With http://winhelp2002.mvps. org/hosts.txt works perfect, but i wish to use the hosts from stevenblack :(

I have this problem NOT in gargoyle version 1.10. I think the hosts file is to big for 1.11.

This is the space what i now have in version 1.11. I have only installed adblock (after the firmware upgrade) and for now i use only the winhelp2002.mvps hosts file.

Plugin Root: /plugin_root
Root Drive 1.188 MBytes Total, 872.000 kBytes Free

Please, can you add a littlebit more space maybe?? Or have you another (better) hosts file as alternative? (and yes i have heard about pi-hole, but i wish to do it with my router + gargoyle)

RomanHK
Posts: 41
Joined: Sat May 04, 2013 4:18 pm
Location: Czech Republik

Re: Gargoyle 1.11.0 Release Candidate 5

Postby RomanHK » Tue Feb 19, 2019 3:42 pm

qzzipc wrote:I'm upgrade my TP-Link TL-WR1043N/ND v1 from 1.10 to 1.11 for the first time and i'm not very happy about the adblock plugin.

You will probably have no memory (V1 only has 32MB of RAM!)
The blocklist increases every day. On Adware + Malware you need a lot of RAM space (I myself had problems already in V2 version (64MB RAM). I add that they are already using HTTPS and need to use SSL (or the uclient-fetch + edit wget source library) you will not have room in Flash memory again.

I currently own another router (1GB RAM) and here I have adblock Adware + Malware + my own OpenWrt adblock filters and I'm very satisfied.

I use Adblock from OpenWrt in version 3.5.5.3 (http://downloads.openwrt.org/releases/1 ... -3_all.ipk) - configuration is done in LuCI, on Gargoyle is just for the experienced.

EDIT: If you can change hosts, try changing the row in runadblock.sh as follows:

Code: Select all

wget -qO- --no-check-certificate "https://github.com/StevenBlack/hosts/raw/master/hosts" | awk -v r="$ENDPOINT_IP4" '{sub(/^0.0.0.0/, r)} $0 ~ "^"r' > /tmp/block.build.list

It may help you.
Last edited by RomanHK on Tue Feb 19, 2019 5:32 pm, edited 1 time in total.


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: Google [Bot] and 4 guests