[TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Want to share your OpenWrt / Gargoyle knowledge? Implemented a new feature? Let us know here.

Moderator: Moderators

phgerin
Posts: 95
Joined: Sun Dec 21, 2014 2:03 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Postby phgerin » Tue May 15, 2018 6:46 am

phgerin wrote:Does anyone know how to install snmpd ?
Tried http://downloads.lede-project.org/snaps ... /packages/

snmpd does install but crashes.


works with

http://downloads.lede-project.org/snaps ... /packages/

Rog66
Posts: 167
Joined: Fri Jan 04, 2013 4:53 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Postby Rog66 » Tue May 15, 2018 4:19 pm

ok - have now reloaded on WRT1900ACS and have most functions running. I rebuilt the settings from scratch and tested as they were applied one by one and TOR appears to now be working.

My computer is showing no internet connection on its network icon although there is.

LANTIS - are the https/url blocking bits working in this version? If so will add those back tomorrow and see how it works.

UPDATE - sorry scratch all the above - wthin a few mins all internal dhcp and external dns lost :-( Back to 1.10 for now

Lantis
Moderator
Posts: 4134
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Postby Lantis » Tue May 15, 2018 4:41 pm

Yes they should be ok
WRT1900AC V1 on 1.10.X
WNDR3800/WRT3200ACM in a constant state of flux
www.lantisproject.com for custom builds and other projects
www.lantisproject.com/gargoyle_ispyisail/ for the latest releases

Rog66
Posts: 167
Joined: Fri Jan 04, 2013 4:53 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Postby Rog66 » Fri May 18, 2018 6:17 am

tried again - reset to default - OK
Set up LAN subnet and wireless - OK
Set up 4 static DHCP leases - OK
Enabled TOR to be triggered per host - dhcp failed

Disabling Tor doesn't restore function nor does reboot afterwards - its as though the TOR enabling is overwriting some config somewhere. Can anyone else replicate this?

phgerin
Posts: 95
Joined: Sun Dec 21, 2014 2:03 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Postby phgerin » Fri May 18, 2018 7:49 am

Not using Tor and no DHCP problem...

Rog66
Posts: 167
Joined: Fri Jan 04, 2013 4:53 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Postby Rog66 » Fri May 18, 2018 7:51 am

ok but can you enable the optin for tor to be triggered by individual hosts (you don't have to trigger any hosts) and see if a new client can join the network and receive an IP address?

(save your config before you do this so you can reload if it messes up)

Lantis
Moderator
Posts: 4134
Joined: Mon Jan 05, 2015 5:33 am
Location: Australia

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Postby Lantis » Fri May 18, 2018 8:16 am

phgerin wrote:Didn't test with previous builds.
I have tried noip.com and dyndns. It just don't update and the force option does nothing.

Mon May 14 14:02:07 2018 daemon.info ddns_gargoyle[4223]: Successfully retrieved local ip from url: http://www.tracemyip.org
Mon May 14 14:02:07 2018 daemon.info ddns_gargoyle[4223]: local IP = 109.129.yyy.xxx
Mon May 14 14:02:07 2018 daemon.info ddns_gargoyle[4223]: remote IP cannot be determined


Appears to be tied to SSL.
If you change the no-ip service to use http it will be ok.

I will investigate fixing properly.
WRT1900AC V1 on 1.10.X
WNDR3800/WRT3200ACM in a constant state of flux
www.lantisproject.com for custom builds and other projects
www.lantisproject.com/gargoyle_ispyisail/ for the latest releases

Rog66
Posts: 167
Joined: Fri Jan 04, 2013 4:53 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Postby Rog66 » Fri May 18, 2018 8:49 am

confirmed re DDNS - dns-o-matic not working either

lilunxm12
Posts: 13
Joined: Sun Aug 23, 2015 4:40 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Postby lilunxm12 » Fri May 18, 2018 11:10 am

Can confirm that ddns is broken in earlier (ispy-0425) build and also openwrt trunk (early April). So ddns is probably also broken on your build and it's probably an upstream issue.
Right now I'm on 17.01.4 stable and will test it again when 18.06 RC is released.

Rog66
Posts: 167
Joined: Fri Jan 04, 2013 4:53 pm

Re: [TESTERS WANTED] Gargoyle 1.11.x Bleeding Edge MVEBU

Postby Rog66 » Fri May 18, 2018 11:11 am

Have found the issue with enabling TOR - fired up my syslog and found dnsmasq crashed as soon as TOR was enabled with the following -

"bad address at line 54 of /var/etc/dnsmasq.conf.cfg01411c"

This line is added when TOR is enabled -

"server=/.onion/#9053"

Commenting it out restores dnsmasq straight away and TOR then functions. This line wasnt added when TOR was enabled in 1.10.

Anyone know what this line is supposed to do?

EDIT
Similary this line was added to /etc/config/dhcp which messed up all dns requests

"list server '/.onion/#9053"


Return to “Show / Tell / Contribute”

Who is online

Users browsing this forum: No registered users and 2 guests