75M/75M fiber, download slow when uploading full

Report wireless and/or network connectivity problems in this forum.

Moderator: Moderators

Post Reply
robnitro
Posts: 84
Joined: Sat Feb 26, 2011 4:50 pm

75M/75M fiber, download slow when uploading full

Post by robnitro »

Hi,
I have 75/75 fiber, that speed tests max 85/90.
(Both wan and lan ports both confirmed gigabit from system log.)

I set qos to 72/75, as that is well below the limits. Pings never go above 10 ms to google during any speed tests. ICMP and packets smaller than 85 are high priority.
Normal http class I limited down to 70/72, so there is space for any ACKs, priority, etc.

However, when downloading a huge file (linux distro by test), the download speed crawls down to <900 kB/s when uploading at full 70 or so Mbit in speed test. The router cpu load is not maxed out (WNDR3800 @800mhz) and ping -t google.com is showing 10 ms.

Why are downloads being killed, even with so much overhead available? Even at full 70Mbit download, the upload of acks is around 1 Mbit.

I have the same issue with latest trunk openwrt.

I thought that UPLOAD at normal priority wouldn't slow down the ACKs at high priority (which is confirmed to be going there), especially while DL is barely used!?

robnitro
Posts: 84
Joined: Sat Feb 26, 2011 4:50 pm

Re: 75M/75M fiber, download slow when uploading full

Post by robnitro »

So I tried 2 situations... I limited the upload to 60M, it still went below 900 kB/s (about 10mbit).
Then I limited the upload to 45M, same thing.
Then I tried 2 different PC's... one doing the download , then run the speed test.
Same thing.
No idea what is going on, because at limit 60 or 45 cpu is no where near fully loaded, and 45UL+ 10dl= 55mbit...

way less than the 75 ONE WAY limit, even if it were added up!

Both tests run with download uncapped and normal qos limit.

robnitro
Posts: 84
Joined: Sat Feb 26, 2011 4:50 pm

Re: 75M/75M fiber, download slow when uploading full

Post by robnitro »

Just tried the MI424WR actiontec router with default firmware.

No issues when downloading even with QOS off.
When uploading at 75 Mbit or even 80 Mbit, the download just drops a bit, to around 50 mbit.
Even at that time, pings shoot up to 100 ms... still the download doesn't drop to a crawl like it does with openwrt/gargoyle.

Confusing!?!?!???????

robnitro
Posts: 84
Joined: Sat Feb 26, 2011 4:50 pm

Re: 75M/75M fiber, download slow when uploading full

Post by robnitro »

The buffalo g300nh even with cpu maxed out qos on doesn't have this issue!

It's the WNDR3800 which is similar to WNDR3700... Stupid WAN port has driver issues:

https://dev.openwrt.org/ticket/13072

robnitro
Posts: 84
Joined: Sat Feb 26, 2011 4:50 pm

Re: 75M/75M fiber, download slow when uploading full

Post by robnitro »

There's a patch there that works. But I have only been able to apply it to openwrt barrier or trunk... as the AA driver has a bit different syntax. No amount of me trying to match it has got the patch to work right... It compiles but gargoyle doesn't boot properly on the router!
https://dev.openwrt.org/attachment/ticket/13072/ag71xx_dma.patch

https://dev.openwrt.org/raw-attachment/ticket/13072/ag71xx_dma.patch

Post Reply