VLAN Tagging on VDSL port - ISP requirement
Moderator: Moderators
VLAN Tagging on VDSL port - ISP requirement
Hi all,
I have a TP-Link TP-W9977 modem bridged to a TP-Link TL-WR1043ND V2 router, which is running Gargoyle 1.9.1. All is currently running well, on ADSL2+. However, we will be changing to VDSL2 soon and my ISP requires that I set VLANID: 100.
I have done some very basic dabbling in WinSCP and PuTTY, however my experience is very limited. I am hoping someone might be able to assist me in setting this up?
Also, generally speaking, am I better off making configuration changes via PuTTY/UCI or via WinSCP? As I have made some changes via UCI which have fixed some DNS rebinding related issues, however I am wondering if it is bad practise to use one over the other (is UCI preferred?), or to mix the two over time?
I have a TP-Link TP-W9977 modem bridged to a TP-Link TL-WR1043ND V2 router, which is running Gargoyle 1.9.1. All is currently running well, on ADSL2+. However, we will be changing to VDSL2 soon and my ISP requires that I set VLANID: 100.
I have done some very basic dabbling in WinSCP and PuTTY, however my experience is very limited. I am hoping someone might be able to assist me in setting this up?
Also, generally speaking, am I better off making configuration changes via PuTTY/UCI or via WinSCP? As I have made some changes via UCI which have fixed some DNS rebinding related issues, however I am wondering if it is bad practise to use one over the other (is UCI preferred?), or to mix the two over time?
Re: VLAN Tagging on VDSL port - ISP requirement
Everything you need to know is here:
https://wiki.openwrt.org/doc/uci/networ ... tch_config
If you want to post your /etc/config/network here (being mindful of any passwords it might contain) i might be able to guide you. However i'll just be referencing that wiki page as well
https://wiki.openwrt.org/doc/uci/networ ... tch_config
If you want to post your /etc/config/network here (being mindful of any passwords it might contain) i might be able to guide you. However i'll just be referencing that wiki page as well
https://lantisproject.com/downloads/gargoylebuilds for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.
Please be respectful when posting. I do this in my free time on a volunteer basis.
Re: VLAN Tagging on VDSL port - ISP requirement
Thanks Lantis, that would assist as I am getting a bit lost in all this.Lantis wrote:Everything you need to know is here:
https://wiki.openwrt.org/doc/uci/networ ... tch_config
If you want to post your /etc/config/network here (being mindful of any passwords it might contain) i might be able to guide you. However i'll just be referencing that wiki page as well
Here is my /etc/config/network:
Code: Select all
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'REMOVED'
config interface 'lan'
option ifname 'eth1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option dns 'REMOVED REMOVED'
config interface 'wan'
option ifname 'eth0'
option proto 'pppoe'
option username 'REMOVED'
option password 'REMOVED'
option keepalive '3 5'
option ipv6 '0'
option dns 'REMOVED REMOVED'
option peerdns '0'
config interface 'wan6'
option ifname 'eth0'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 6'
Do I make these changes by editing a file (via WinSCP), or do I enter a series of changes via UCI?
Re: VLAN Tagging on VDSL port - ISP requirement
This might get you started:
You have to bind the pppoe protocol to the vlan interface eth0.100 and configure your switch to have a vlan 100 which tags traffic being send on the vlan.
Code: Select all
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'REMOVED'
config interface 'lan'
option ifname 'eth1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option dns 'REMOVED REMOVED'
config interface 'wan'
option ifname 'eth0.100'
option proto 'pppoe'
option username 'REMOVED'
option password 'REMOVED'
option keepalive '3 5'
option ipv6 '0'
option dns 'REMOVED REMOVED'
option peerdns '0'
config interface 'wan6'
option ifname 'eth0.100'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4'
config switch_vlan
option device 'switch0'
option vlan '100'
option ports '5t 6t'
Re: VLAN Tagging on VDSL port - ISP requirement
Thanks AdriAdri wrote:This might get you started:
You have to bind the pppoe protocol to the vlan interface eth0.100 and configure your switch to have a vlan 100 which tags traffic being send on the vlan.Code: Select all
config interface 'loopback' option ifname 'lo' option proto 'static' option ipaddr '127.0.0.1' option netmask '255.0.0.0' config globals 'globals' option ula_prefix 'REMOVED' config interface 'lan' option ifname 'eth1' option force_link '1' option type 'bridge' option proto 'static' option ipaddr '192.168.1.1' option netmask '255.255.255.0' option ip6assign '60' option dns 'REMOVED REMOVED' config interface 'wan' option ifname 'eth0.100' option proto 'pppoe' option username 'REMOVED' option password 'REMOVED' option keepalive '3 5' option ipv6 '0' option dns 'REMOVED REMOVED' option peerdns '0' config interface 'wan6' option ifname 'eth0.100' option proto 'dhcpv6' config switch option name 'switch0' option reset '1' option enable_vlan '1' config switch_vlan option device 'switch0' option vlan '1' option ports '0 1 2 3 4' config switch_vlan option device 'switch0' option vlan '100' option ports '5t 6t'
I have already made some changes in UCI (DNS Rebinding related), how should I make the changes you suggested above? As there are a few entries I would think WinSCP to edit a file? If so, I am not sure of which file that should be.
Re: VLAN Tagging on VDSL port - ISP requirement
Sorry i keep missing your question about how to make these changes.
If you are comfortable with the correct syntax, then WinSCP and just the built in text editor is perfectly fine and probably faster.
If you are unsure of syntax, UCI is probably safer because it shouldn't let you make a syntax mistake.
The file will be /etc/config/network
If you are comfortable with the correct syntax, then WinSCP and just the built in text editor is perfectly fine and probably faster.
If you are unsure of syntax, UCI is probably safer because it shouldn't let you make a syntax mistake.
The file will be /etc/config/network
https://lantisproject.com/downloads/gargoylebuilds for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.
Please be respectful when posting. I do this in my free time on a volunteer basis.
Re: VLAN Tagging on VDSL port - ISP requirement
I haven't changed to this configuration yet, but I am about to. I just want to make sure that this is correct, and that the only change is that my VDSL port will be tagged as VLAN 100. I need everything else to function the same.Adri wrote:This might get you started:
You have to bind the pppoe protocol to the vlan interface eth0.100 and configure your switch to have a vlan 100 which tags traffic being send on the vlan.Code: Select all
config interface 'loopback' option ifname 'lo' option proto 'static' option ipaddr '127.0.0.1' option netmask '255.0.0.0' config globals 'globals' option ula_prefix 'REMOVED' config interface 'lan' option ifname 'eth1' option force_link '1' option type 'bridge' option proto 'static' option ipaddr '192.168.1.1' option netmask '255.255.255.0' option ip6assign '60' option dns 'REMOVED REMOVED' config interface 'wan' option ifname 'eth0.100' option proto 'pppoe' option username 'REMOVED' option password 'REMOVED' option keepalive '3 5' option ipv6 '0' option dns 'REMOVED REMOVED' option peerdns '0' config interface 'wan6' option ifname 'eth0.100' option proto 'dhcpv6' config switch option name 'switch0' option reset '1' option enable_vlan '1' config switch_vlan option device 'switch0' option vlan '1' option ports '0 1 2 3 4' config switch_vlan option device 'switch0' option vlan '100' option ports '5t 6t'
I plan on doing it via WinSCP as it's faster.
Re: VLAN Tagging on VDSL port - ISP requirement
Looks ok to me. I'd make a backup first, and be familiar with how to failsafe reset your router, just in case.
https://lantisproject.com/downloads/gargoylebuilds for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.
Please be respectful when posting. I do this in my free time on a volunteer basis.
Re: VLAN Tagging on VDSL port - ISP requirement
Thanks, I have changed the configuration but now it seems like my Gargoyle router is not interfacing with my bridged modem. Before I could set the router to DHCP (Wired), get a WAN-side IP address for the router from my modem, then change to PPPoE and all would be fine. The router manages LAN-side DHCP.Lantis wrote:Looks ok to me. I'd make a backup first, and be familiar with how to failsafe reset your router, just in case.
Now it seems like my router cannot get an IP address from my modem at all. Would something in the configuration affect this?
Here is my current setup:
Modem: 192.168.2.1 (static)
Router WAN: 192.168.2.2 (from modem DHCP)
Router LAN: 192.168.1.1
Update: I have just reverted to my original /etc/config/network file prior to these changes and I am getting a WAN IP address from the modem again. The issue seems to be related to this new configuration.
Re: VLAN Tagging on VDSL port - ISP requirement
Are you using the interface to make the change between DHCP and PPPoE?
If yes, it will override the settings you just changed more than likely
If yes, it will override the settings you just changed more than likely
https://lantisproject.com/downloads/gargoylebuilds for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.
Please be respectful when posting. I do this in my free time on a volunteer basis.