Version 1.3.13

The latest news about Gargoyle

Moderator: Moderators

Re: Version 1.3.13

Postby ruriruri » Fri Apr 01, 2011 6:07 pm

Upgraded from 1.3.10 to 1.3.13 via GUI. Runs much faster. Wireless LED working on WZR-hp-g300nh.

The port forwarding isn't working for me. Custom remote admin port isn't working.

Anyone else got the same problem?
ruriruri
 
Posts: 50
Joined: Mon Jun 14, 2010 10:42 am

Re: Version 1.3.13

Postby mix » Fri Apr 01, 2011 11:51 pm

keelerds wrote:I successfully upgrade 1.3.12->1.3.13, but had to use the mtd write method again. The GUI and sysupgrade didn't work. Do you think I'll have to go this route from now on?

I have a WRT54GL, v 1.1. Thanks.



I can confirm I am still having this same issue, with the same router, and the same version. Eric, is this really a free memory problem as others have speculated? You really don't notice this problem with builds on your own WRT54GL? The only Gargoyle features/settings I am using are Wireless DHCP and a different subnet. Everything else is the default setting that comes with the firmware.

I am able to write the firmware by connecting to the router with ssh and executing these commands in the shell:

cd /tmp
wget http://www.gargoyle-router.com/download ... uashfs.trx
mtd write gargoyle_1.3.13-brcm47xx-squashfs.trx linux

Eventually the shell will freeze, and I am no longer able to access the web interface or a new ssh session (though for some reason nat internet access through the router remains uninterrupted, and my original ssh session to write the firmware is never terminated). I wait about 5 minutes in this "mode" since I have no clue what is happening (probably nothing in actuality), then I manually pull the power plug to reboot it. Upon boot up the power led flashes rapidly for several minutes and then the router comes back to life, new firmware and all. All settings including password are reset to stock/default and need to be re-entered.
WRT54GL v1.1
Gargoyle 1.4.7
mix
 
Posts: 292
Joined: Sun Feb 27, 2011 11:18 am

Re: Version 1.3.13

Postby keelerds » Sat Apr 02, 2011 10:34 am

DoesItMatter wrote:
keelerds wrote:Currently 12.1MB / 13.1MB (92.1%). That is pretty typical. I see 96% sometimes. I don't think I've seen higher.

I bought the WRT54GL because I thought it would be the most reliable and stable. I sometimes wish I had a router with more memory though. Always being above 90% memory usage makes me nervous.


I think that is your issue right there.

When you update via the GUI, it loads it into memory

Since you only have 1MB left, it can't load the image into memory.

Safest way to upgrade is via TFTP.

You might want to consider sticking with 1.2.5 for the WRT54GL
Should be a bit better for memory management.

If you really want to stick with the WRT54G series, you may want
to consider modding it to add more flash/ram and/or look into
getting a WRT54G-TM - if they are still available somewhere.

4MB Flash / 16MB Ram is just not enough anymore sadly.

Thanks for the advice! I'm not committed to the WRT54G series, so I'm seriously considering a Buffalo WZR-HP-300NH. I think it was still a Work In Progress at OpenWRT when I bought the WRT54GL, but it's fully supported now (as you well know, judging by your sig).

I'm not sure I'm handy enough to mod my WRT54GL. The WRT54G-TM is a Work In Progress, so I'll stay away from that too.
http://wiki.openwrt.org/toh/start#linksys1

Over the past few weeks, I've sometimes lost wireless connection. The SSID still broadcasts, but my laptops can't connect. They get a Connection Timeout. The hard connections still work. Only rebooting seems to help. I wonder if I am hitting memory walls with the newest 1.3.x. Probably the easiest solution is a new router.
keelerds
 
Posts: 10
Joined: Wed Feb 09, 2011 8:37 am

Re: Version 1.3.13

Postby ruriruri » Sun Apr 03, 2011 2:46 am

Enable DMZ seems to stop individual port forwarding from working.
ruriruri
 
Posts: 50
Joined: Mon Jun 14, 2010 10:42 am

Re: Version 1.3.13

Postby Eric » Sun Apr 03, 2011 11:55 am

mix/keelerds: I forgot to mention it in the initial post, but this version (1.3.13) also goes back to doing the upgrade the old way on broadcom routers. If you're still having problems it probably is a memory issue of some sort like what DoesItMatter is suggesting.

ruriruri/k1nd: Thanks for reporting the port forwarding/DMZ issue, and the issue with UPNP. I will look into these issues. These probably popped up now because the OpenWrt vesion got bumped in this release and the new version of OpenWrt has a new firewall implementation.
Eric
Site Admin
 
Posts: 1369
Joined: Sat Jun 14, 2008 1:14 pm

Re: Version 1.3.13

Postby mkc2lr » Sun Apr 03, 2011 2:53 pm

1.3.13 is great !!!!!
I first tried 1.3.10 for my client bridge, but it was not stable. With 1.3.12 there was no improvement.
1.3.13 is completely different. I can see a significant improvement in speed and stability !!!! Thank you !
mkc2lr
 
Posts: 11
Joined: Thu Feb 24, 2011 3:17 pm

Re: Version 1.3.13

Postby 1an » Mon Apr 04, 2011 12:42 am

Eric and development team,

It looks as though the links for restriction.sh and port_forwarding.sh have gone awol from the Firewall tab on the left side of the browser GUI router interface (checked with firefox 3.6 and IE6)

They are still accessible from the browser URL.

I'm using Buffalo wzr-hp-g300nh,
same in WRT54GL

Ian
Buffalo WZR-HP-G300NH = Gargoyle 1.5.3
Linksys WRT54GL v1.2 = Gargoyle 1.3.13
SMC Barricade SMC2804WBRP-G = SMC firmware v2.08
1an
 
Posts: 41
Joined: Wed Aug 11, 2010 7:18 am
Location: Australia

Re: Version 1.3.13

Postby paescu » Mon Apr 04, 2011 12:05 pm

installed 1.3.13 on WNDR3700 yesterday (from latest stock firmware) - configured from scratch - working great so far - thanks for this release Eric! - here are a few things I noticed (not done exhaustive testing yet):
- enabled UPNP -> bandwidth graphs where empty - disable UPNP -> graphs where back. (have to confirm with more testing)
- wifi (trying to get 40MHz, got "HT40 secondary channel 15 not allowed" and "20/40 MHz operation not permitted on channel pri=7 sec=11 based on overlapping BSSes" - had to change to channel e.g. 7 and add "option 'noscan' '1'" - working great now.. - will do more testing as I get to it.
paescu
 
Posts: 3
Joined: Mon Apr 04, 2011 11:49 am

Re: Version 1.3.13

Postby Polki » Tue Apr 05, 2011 12:22 am

Installed yesterday and am having problems with port forwarding not working. Was working fine on 1.3.12-restarttest version.

I did restore settings from a back up I made before the upgrade, maybe causing issues however I dont want to set up from fresh install as i dont want to loose all my flat mates data usage etc.

EDIT: Sorry should have said I have a TP-Link wr1043nd

Vance
Polki
 
Posts: 6
Joined: Thu Mar 24, 2011 6:25 pm

Re: Version 1.3.13

Postby DoesItMatter » Wed Apr 06, 2011 6:58 am

Polki wrote:I did restore settings from a back up I made before the upgrade, maybe causing issues however I dont want to set up from fresh install as i dont want to loose all my flat mates data usage etc.

Vance


It should not matter jumping up from 1 version and restoring
a backup configuration file - that usually works ok.

I would be hesitant on reloading an old config if you jumped from
say 1.3.5 -> 1.3.10 in 1 upgrade, and then reloaded the config.
You could have issues at that point - you shouldn't, but there
could be issues.

Also look at the main release info and see if Eric announced a
major change in the code - those are usually better handled
by re-configuring from scratch and NOT loading an old config.

So, if you have to keep data til end of month, probably shouldn't
upgrade to one of those major change versions until you can
re-configure from scratch.
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.376.48
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.6.2
Linksys E3000 = Toastman Tomato USB 1.28.7505
TP-Link WR1043ND V1.8 - OpenWRT Trunk 43375
Engenius - ESR900 Stock 1.4.0
User avatar
DoesItMatter
Moderator
 
Posts: 1335
Joined: Thu May 21, 2009 3:56 pm

PreviousNext

Return to News

Who is online

Users browsing this forum: Bing [Bot] and 3 guests