TP-Link MR3420 - 3g Dongle problem

Report wireless and/or network connectivity problems in this forum.

Moderator: Moderators

TP-Link MR3420 - 3g Dongle problem

Postby jorgemiguel4 » Thu Dec 29, 2011 2:24 pm

Hello, Im trying to setup a 3G USB dongle( ZTE MF622) on my MR3420 but it isn't detected.

Code: Select all
root@Gargoyle:~# ls /dev/
console             mtd3ro              null
cpu_dma_latency     mtd4                port
full                mtd4ro              ppp
kmsg                mtd5                ptmx
log                 mtd5ro              pts
mem                 mtdblock0           random
mtd0                mtdblock1           shm
mtd0ro              mtdblock2           tty
mtd1                mtdblock3           ttyS0
mtd1ro              mtdblock4           urandom
mtd2                mtdblock5           watchdog
mtd2ro              network_latency     zero
mtd3                network_throughput



Some help please

I'm sorry about my english...


Edit: I'm now on version 1.5.2 but already tried 1.4.5 and 1.5.1 without luck.
jorgemiguel4
 
Posts: 85
Joined: Thu Dec 29, 2011 2:17 pm

Re: TP-Link MR3420 - 3g Dongle problem

Postby DoesItMatter » Thu Dec 29, 2011 3:56 pm

http://wiki.openwrt.org/toh/tp-link/tl-mr3420

The MR3420 only has 4 MB of flash

You may not be able to use Gargoyle with additional packages.

What you should try first is getting OpenWRT 10.03.1 working with it
then install the USB addon packages and see about getting
your USB dongle working like that

Once that works, you MIGHT be able to do the same thing
with Gargoyle - but again, not sure if you have enough flash space.

Also - use 1.4.5 for any testing, don't bother with 1.5.2 yet until
you can get your USB dongle configured and working
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.6.2
Linksys E3000 = Toastman Tomato USB 1.28.7505
TP-Link WR1043ND V1.8 - OpenWRT Trunk 42345
Engenius - ESR900 Stock 1.2.2
User avatar
DoesItMatter
Moderator
 
Posts: 1333
Joined: Thu May 21, 2009 3:56 pm

Re: TP-Link MR3420 - 3g Dongle problem

Postby jorgemiguel4 » Thu Dec 29, 2011 4:33 pm

Is it possible to install Gargoyle in a flash drive like OpenWrt? Can I follow the backfire tutorial for Gargoyle? -> http://wiki.openwrt.org/doc/howto/extroot

In OpenWrt 3G works well... but I loved the Gargoyle's Active Congestion Control
jorgemiguel4
 
Posts: 85
Joined: Thu Dec 29, 2011 2:17 pm

Re: TP-Link MR3420 - 3g Dongle problem

Postby DoesItMatter » Thu Dec 29, 2011 5:59 pm

Maybe, you can be the first to try!

Not sure how Gargoyle / OpenWRT works with a USB hub though

You only have 1 USB port on that router right?

So you'd need a USB hub that would allow the USB dongle
plus your USB flash drive connected at the same time
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.6.2
Linksys E3000 = Toastman Tomato USB 1.28.7505
TP-Link WR1043ND V1.8 - OpenWRT Trunk 42345
Engenius - ESR900 Stock 1.2.2
User avatar
DoesItMatter
Moderator
 
Posts: 1333
Joined: Thu May 21, 2009 3:56 pm

Re: TP-Link MR3420 - 3g Dongle problem

Postby jorgemiguel4 » Fri Dec 30, 2011 9:50 am

Yes, you are right. I only have one USB port. I will buy a USB hub to try it.

But the major problem is that this router don't have enough space to install USB drivers with Gargoyle, so I can't use a external Flash.

Is there a way to delete all gargoyle stuff and reinstall again?
jorgemiguel4
 
Posts: 85
Joined: Thu Dec 29, 2011 2:17 pm

Re: TP-Link MR3420 - 3g Dongle problem

Postby DoesItMatter » Fri Dec 30, 2011 2:58 pm

If you delete all the Gargoyle stuff, all you are left with is OpenWRT

You might as well just try OpenWRT 10.03.1 - flash that on your router
and see if you have enough space to get the stuff running.

If you still don't have enough space, your only option is to try and
compile your own builds and remove some things, then add in the
USB driver stuff.

Otherwise, look for a new router with 8MB+ flash
:twisted: Soylent Green Is People! :twisted:
2x Asus RT-N16 = Asus 3.0.0.4.374.43
2x Buffalo WZR-HP-G300NH V1 A0D0 = Gargoyle 1.6.2
Linksys E3000 = Toastman Tomato USB 1.28.7505
TP-Link WR1043ND V1.8 - OpenWRT Trunk 42345
Engenius - ESR900 Stock 1.2.2
User avatar
DoesItMatter
Moderator
 
Posts: 1333
Joined: Thu May 21, 2009 3:56 pm

Re: TP-Link MR3420 - 3g Dongle problem

Postby jorgemiguel4 » Fri Dec 30, 2011 4:06 pm

Success :D

Code: Select all
        _______                     ________        __
       |       |.-----.-----.-----.|  |  |  |.----.|  |_
       |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
       |_______||   __|_____|__|__||________||__|  |____|
                |__| W I R E L E S S   F R E E D O M

----------------------------------------------------------------
|                                                              |
| OpenWrt Backfire 10.03.1                                     |
| Wersja OpenWrt: 29608                                        |
| Zbudowano: 2011-12-27 15:15 CET                              |
|                                                              |
| Cezary Jackiewicz (obsy), http://eko.one.pl                  |
|                                                              |
----------------------------------------------------------------
root@Gargoyle:~$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 1792      1792         0 100% /rom
tmpfs                    14804      1968     12836  13% /tmp
tmpfs                      512         0       512   0% /dev
/dev/sda1                60725      8277     49313  14% /overlay
mini_fo:/overlay          1792      1792         0 100% /
root@Gargoyle:~$
jorgemiguel4
 
Posts: 85
Joined: Thu Dec 29, 2011 2:17 pm


Return to Network / Wireless Issues

Who is online

Users browsing this forum: No registered users and 1 guest